Me paso a Debian y tengo problemas.


  • 0

    Hola a todos,

    Este mediodía me he cargado el archivo xorg (sin copia de seguridad, naturalmente :rolleyes: ) y no he conseguido arreglarlo. Como mi copia de Kubuntu 7.04 la tiene un amigo y tengo aquí Debian 4.0, he decidido dar el paso y meter Debian en el PC.

    Todo ha ido bien, he conseguido instalar KDE sin grandes problemas, he puesto unos cuantos repositorios (si hay más que sean interesantes, decídmelo por favor)

    deb http://ftp.es.debian.org/debian/ etch main contrib non-free
    deb-src http://ftp.es.debian.org/debian/ etch main contrib non-free

    deb http://security.debian.org/ etch/updates main contrib non-free
    deb-src http://security.debian.org/ etch/updates main contrib non-free

    deb http://www.debian-multimedia.org/ etch main

    y he instalado la mayoría de programas que suelo usar habitualmente.

    El mayor problema me ha venido al instalar iceweasel (firefox para Debian), el tipo de letra permanece inalterable, aunque le haya instalado varios tipos de letra nuevos y haya cambiado la configuración en las preferencias. He buscado en google y he encontrado a varias personas con el mismo problema, pero no he encontrado ninguna respuesta. ¿Alguién sabe algo?

    Otro problema lo he tenido al instalar amsn, en los repositorios sólo viene la versión 0.95 y quiero la 0.97 (hay un gran cambio), así que me he decidido a instalarla "a pelo". He ido metiendo las dependencias hasta que he metido libjpeg y amsn sigue sin reconocerlo. Luego os diré exactamente lo que me aparece, ahora tengo que irme.

    Gracias por la ayuda.



  • 1

    No se si es este: gtk-qt-engine

    En el centro de control, en apariencia, tiene que salir una opcion de "GTK styles and fonts"…

    Prueba a ver...

    EDITO: Sobre lo del amsn no te puedo decir nada, excepto que kopete (para mi) cumple a las 1000 maravillas su cometido
    EDITO2: se me ha olvidado comentarte que yo actualizaria a testing... en nuestras arquitecturas es 100% estable y los paquetes estan un poco mas actualizados... por ejemplo en testin tenemos: amsn Version: 0.96+dfsg1-2 (i386)



  • 2

    Muchas gracias, me ha ayudado mucho. Ahora el estilo es como el del resto del escritorio. Solo falla la letra, la tipografía sigue sin ir correcta del todo, pero puedo cambiarla en parte. El tamaño sólo puedo cambiarlo desde editar-tamaño del texto-aumentar o disminuir y el tipo de letra lo tengo que elegir en las opciones, no permite que lo elija la página web.

    En cuanto al amsn, me ha ido pidiendo paquetes varios al hacer ./configure. libpng y libjpeg han sido los 2 últimos. Los he tenido que instalar "a pelo" también, no los tengo en los repositorios.El último, libjpeg, no lo he encontrado como tal, sino que tengo la versión libjpeg-6b (que debería ser la misma según lo que he leído). Lo instalo y el configure de amsn me lo sigue pidiendo. ¿Alguna idea? Sino me tendré que pasar a otro messenger, pero me gustaba el 0.97 que tenia instalado en Kubuntu, bonito y con muchísimas opciones.

    EDIT: He usado la 0.95, la 0.96 y la 0.97. No hay color, con la 0.97 ha habido un reestyling completo y es muchísimo más bonito y mejor. Ah, y por ahora me quedaré en la estable, la verdad es que quiero experimentar lo que es un SO sin ningún problema (Ubuntu era una mejora con respecto a Windows, pero distaba de ser estable).



  • 3

    Instala estas fuentes:

    xfonts-75dpi
    xfonts-100dpi
    xfonts-75dpi-transcoded
    xfonts-100dpi-transcoded
    xfonts-base-transcoded
    msttcorefonts

    Te aseguro que testing es igual de estable de la mismisima version "stable" para i386

    PD: estas son las dependencias para la version de testing:
    Depends: tcl8.4, tk8.4, tcltls, python, libc6 (>= 2.5-5), libgcc1 (>= 1:4.1.2), libice6 (>= 1:1.0.0), libjpeg62, libpng12-0 (> = 1.2.13-4), libsm6, libstdc++6 (>= 4.1.2), libx11-6, zlib1g (>= 1:1.2.1)



  • 4

    Fuentes instaladas y problema menor que antes, pero sigue sin ir bien del todo. Los tipos de fuente ya puedo cambiarlos, pero el tamaño va un poco a su rollo (tengo que hacer ctrl++ o ctrl– casi en cada página en la que entro) y sigue sin aceptar el tipo de fuente que elija la página, siempre coge el que yo tengo elegido por defecto.

    Todas esas dependencias las tengo cubiertas, no se que me puede estar fallando, la verdad.



  • 5

    Puedes bajarte el paquete del aMSN 0.97 para Ubuntu o Debian sid e instalarlo con GDebi o dpkg. Cuando una versión superior entre en los repositorios de Debian etch, lo actualizas sin más.

    Si te pide algún paquete en una versión superior a la que tienes, haces lo mismo, con cuidado de que no entre en conflicto con otros paquetes importantes.

    PD: aMSN 0.97 para Debian sid



  • 6

    Con respecto a las fuentes, te sugiero instalar el paquete msttcorefonts, que te instalará las fuentes oficiales de Microsoft (Tahoma, Verdana, Coooomic Sans jeje…). Puede que muchas webs no se vean igual porque tienen el tipo de letra forzado y al buscar un equivalente en el sistema cambie el tamaño.

    En cuanto al amsn, si no quieres pasar a testing (es una puta roca, después de un año y viniendo de Gentoo) tienes varias soluciones. La más limpia creo que será bajarte el paquete a pelo en tu directorio personal ya que se puede ejecutar en local y sin instalar. Al ser un lenguaje interpretado no tendrás que compilar nada a no ser que uses algún plugin especial. Por lo demás, una vez descomprimido, puedes lanzar el ejecutable con wish delante (por ejemplo "wish amsn" dentro del directorio del ejecutable).

    Sé que lo de amsn no es muy ortodoxo pero prefiero hacer eso antes que ir guarreando el sistema sobreescribiendo paquetes de las ramas oficiales. Cuando cambies de versión, borras el directorio y vuelta a empezar.



  • 7

    Al final, despues de muchos problemas de dependencias, he decidido pasarme a testing. La operación ha sido más o menos sencilla, sólo falla al actualizar dpkg y dpkg-dev porque, según apt-get, la firma md5 no coincide. Supongo que será un problema del repositorio y que lo arreglarán en breve. También he instalado amsn 0.96, espero que pronto lo actualicen a 0.97, en mi opinión merece mucho la pena.



  • 8

    ¿Lo que falla es la firma md5 o la gpg? Si es lo último, puede que se solucione actualizando el paquete debian-keyring.

    Yo llevo más de un año con testing y te aseguro que es muy estable, no creo que te arrepientas.

    La versión 0.97 de amsn ya está en sid, así que no creo que se haga esperar mucho en testing.



  • 9

    El mensaje es el siguiente

    Des:1 http://ftp.es.debian.org testing/main dpkg 1.14.5 [2067kB]
    Descargados 2067kB en 1s (1244kB/s).
    E: Se produjo un fallo al descargar http://ftp.es.debian.org/debian/pool/main/d/dpkg/dpkg_1.14.5_i386.deb: La suma MD5 difiere
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias

    Por si acaso he instalado debian-keyring, pero no me soluciona nada. Por el momento, con testing el sistema va aún más rápido (y eso que estaba encantado despues de pasar por la lentitud de Kubuntu) y es perfectamente estable.

    No he conseguido solucionar los problemas de las fuentes, pero por lo demás estoy más que satisfecho. Muchas gracias.



  • 10

    http://packages.debian.org/lenny/iceweasel

    Ahí pone que sugiere como dependencia el paquete iceweasel-gnome-support, quizás fuera de gnome te solucione algunos aspectos gráficos, sólo te lo digo por probar.

    También recomienda latex-xft-fonts pero también te lo digo por probar.

    ¿Has usado Konqueror? Yo prefiero Firefox pero Konqueror es el gran desconocido, se integra a la perfección con KDE y funciona realmente bien.



  • 11

    Ya he encontrado los primeros efectos secundarios de haberme pasado a testing, Iceweasel me abre mal algunas páginas, con "textos" como los siguientes:

    Esas páginas las tengo que abrir con el Konqueror y no me dan ningún problema. He reinstalado las fuentes y no ha habido mejora.



  • 12

    ¿has hecho un dist-upgrade completo? ¿has hecho un dpkg-reconfigure iceweasel?

    por preguntar na más jeje :)



  • 13

    El dist-upgrade estaba hecho, pero el dpkg-reconfigure iceweasel no. Lo he hecho, he reiniciado iceweasel y no hay cambios. De hecho, he escrito "hardlimit.com" sin las "www" y me han salido todos los caracteres en chino o lo que sea eso. Luego he puesto "www.hardlimit.com" y se ha cargado bien. Creo que esos caracteres los da sólo cuando carga algún componente flash, voy a ver si consigo averiguar algún dato más.



  • 14

    Solución por las bravas. "aptitude remove –purge iceweasel", luego borrar la carpeta .mozilla de mi /home y reinstalar todo. Habiendo guardado copias de seguridad, claro. Lo de los caracteres raros está arreglado, falta sólo el que se vean bien los tipos de letra.

    ¿Alguién podría enseñarme el siguiente pantallazo? está en preferencias->contenido->tipos y colores->avanzadas.

    Así puede que sepa qué es lo que tengo mal. Gracias.



  • 15

    Aquí tienes la mía:



  • 16

    Cuando ayer dije que ya iba mejor, iceweasel se empezó a cerrar automáticamente, en cualquier página en la que entrara. Como despues de tantos problemas no habia conseguido dejarlo bien y todavía no habia volcado la copia de seguridad, decidí volver a formatear y empezar de cero.

    Me ha costado más de lo que pensaba (cada vez que instalaba las X se bloqueaba), pero ahora parece que todo funciona. Bueno, no todo, amsn antes se me ha bloqueado, veremos si ahora consigo que funcione.



  • 17

    No se MonXP, parece que te esta dando muchos mas problemas de los debidos Debian…

    A mi ya te digo que en testing, no he tenido ni un solo problema (algun fallo ocasional, pero nada raro)...



  • 18

    Ya me he dado cuenta, puede ser que la placa base esté muriendo, sólo lleva 5 años conmigo la pobre (estará amortizada? ;)). Puede que haya llegado la hora de comprarme un C2D baratito y overclockearlo al máximo que me permita un silent-pc.

    Voy a probar una temporada con la configuración tal y como la tengo (diría que lo tengo todo bien puesto ya, sonido, codecs multimedia, programas que uso, etc). Si me sigue dando problemas, equipo nuevo y a correr.



  • 19

    Es un AthlonXP el micro? porque de ser así lo has amortizado bien bien, pues un paso de gigante ya sería pillarte un E2140/60 con unas DDR2-667.





Has perdido la conexión. Reconectando a Hardlimit.