Prueba y compara el rendimiento de tu PC con nuestro banco de pruebas.

No me detecta el lector DVD como DVD, si no como CDROM



  • Buenas, tengo dos lectores, uno de CD (k es una gravadora) i un lector DVD normal i corriente, marca Pioneer.

    Cuando carga el kernel me detecta k es un DVD, bueno pone el modelo i esas cosas, pero en /dev/ no existe el modulo "dvd" me pilla dos lectores de CD….k raro.

    Se tiene k hacer algo pa decirle k es un DVD?? tengo algun archivo mal configurado?

    Eske me instale el XINE para ver DVD's pero no puedo ya k no me detecta el "/dev/dvd", como lector de cd's el DVD funciona correctamente.

    Salu2! i gracias!



  • Tranquilo, si es DVD te lo pillará como DVD aunque el dispositivo se llame /dev/cdrom2 o algo así.

    El caso es que /dev/cdrom y similares son enlaces simbólicos a /dev/hdX 🆒

    Dile a Xine que use /dev/loqueseacomosellameeldvd 😉



  • Esto es lo que me sale a mi en el arranque:

    scsi1 : SCSI host adapter emulation for IDE ATAPI devices
    Vendor: CREATIVE Model: DVD5241E Rev: 0.45
    Type: CD-ROM ANSI SCSI revision: 02
    Attached scsi disk sda at scsi0, channel 0, id 0, lun 0

    En mi caso lo detecta como SCSI porque tengo activa la emulacion para poder copiar on-fly del lector a la grabadora… ahora que pienso eso ya no me hace falta porque ambos son SCSI, pero bueno... esta puesto desde hace tiempo.

    El /dev/dvd al que tu haces referencia, no es mas que un enlaze simbolico al sr2 como devia Mystix, que es donde me detecta el dvd:

    homer [root]:~# file /dev/dvd
    /dev/dvd: symbolic link to sr2



  • Ok gracias, es logico lo k deciis 😛 no se me ocurrio pq como tambien el logico k fuera el modulo /dev/dvd pues…jejej

    Bueno ok, esta tarde lo pruebo a ver k tal 🙂

    Gracias i hasta la proxima!!



  • buenas, he cambiado la unidad por /dev/cdrom k es el lector DVD, i no furrula, no hace nada, yo siento como lee en dvd pero no hace nada…no me da ningun error tampoco, si le digo cdrom1 entonces me dice k hay un error (normal :D) pero si le pongo bien el nombre no me dice nada...

    k puede pasar??

    lo del "dvd_raw_device"?? k es??

    le he puesto tambien "dev/cdrom" (el DVD)...

    Bueno a ver....:(



  • Buenas, al final leyendo el FAQ del programa, vi k me tenia k meter algunos plugins o algo mas, pero luego me dijo k el plugin k usaba no podia reproducir DVD's encryptados (o sea todas las pelis normales 😞 ) sabeis si hay alguno k lo soporte, o algo?

    Enga gracias.



  • http://www.videolan.org En esta pagina encontraras el reproductor vlc, no lo uses si no quieres aunque yo es el que gasto (me gusta mas que el vlc por las features que tiene pese a ser menos vistoso), pero lo realmente bueno de la pagina es que te explica que librerias necesitas, tales como las libdvdread para leer los dvd's, las libdvdcss para leer los encryptados… etc. Eso si... espero que te guste leer. 🙂

    Un saludo.



  • Pero si eso ya lo tengo puesto 😞 bueno , me lo volvere a poner a ver k tal…



  • Haber si te puedo ayudar:

    Vete a la página http://www.mplayerhq.hu y

    -baja la última versión del Mplayer

    -baja un Skin, el que más te guste

    -bajaté tambien unas fuentes por si quieres subtítulos.

    -como root y en el directorio que quieras descomprimes el Mplayer:
    tar jxvf MPlayer-09xxxxx.tar.bz2
    -entra en el directorio que te ha creado la descompresión
    cd MPlayer-0.9xxxxx
    ./configure –enable gui
    make
    make install
    -Una vez compilado el Mplayer descomprimes el Skin de igual manera
    tar jxvf nombre_del_Skin.tar.bz2
    -crea con mkdir el directorio default
    mkadir /usr/local/share/mplayer/Skin/default/
    -mueve el Skin a el directorio default
    mv ./nombre_del_Skin/* /usr/local/share/mplayer/Skin/default/
    -haz esto mismo con las fuentes, aunque creo recordar que el directorio, fonts, ya estaba creado
    mkadir /usr/local/share/mplayer/Skin/fonts etc...

    Si todo te ha ido bien, eso espero, veras los DVDs, VCDs, DivX ....

    Se me olvidadba, si por casualidad te diera algun tirón el video al reproducirlo, no es cosa del Mplayer es que necesitas bajarte los drivers de NVIDIA para Linux y meterselos.

    Salu2



  • todo esto yasta hecho, en una revista te enseñavan un monton de cosas para meter, codecs i demas….ta bien.

    La cuestion eske todo esto ya lo tengo, pero no se me ve el DVD...

    Para verlo en el mplayer es:

    mplayer -dvd

    ??? 😕

    Salu2!



  • Pues no se si como tu dices funciona, yo utilizo:

    mplayer -gui -vo Xv -zoom

    Salu2



  • Se me olvidadba, si te falla con Xv prueba:

    mplayer -gui -vo x11

    si lo dejas así, se te verá en una ventana, si le añades

    -zoom, se te verá en pantalla completa

    Salu2



  • MPlayer 0.90rc2-3.2 (C) 2000-2002 Arpad Gereoffy (see DOCS)

    CPU: Advanced Micro Devices (Family: 6, Stepping: 0)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
    Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

    Reading config file /usr/local/etc/mplayer/mplayer.conf
    Reading config file /home/marcalj/.mplayer/config
    The gui option can't be used on the command line

    No se, alomejor no tengo bien configurado lo del gui en el mplayer.conf…

    K puede ser si no?



  • Puede ser que no lo hayas instalado con gui (hay que leer los README, que esto no es Windows)
    ./configure –enable-gui (para el gui) --enable-lirc (para el mando a distancia de la avermedia) --language=es (spanish ole!) --disable-rtc (error que da cuando lo abres si no tienes el kernel compilado con rtc)
    😉



  • marcalj, como te dice Orko, es bueno leerse los Readme, pero por si tenías, al igual que yo problemas con el inglés, por eso te puse el post de más arriba.
    El problema es casi seguro que te viene del Skin, te ponía que crearas el directorio default y me da la impresión de que no lo tienes ni creado, compruebalo haber si estoy equivocado.
    /usr/local/share/mplayer/Skin/default/
    dentro deberas de tener bastantes ficheros .png, si los tienes vuelve a compilar el mplayer tal y como te lo posteaba y si quieres las ayudas en español, como decía Orko:
    ./configure –enable-gui --language=es

    De todas formas y repasando el post me he dado cuenta de que en --enable gui, le falta un guión, o sea que es --enable-gui
    Venga, animate que va de cine y eso que yo tengo una TNT2 de 3000 pelas



  • Buenas chicos, gracias por el interes.
    Queria aclarar unas cosas…el mplayer lo uso perfectamente, me da igual tener el gui o no, yo normalmente veo los videos pelis etc perfectamente, en pantalla completa (por defecto) ya k tengo conectado el TVOut en la tele i veo las pelis alli a la perfeccion.

    Yo simplemente decia k no podia ver los DVD's originales. Si vosotros me deciis k sin el gui no se pueden ver pos vale, lo vuelvo a compilar i listos, pero si no es imprescindible pues me da igual tenerlo o no, yo prefiero no tenerlo, con las teclas ya me aclaro i yas estoy acostumnbrado.

    Por lo de las librerias ya las tengo todas instaladas, pero sigo sin poder ver los DVD's.

    Enga gracias chicos. Que me deciis ahora? 😞

    Salu2!



  • bueno un colega me dijo k hiciera un link:

    ln -s /dev/cdrom /dev/dvd

    I en el mplayer puedo ver los DVD's poniendo:

    mplayer -dvd 1 -alang es

    No se pq no me va con el Xine…vaya paranoias.

    Lo k pasa eske va a trompicones a veces...no hay forma de solventarlo??


Accede para responder