Prueba y compara el rendimiento de tu PC con nuestro banco de pruebas.

Archivos de configurar la red



  • aber si me podeis ayudar…que nose ke ostias ando:susto:
    Al intalar gentoo nose como e conseguido que andara la red...baje los src de instalaccion...
    Pero despues de instalar ahora no anda..:muerto:
    en la instalaccion con el comando net-setup se configuraba las ip,gateway…pero ahora no anda,ese comando...para configurar:nono:

    Y los archivos de configuraccion son diferentes que en debian..y no se cuales hay que mirar...

    /etc/config.d/net aqui parece que estan las ip,gateway..
    /etc/hosts este para que es?
    /etc/resolv.conf el dns

    Configurando esos archivos tendria que ir no?

    aber como esplico...
    si pongo en hosts
    172.26.0.3 localhost

    y ago..
    #insmod nvnet
    #ping localhost
    y me hace ping..
    #ping 172.26.0.1(router)
    no hace...

    alguna idea.. para este newbie:rolleyes:

    Un saludo y gracias.



  • Tienes el módulo de tu tarjeta de red cargado??? a ver si es q no te levanta la interfaz eth0 (tiene más pinta de eso que de estar mal configurado)

    No es igual q en debian, pero no será muy diferente

    aber como esplico…
    si pongo en hosts
    172.26.0.3 localhost

    y ago..
    #insmod nvnet
    #ping localhost
    y me hace ping..
    #ping 172.26.0.1(router)
    no hace...

    en /etc/hosts sólo debes tener algo así:
    josefu@kaligula:~$ cat /etc/hosts
    127.0.0.1 localhost
    x.x.x.x nombre_de_la_maquina

    en las x.x.x.x iria la ip de tu equipo.
    Lo de la direccion 127.0.0.1 localhost es un convenio para denominar a la própia máquina.



  • yo tengo gentoo instalada, y te digo como hago

    modprobe 8139too (ese es el modulo de mi tarjeta de red)
    net-setup eth0 (elijo que lo haga en dhcp)

    para probar si va o no vva no hago ping pq cuando no me iba se le iba la olla, yo simplemente abro una pagina con lynx

    pero no necesitas mas historias para la red, bueno pones el modulo de tu tarjeta o sino prueba con todos los modulos a ver cual va
    ya podras hacer los emerge y eso
    yo de todos modos tengo apuntado en una hoja lo que pone en el manual, pero puedes hacer otra cosa
    metes un passwd
    passwd
    y escribes la contraseña para root
    entras a otro login con alt+f y desde hay haces: lynx www.gentoo.org/doc/es/gentoo-x86-install.xml
    y tendras el manual de instalacion, en castellano, asi puedes seguir los pasos (bueno yo ya me los se jejeje)



  • /etc/network/interfaces

    ese es el archivo de configuracion de los dispositivos de red.

    Si ejecutas el comando ifconfig te saldra tu configuracion actual.

    este es mi fichero de interfaces a ver si te sirve de algo:

    _

    The loopback interface

    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet static
    address 172.16.0.10
    netmask 255.255.0.0
    broadcast 172.16.0.255
    gateway 172.16.0.1

    auto eth1

    iface eth1 inet static
    address 192.168.0.10
    netmask 255.255.255.0
    _

    una vez q lo cambies te vas a /etc/init.d
    y ejecutas ./networking restart y se aplican los cambios 🙂

    Yo uso una debian quizas cambien algunos archivos 😛



  • Y los archivos de configuraccion son diferentes que en debian..y no se cuales hay que mirar…

    como dige…los archivos son diferentes doice pero gracias de todos modos.

    :susto: e instalau otra vez gentoo….:rolleyes: y con el cd de instalaccion te detecta la targeta de red de nforce..net-setup eth0...rellenas ip,gateway...y todo funciona.

    despues de la instalacion ...cargo el modulo nvnet y nada...😕

    modprobe 8139too (ese es el modulo de mi tarjeta de red)
    net-setup eth0 (elijo que lo haga en dhcp)

    despues de instalar gentoo el comando net-setup ya anda?? porke a mi no me anda koenigsegg

    Un saludo.



  • bueno ya lo e puesto…habia ppuesto la ip mal...:rolleyes: menudo paquete ke soy.

    para poner gentoo en espainol que hay que hacer?

    y el comando para buscar paquetes cual es?por ejemplo en debian era..apt-cache search noia..como?

    un saludo.



  • ya vas mas adelantado que yo, yo solo lo he instalado, he metido el xfree y kde pero no lo he echo andar, eso si, noto diferencia… y mucha
    yo tengo algun problema con el kernel, y no he puesto al red
    lo de instalar algo es con emerge, haces man emerge o sino en la web de gentoo tienes en español manual de como funciona este sistema, pero para uqe tengas para rato haces emerge kde y estaras unas horas con eso jejejeje
    para poner en español si has metido la rc4 (la meti ayer) no tep regunta lo del teclado, vas a /etc/rc.conf y escribes donde te pone lo del teclado, sustituyes us por es y ya tendras teclado español

    a mi me da varios errores mas, pero y mirare estoy de examenes, y no me sobra el tiempo

    por cierto, si quiero usar dhcp que ip tengo que poner en el /etc/hosts ?? pq creo que puede ser eso lo que no meva, y a que he recompilado eln ucleo y he añadido soprote para ext3 (antes no lo hize) para la tarjeta de red y algo mas, perome sigue diciendo que me falla algo de DEVFS y no he visto ninguna opcion ni nada
    aparte tengo mas cosas que hacer pero no voy a agobiar de moemnto jejejeje



  • por cierto, si quiero usar dhcp que ip tengo que poner en el /etc/hosts ?? pq creo que puede ser eso lo que no meva, y a que he recompilado eln ucleo y he añadido soprote para ext3 (antes no lo hize) para la tarjeta de red y algo mas, perome sigue diciendo que me falla algo de DEVFS y no he visto ninguna opcion ni nada

    hosts yo no e tocado para nada y funciona,…editas el fichero /etc/config.d/net y descomentas la linea que pone dhcp.

    y lo de montar particion ami tambien me da error...pero bueno..no hay prisa:D

    Un saludo.



  • te cuento lo de la particion, cuando compilas el kernel, yo para no perder tanto tiempo compile el kernel sin modificar nada, lego me di cuenta que si intentaba montar cualquier unidad ya fuese la boot en ext3 o una fat32 no me dejaba pq eso no estaba en el kernel, pues bueno, voy compilo el kernel con esos sistemas de ficheros que me interesan, pero claro no podia pasarlo a la particion boot pq no podia montarla, pues simplemente copie la imagen desde mandrake y listo
    pero tienes que recompilar el kernel, tb de paso elije tu tarjeta de sonido, l grafica…. la emulacion scsi y lo que necesites


Accede para responder