Preguntas de Debian/unstable


  • 0

    weno gente, despues de estar 1 semana con debian stable y estar hasta las pelotas de no poder meter cosas y despues haber jodido los modprobe( o como se llame):rolleyes: , he reinstalado Debian…

    Weno, he hecho la instalacion y cuando me pregunto si iniciar tasksel y dselect, le dije que no, para cambiar los sources y ponerlos a "unstable"
    Despues he hecho apt-get update-->apt-get dist-upgrade-->ap-get upgrade

    haciendo apt-get upgrade, me dice que hay un error en el source security....unstable(que antes era stable, pero lo he cambiado)LO debo vlver a poner a stable, o que??

    weno, ademas de esto he mirado si por alli hay el KDE 3.1.1 o 3.1.2 con apt-cache search....pero nada.Solo existe un KDE y no tengo ni warra cual es:D

    pues eso, el la web de KDE he visto eso, pero solo es para instalarlo en stable:
    deb http://download.kde.org/stable/3.1.2/Debian stable main

    hay algun source como este, pero para unstable o basta con cambiar solo stable por unstable??

    entonces, cuando instalo el KDE, despues que tengo que hacer, solo configurar las X con lo de dpkg-reconfigure xserver-xfree86??

    o ademas tengo que hacer algo con kdm y ese rollo….

    joer, esq esto es un como lioso:P
    me toy hartando y un poco, pero espero que alguien me pueda ayudar....por eso pongo aki un post:P

    weno, espero que me compendais, sino me odo:D

    enga, un saludo
    the ruNNer

    PD: para usar KDE 3.1.1 tengo que tener instalado el gcc-3.3 y XFree 4.3??algo mas??gracias:|



  • 1

    haciendo apt-get upgrade, me dice que hay un error en el source security….unstable(que antes era stable, pero lo he cambiado)LO debo vlver a poner a stable, o que??

    No utilices el source de security debian, simplemente borra la entrada de sources.list

    weno, ademas de esto he mirado si por alli hay el KDE 3.1.1 o 3.1.2 con apt-cache search….pero nada.Solo existe un KDE y no tengo ni warra cual es

    Pues si sólo hay uno, ese es el último xD apt-get install kde y apañao

    entonces, cuando instalo el KDE, despues que tengo que hacer, solo configurar las X con lo de dpkg-reconfigure xserver-xfree86??

    Si tienes instalas las X, ya las tendrás configuradas, por lo q no tendrás q tocar nada.

    o ademas tengo que hacer algo con kdm y ese rollo….

    Para tener el kdm, lo de siempre –> apt-get install kdm

    PD: para usar KDE 3.1.1 tengo que tener instalado el gcc-3.3 y XFree 4.3??algo mas??gracias

    KDE 3.1 funciona en XFree 4.2.x para arriba, no hay ningún problema.
    Tu tranquilo, q todo lo q le haga falta, el apt-get lo buscará

    Salu2



  • 2

    Totalmente de acuerdo en la ayuda que te ha proporcionado josefu xD Te doy un dato más, si quieres saber la versión y demás datos de un paquete pon esto: apt-cache show pakete, esto te dirá el nombre, las dependencias, la versión, una descripción, etc…

    Otra cosilla, si no deseas liarte y pasarte a unstable, ¿por qué no pruebas las sources de la woody? Tienes que editar el /etc/apt/sources.list como bien ya sabrás y hacer un apt-get update, y la mayorÃ_a de los paquetes están ya "backporteados" a woody. Te dejo aquÃ_ un link donde podrás encontrar todo lo que necesites para nuestro fabuloso apt xD



  • 3

    ok gracias a los dos:sisi:

    Elfo, la pagina de apt-get ya la conocia, Josefu no para de hablar de ella:D

    weno, voy a probar eso del kde y kdm y xfree 4.x y rollazos, a ver si ya me empieza a rular bien;)

    enga, ya os contare
    the ruNNer



  • 4

    weno, cuando hago apt-get install kde, para instalar el kde 3.1.x, me dice esto:

    "Some packages could not be installed. This may mean that you have requested an imposible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

    Since you only requested a single operation it is extremely likely that the package is simply not instalable and a bug report against that package should be filed.

    The following informaton may help to resolve the situation
    The following package have unmet dependencies
    kde: depends: kdegraphics but it is not going to be installed
    E: Brocken packages"

    y si entonces meto apt-get install kdegraphics me sale esto:

    "Some packages could not be installed. This may mean that you have requested an imposible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

    Since you only requested a single operation it is extremely likely that the package is simply not instalable and a bug report against that package should be filed.

    The following informaton may help to resolve the situation
    The following package have unmet dependencies
    kdegraphics: Depends: kuickshow (>4:3.1.2-1) but it is not going to be installed
    E: Brocken packages"

    Josefu me habia dicho que pruebe instalar el kde 2.2 desde la cd, poniendo apt-cdrom add y entonces meter el cd, pero parece que soy muy patoso y tonto o el PC no quiere. De todas formas, me dice ahora que un kdelib…. no se puede instalar o yo que se....:(

    ahora, me meto en los sources, vuelvo a cambiar todos por stable y hago apt-get update??y si se instala el kde 2.2 vuelvoa ponerlos en unstable??

    noce lo que hacer,a ver si alguien sabe resolverme el problem;)

    un saludo
    the ruNNer



  • 5

    una pregunta imbecil:

    estando en unstable puedo instalar cosas que sean stable??

    xfavor no os riais de mi:D:D:D:D

    un saludo
    the ruNNer



  • 6

    estando en unstable puedo instalar cosas que sean stable??

    Si que se puede mientras no halla problemas de dependencias.

    Estaba instalando una debian anoche, y me surgió el mismo problema que a ti. Hay un problema de dependencias con kdegraphics la librería en cuestión creo recordar que era imlib2, no me acuerdo muy bien.
    Yo tuve suerte y la tenía en un mirror local que tenía en el portátil, así que añadí como source el otro pc y lo instaló todo sin problemas.

    Estas utilizando XFree 4.3??? si es así puede ser que sea eso. Pero si tenías añadido el source desde dónde instalaste esa versión de XFree, no debería haberte dado problemas, ya que si el paquete no lo tenías localmente, se lo habría bajado.

    De todas maneras, si tienes XFree 4.2.x siempre te quedará la solución de instalar manualmente con dpkg -i paquete; pero para eso debes tener los paquetes en tu máquina.
    Para saber que es lo que realmente falta, debes ir a donde tengas bajados los paquetes; y ya que te dice que es un problema de dependencias del paquete kdegraphics, buscas todos los relacionados con dicho paquete (en www.debian.org en la sección de paquetes puedes buscar sus dependencias) y empiezas a instalar paquetes hasta que te con alguno un error de dependencias, te dirá que paquete/versión le falta (también te recuerdo que creo que el que me faltaba a mi era el imlib2); te lo bajas desde la web de debian; lo instalas y pruebas de nuevo a instalar todos los paquetes de kdegraphics; y así hasta que no dé error.

    Se que es un poco coñazo, pero es lo único que se me ocurre.



  • 7

    pero el fallo de dependencias es solo de momento o como va eso, es decir, es problema de algun mirror que se va a resolver o es problema del kde??

    se me ha ocurrido instalar kde 2.2 que lo tengo en la cd. Asi puedo estar en el foro, en el msn y de paso actualizando el kde:D
    Weno, instalar el kde 2.2 y despues cambiar a unstable todo y hacer apt-get dist-upgrade y apt-get uopgrade y asi instalar el kde 3.1.x automaticamente….
    me lo aconsejais??

    EDITO: a q tal pasarme otra vez a stable, instalar el kde 3.1.2(que lo hay en stable) y despues volver a pasarme a unstable??Seria mucho lio y mucho bajarme con mi super modem, pero weno....:P

    enga, muchas gracias
    un saludo
    the ruNNer





Has perdido la conexión. Reconectando a Hardlimit.