Problemas con K3B


  • 0

    Estoy intentando hacer que me funcione la copia desde mi DVD a la grabadora con K3B, pero no consigo que el programa me detecte en condiciones el DVD. He probado a instalar la última versión 0.9 en detrimento de la 0.8.1 que tenia anteriormente, pero el programa sigue. Eso si, esta version me avisa de cual es el programa y de lo que tengo que corregir, pero no se como hacerlo.

    El mensaje es este:

    No support for ATAPI with cdrdao
    You will not be able to use all your reading devices as copy sources since there is at least one not configured to use SCSI emulation and your system does not support ATAPI with cdrdao.
    Solution: The best and recommended solution is to enable ide-scsi (SCSI emulation) for all writer devices. This way you won't have any problems.

    ¿Me echais un cable?

    Gracias.



  • 1

    humm mandrake debe tener un asistente para configurar grabadoras

    si no es asi la soilucion es complicada debes

    RECOMPILAR EL KERNEL

    y habilitar la emulacion ide-scsi

    o ver si ya esta habilitada
    añade esto a la imagen del lilo que uses habitual mente

    append="hdc=ide-scsi"
    mi lilo.conf porsi tas perdido
    /*

    $Header: /home/cvsroot/gentoo-x86/sys-apps/lilo/files/lilo.conf,v 1.3 2002/09/30 00:55:18 woodchip Exp $

    Author: Ultanium

    Start LILO global section

    menu-scheme=Wb
    boot = /dev/hda
    prompt
    #boot=/devices/discs/disc0/disc
    map = /boot/System.map
    #compact # faster, but won't work on all systems.
    lba32
    #if lba32 do not work, use linear
    #linear
    #if you always want to see the prompt with a 15 second timeout:
    timeout=150
    default = Jugar
    delay = 50
    vga = normal# Normal VGA console

    End LILO global section

    Linux bootable partition config begins

    image = /boot/bzImage2.6.0.test2
    root = /dev/hda9
    #root = /devices/discs/disc0/part3
    label = 2.6.0.test2

    read-only for checking

    append="hdc=ide-scsi"

    image = /boot/bzImage
    root = /dev/hda9
    #root = /devices/discs/disc0/part3
    label = Jugar

    read-only for checking

    append="hdc=ide-scsi"

    image = /boot/secure
    root = /dev/hda9
    #root = /devices/discs/disc0/part3
    label = Secure

    read-only for checking

    append="hdc=ide-scsi"

    Linux bootable partition config ends

    DOS bootable partition config begins

    other = /dev/hda1

    #other = /devices/discs/disc0/part1

    label = Windows

    table = /dev/hda

    DOS bootable partition config ends

    */
    bueno despues de esto
    vete a una consola
    cdrecord –scanbus
    debe devolver algo asi
    miguel@localhost facultad $ cdrecord --scanbus
    Cdrecord 2.01a05 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
    Linux sg driver version: 3.1.24
    Using libscg version 'schily-0.7'
    scsibus0:
    0,0,0 0) 'HL-DT-ST' 'DVD-ROM GDR8161B' '0100' Removable CD-ROM
    0,1,0 1) 'HL-DT-ST' 'CD-RW GCE-8481B ' '1.01' Removable CD-ROM
    0,2,0 2) *
    0,3,0 3) *
    0,4,0 4) *
    0,5,0 5) *
    0,6,0 6) *
    0,7,0 7) *
    miguel@localhost facultad $
    sino esque vas a tener que reinstalar mandrake para que pille la grabadora o bien ser un hombre (o mujer) con eso bien puesto y
    RECOMPILAR EL KERNEL



  • 2

    a mi me pasa mas algo similar si no es lo mismo
    si ejecuto elprograma de configuracion de k3b al final me dice que no puede añadir en el fstab la linea correspondiente al dvd, la he añadido manualmente y entonces el programa no da problemas (el de configuracion no da error) pero me sigue sin aparecer la opcion para uqe lea del dvd para grabar un cd

    si que he grabado un cd con la grabadora, y tnego la linea esa en lilo, la de ide-scsi, por eso puedo grabar, claro esta, pero si hago

    [osfesa@unit0 osfesa]$ cdrecord –scanbus
    Cdrecord 2.0 (i586-mandrake-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
    Linux sg driver version: 3.1.24
    Using libscg version 'schily-0.7'
    scsibus0:
    0,0,0 0) 'LITE-ON ' 'LTR-52327S ' 'QS04' Removable CD-ROM
    0,1,0 1) *
    0,2,0 2) *
    0,3,0 3) *
    0,4,0 4) *
    0,5,0 5) *
    0,6,0 6) *
    0,7,0 7) *

    vereis que no pilla la unidad dvd como a meninas92, entoences no se que linea he de incluri en el fstab, supongo que sera de eso, al final he dejado fstab como lo tenia no sea que lie alguna

    he recomilado el kernel muchas veces ya, no me asusta volver a hacerlo, lo tengo tal como lo mete mandrake, pero puedo grabar osea que la emulacion scsi tengo activada



  • 3

    Uhm, lo del lilo no hace falta, recompila el kernel como dice meninas92, habilita el "SCSI Emulation Support" y "SCSI Generic Support", y deshabilita el "IDE CDROM Support", arranca con ese kernel y listos… Para mí así es más fácil. Un saludo



  • 4

    Pues lo acabo de conseguir :sisi:. Por suerte no he tenido que tocar el Kernel, porque sabia que la emulacion SCSI si estaba soportada, porque es como funcionaba la grabadora.

    Lo he hecho del siguiente modo.

    Ya existia una linea append en mi lilo.conf de esta manera para la grabadora:

    append="devfs=mount hdc=ide-scsi acpi=off quiet"

    y no me dejaba añadir otra como la que me decia meninas92, pero con hdd, que es el que corresponde a mi DVD. Me decía que append estaba duplicado. Asi que sin conocer bien la sintasis de append, me ha dado por probar a ponerlo de este modo:

    append="devfs=mount hdc=ide-scsi hdd=ide-scsi acpi=off quiet"

    y funcionó.

    Mi lilo.conf queda así:

    boot=/dev/hda
    map=/boot/map
    default="linux"
    keytable=/boot/es-latin1.klt
    prompt
    nowarn
    timeout=100
    message=/boot/message
    menu-scheme=wb:bw:wb:bw
    image=/boot/vmlinuz
    label="linux"
    root=/dev/hda1
    initrd=/boot/initrd.img
    append="devfs=mount hdc=ide-scsi hdd=ide-scsi acpi=off quiet"
    vga=788
    read-only
    image=/boot/vmlinuz
    label="linux-nonfb"
    root=/dev/hda1
    initrd=/boot/initrd.img
    append="devfs=mount hdc=ide-scsi acpi=off"
    read-only
    image=/boot/vmlinuz
    label="failsafe"
    root=/dev/hda1
    initrd=/boot/initrd.img
    append="devfs=nomount hdc=ide-scsi acpi=off failsafe"
    read-only
    other=/dev/fd0
    label="floppy"
    unsafe

    Gracias por la ayuda, y espero que le valga también a koenigsegg.

    Saludos.



  • 5

    muchas gracias a ambos, eso es lo que me faltaba, la linea que añadi era la correcta en el fstab, pero como en lilo no cargaba lo uqe hemos añadido pues no rulaba
    muchas gracias a ambos



  • 6

    Bueno, ahora me he encontrado con un problema, que seguro que es una chorrada, pero no puedo cambiarlo.

    Al poner el DVD como SCSI me ha cambiado el icono del escritorio KDE, poniéndome el de un disco duro en vez de uno de CD. Encima me he decidido por cambiar el punto de montaje de ambos dispositivos para que sea en /mnt/dvd y /mnt/grabadora y ahora son los iconos de ambos dispositivos los que me aparecen como discos duros, de hecho hasta pone 'disco duro montado en /mnt/dvd'. ¿Como cambio esto?.

    Gracias.



  • 7

    pue seso que el entorno grafico no es lo mio pero de todas todas

    prueba a borrar el icono y crear uno nuevo
    borrar es facil
    crear nuevo creo que tb
    boton derecho crear nuevo unidad de cdrom dvd por lo menos en mi kde

    si te molesta el icono de disco duro puedes cambiarlo en las propiedades





Has perdido la conexión. Reconectando a Hardlimit.