No puedo borrar un par de ficheros en Windows XP ¡¡¡¡¡



  • Hola a todos , llevo intentando borrar dos archivos algo grandes , unos 400 megas , del disco duro pero cuando les doy a eliminar , el windows me dice que este archivo está siendo utilizado por otra persona o programa , cierre todas las aplicaciones etc etc …....

    He intentado reiniciando , quitar programas de la memoria , pero nada , ¿a alguien se le ocurre algo ?

    Los archivos son dos avi .

    Saludos¡



  • Desde ms-dos ? en modo a prueba de fallos ? …



  • ^En modo a prueba de fallos los he podido borrar , la verdad es que no se me había ocurrido, gracias kracker ¡ ;)



  • Desde la consola de comandos tampoco te debe de dar ningún problema y así no tienes que reiniciar. Creo que es un bug de liberación de memoria del XP (no estoy seguro, pero es habitual).



  • Tiuuuu habia algo mas rapido que eso. Le das a ctrl+alt+sup y en la pestaña de procesos quitas el que tenga activos esos archivos (fijate que ponga en el usuario que lo ha activado tu nombre) y ya ta. Eso me pasa a mi con los directorios estos que te meten sin permiso las paginas guarras xD XD. Y haciendo eso puedo borrarlos sin tener que reiniciar.

    P.D.: Ahora ya no me pasa porque ya no uso IE.



  • Gracias a los dos ¡ , tomo nota , je,je…........


  • Mercaderes HL

    Publicado originalmente por Kako
    **Tiuuuu habia algo mas rapido que eso. Le das a ctrl+alt+sup y en la pestaña de procesos quitas el que tenga activos esos archivos (fijate que ponga en el usuario que lo ha activado tu nombre) y ya ta. Eso me pasa a mi con los directorios estos que te meten sin permiso las paginas guarras xD XD. Y haciendo eso puedo borrarlos sin tener que reiniciar.

    P.D.: Ahora ya no me pasa porque ya no uso IE.**

    Tio no entiendo lo que quieres decir. A mi no me aparecen por ningun sitio los ficheros utilizados por cada proceso.



  • Nas, a ver…

    Tio no entiendo lo que quieres decir. A mi no me aparecen por ningun sitio los ficheros utilizados por cada proceso.

    Si le das a ctrl+alt+sup te sale el administrador de tareas de Windows. Si le das a la pestaña de procesos ves los archivos que estan ejecutando algun proceso en ese momento (esos no te los dejaria borrar windows). Si te das cuenta pone al lado el usuario que los ha activado (SYSTEM osea es cosa de windows (ese no es) o tu nombre de usuario). Si seleccionas el proceso activo de tal archivo y le das a terminar, ya puedes borrar el archivo que has dejado libre de proceso.

    No se si ta mu claro… si eso pongo fotos.. xD



  • Yo lo que hago es abrir una ventana de ms-dos (bueno el sucedaneo de XP) cerrar desde el alt+ctrl+supr el explorer.exe y borrarlo desde la ventanuca del "ms-dos".

    Ultimamente cuando me pasa simplemente lo dejo y la proxima vez q inicio el pc ya lo borro.



  • No es ningun bug, es culpa del put* explorer, que como tiene que mirar que archivo es, como esta comprimido etc para las propiedades se tira la de dios utilizando el archivo, y claro, no se puede borrar porque se esta utilizando.
    Si no usais las vistas "detalles" ni "vistas en miniatura" y no teneis activada la "barra de estado" deberia dejaros borrarlo directamente.
    Yo lo que hago es darle a suprimir y esperar unos segundos hasta que en la barra de estado me pone las caracteristicas, luego le digo que si a borrarlo, con la vista "lista" me funciona.

    Saludos


  • Mercaderes HL

    Publicado originalmente por Kako
    **Nas, a ver…

    Si le das a ctrl+alt+sup te sale el administrador de tareas de Windows. Si le das a la pestaña de procesos ves los archivos que estan ejecutando algun proceso en ese momento (esos no te los dejaria borrar windows). Si te das cuenta pone al lado el usuario que los ha activado (SYSTEM osea es cosa de windows (ese no es) o tu nombre de usuario). Si seleccionas el proceso activo de tal archivo y le das a terminar, ya puedes borrar el archivo que has dejado libre de proceso.

    No se si ta mu claro... si eso pongo fotos.. xD**

    Vamos a ver, eso no te vale de nada. Ahi unicamente ves los ficheros EJECUTABLES (si te das cuenta son todos .exe) que se estan ejecutando, pero no ves el resto de ficheros. y el problema de no poder borrar ocurre con todos. A mi me ocurre mucho con los .avi. No hay manera de borrar algunos, es mas, aunque reinicie y me espere 3 dias siguen bloqueados de alguna manera. Solo puedo borrarlos desde la consola.



  • Vamos a ver, eso no te vale de nada. Ahi unicamente ves los ficheros EJECUTABLES (si te das cuenta son todos .exe) que se estan ejecutando, pero no ves el resto de ficheros. y el problema de no poder borrar ocurre con todos. A mi me ocurre mucho con los .avi…

    Pos termina el proceso del .exe que los tiene abiertos xD. O sea el programa que uses para verlos xD.


  • Mercaderes HL

    Tio, si es que ese NO ES EL PROBLEMA. Porque no hay ningun proceso realmente que lo tenga pillado el fichero!!! Por ponerte un ejemplo. Reproduzco una peli .AVI, despues cierro el mplayer e intento borralo o moverlo. Me dice que no puedo porque esta pillado. Reinicio el ordenador, intento borrarlo (NO PUEDE SER QUE DESPUES DE REINIAR ESTE TODAVIA EL MPLAYER EN MEMORIA…) y sigue sin dejarme.

    Para poder eliminarlo tengo que:

    • Opcion uno, seleccionar el fichero con el explorer, esperar unos 10 minutos y despues darle a suprimir (asi funciona a veces)
    • Arrancar en modo a prueba de fallo (que tampoco funciona todas las veces)
    • Cerrar el explorer y hacerlo desde la consola. (que por el momento si va)...


  • Si, la verdad es que todos estamos un poco cansados de este "bug", pero bueno, yo he descubierto un "pequeño truco" (que hasta ahora no me ha fallado) para borrar estos archivos.

    El truco es muy simple, consiste en crear un archivo de texto de tamaño 0 (cero) y darle el nombre del archivo que queremos borrar (con extensión incluida). Una vez hecho esto lo movemos a la carpeta donde tenemos el archivo que queremos borrar y lo sobreescribimos. Después pulsamos la tecla suprimir y ya está.

    Quien dice un archivo de texto, dice cualquier otro archivo. Yo lo hago en una carpeta diferente o en el mismo escritorio. Ya sabéis, click derecho -> nuevo -> documento de texto

    De esta manera tendremos un archivo llamado "Nuevo Documento de texto.txt" que será el que hay que renombrar, etc, etc, etc…

    Ya os digo que a mi hasta ahora no me ha fallado. A ver si os funciona.

    Salu2.


  • MODERADOR

    Tambien se podia hacer creando un archivo de registro.. a ver si encuentro como era.


  • Mercaderes HL

    La verdad es que no entiendo como despues de un SP1, y un monton de actualizaciones desde que salio el WXP aun no lo hayan solucionado los de M$



  • Publicado originalmente por fanol
    **Hola a todos , llevo intentando borrar dos archivos algo grandes , unos 400 megas , del disco duro pero cuando les doy a eliminar , el windows me dice que este archivo está siendo utilizado por otra persona o programa , cierre todas las aplicaciones etc etc …....

    He intentado reiniciando , quitar programas de la memoria , pero nada , ¿a alguien se le ocurre algo ?

    Los archivos son dos avi .

    Saludos¡**

    ¿tienes el emule conectado?
    desconectalo y espera de 10 a 15 minutos,para que dejen de hacer peticiones y podras borrarlo



  • a mi me pasa algo similar cuando intento formatear una particion o bien otro disco duro (fisico) me dice que esta siendo usado por windows ¿?¿?¿?


  • MODERADOR

    El truco es muy simple, consiste en crear un archivo de texto de tamaño 0 (cero) y darle el nombre del archivo que queremos borrar (con extensión incluida). Una vez hecho esto lo movemos a la carpeta donde tenemos el archivo que queremos borrar y lo sobreescribimos. Después pulsamos la tecla suprimir y ya está.

    A mi no me deja sobreescribirlo :/



  • "krampak"… supongo que el archivo lo has creado en OTRA carpeta...

    Yo te aseguro que me funciona en los 3 ordenadores que tengo, lo he probado en otros y nunca me ha fallado este sistema. De hecho lo tengo ya memorizado como "algo habitual" para estos casos :p .

    Salu2.


Accede para responder
 

Has perdido la conexión. Reconectando a Hardlimit.