Abrir puertos en debian


  • 0

    Bueno, pues he conseguido instalar samba, apache, proftpd, xmule y alguna cosa más y lo he echo ya solo.

    No está mal, despues de ser la decima vez que los instalo (es broma eh¡¡).

    Y ahora tengo un problema (que raro :p).
    El xmule me dice que tengo cerrado el puerto 4662 (el del emule) y por lo tanto tendré LowID.

    ¿¿¿COMO SE ABRE UN PUERTO???:risitas: :risitas:



  • 1

    Hombre, en principio no deberías tener problemas con ningún puerto (de hecho a mí no me pasa), a mí tu problema me suena más a que estás detrás de un firewall o un proxy con los puertos capados… puede ir por ahi el asunto?

    Un saludo



  • 2

    Lo más normal es preguntar como se cierra :-)

    ¿No tendras un router para salir a internet? si la respuesta es afirmativa, es ahí donde tienes que abrir el puerto.

    Saludos



  • 3

    No, no. Está directamente conectado al cable-modem. Y si arranco con windows o Mandrake funciona perfectamente.



  • 4

    ¿tienes router ?
    si es que si te vas al router i le dices que todo el trafico del protocolo TCP que entre por el puerto 4662 y 4665 lo mande a tu masquina (dirección ip) y ya esta

    el puerto esta abierto pero el low id te aparece pq no puedes conectar directamente con tu maquina ya que el router hace de intermediario y la comunicación no es transparente



  • 5

    Que no, que no, que no tengo router.
    El esquema es:

    INTERNET–-------CABLE-MODEM----------SWICTH-------------PCs

    Y el cable modem no hace de router y además si en el mismo PC arranco en mandrake por ejemplo si me funciona perfectamente.



  • 6

    Bueno, pues se ha arreglado solo.

    Habia reiniciado 2 veces para ver si al reiniciar se arreglaba y no.

    Y ahora que he reiniciado para otra cosa ya si funciona asique nada.

    Expedientes X en linux tambien????? Yo creia que solo pasaban en Windows. :p:p



  • 7

    No suele haber expedientes X de este tipo en Linux, casi siempre hay una razón lógica. Es muy raro que se arregle algo por reiniciar, lo normal es que si algo no funcina, tras un reinicio sigue sin funcionar.

    Cuando quieras saber si hay algún puerto "cerrado" sigue los siguientes pasos:

    • ejecuta /sbin/iptables -L -n y comprueba que no haya reglas que afecten a esos puertos en concreto. Comprueba también que las políticas por defecto sean ACCEPT.

    • comprueba con netstat -putan que el puerto en cuestión no esté siendo utilizado por otro programa.



  • 8

    Efectivamente no hay ningun expedienet X. Tan sencillo como que el problema lo tenias en el servidor de edonkey al que te conectabas (O temporalmente tu ISP habia cerrado dichos puertos, cosa bastante improbable). ¿Te has fijado si el mensaje te lo daba siempre el mismo server, y si ese server era el mismo al que te conectabas con exito en windows y mandrake?

    Un saludo.



  • 9

    Pues no me fijé a que server conectaba. Puede que si que sea problema de él.

    Bueno, da igual, ya funciona….............





Has perdido la conexión. Reconectando a Hardlimit.