Permisos


  • 0

    Buenas.

    Ante todo me presento, me acabo de registrar aunque llevo un par de semanas entrando a la página y a los foros(muy buenas ambas cosas). Bueno, al grano, tengo 1 problema…
    Me he instalado recientemente una Debian woody y estoy bastante contento de ella. Veamos, me he montado una particion q tengo de windows(fat32) porque uso mucho emule con win, y tengo pensado usar xmule con debian... en fin, he editado el fstab, y montado la particion, pero no consigo dar los permisos a mi user para poder escribir, solo puedo leer. Si quiero escribir tengo que entrar como root, y he probado a cambiarlos y me dice siempre acceso denegado. A ver que se os ocurre.

    Un saludo, y muchas gracias.



  • 1

    Lo que buscas es la opción "umask" de fat. Busca en el manual de mount cómo utilizarla correctamente.

    Una vez que decidas qué valor de umask has de utilizar, simplemente añade umask= <el_valor_que_quieres>al campo "options" de /etc/fstab.</el_valor_que_quieres>



  • 2

    Otra cosa, escribir desde linux sobre la particion de windows a veces puede dar problemas, como por ejemplo que si la particion de windows tiene montado el SO sobre ella luego no te arranque (es decir, en un equipo con arranque dual si desde linux accedes a la particion de windows indebidamente), por eso por defecto los permisos sobre particiones de windows son de solo lectura si mal no recuerdo :rolleyes:



  • 3

    Escribir sobre una partición de windows puede dar problemas principalmente en dos casos:

    • El sistema de ficheros es NTFS (no es el caso, ya que es fat32)
    • Si al escribir te cargas alguno de los archivos del sistema (pero esto también ocurre si lo haces desde windows XD)

    En resumen, si tienes fat32 y no te pones a borrar archivos en directorios "delicados" puedes leer y escribir en esa partición sin problemas. Únicamente podrás notar que al copiar algún archivo a esa partición el cp te dará algún aviso respecto a que no ha podido cambiar los permisos o algo similar (fat32 no tiene permisos, de ahí el aviso).





Has perdido la conexión. Reconectando a Hardlimit.