¿Como configuro la ethernet en Gentoo ?



  • Hola a todos,

    pues mi problema es que estoy intentando configurar la targeta de red en gentoo para conectarme a internet pero no hay manera ( antes utilizaba un modem y por eso no me hacía falta ). Yo tengo ip asignada mediante dhcp ( por cierto mi tarjeta de red es la Asustek/Broadcom 440 10/100 Integrated controller ) , y he intentado configurarla con ifconfig pero no he tenido exito, también he mirado en el archivo resolv.conf y tampoco. Como es la primera vez que lo hago ando un poco perdido. He mirado en el kernel y creo que tengo el modulo activado pero no se muy bien cual es. ¿ Alguien me puede echar una mano?



  • Pues nose que modulo es para esa targeta, pero si te sirve de algo el archivo de configuracion es este:

    /etc/config.d/net
    rc-update add net.eth0 default (para que carge al arrancar)

    Un saludo.



  • He mirado el archivo /etc/conf.d/net pero la verdad es que ando un poco perdido, he probado varias cosas pero nada, he buscado por la web y tampoco he encontrado nada que me funcione, me pone que no encuentra un dispositivo eth0, y lo tengo cargado en el kernel como módulo. l3g0r ¿ puedes ponerme tu archivo de configuración para hacerme una idea de como se configura ?. ¿ Alguien conoce algun manual sobre el tema que esté bien esplicado y que empiece desde cero, como si tuvieras que instarla ethernet desde el principio ? . Con el live cd de gentoo si que la detecta porque lo he probado, tiene un script llamado net-setup que la detecta automáticamente. Bueno si alguien sabe como arreglarlo por favor que me lo diga, porque si por algo me puse gentoo es por el portage y si no puedo usarlo de que me sirve :rabieta: . Salu2



  • Si quieres dhcp segun esto link

    Add the relevant modules to /etc/modules.autoload, and then edit /etc/conf.d/net. If your network uses dhcp, simply uncomment this line:
    Code:

    For DHCP set iface_eth? to "dhcp"

    For passing options to dhcpcd use dhcpcd_eth?

    iface_eth0="dhcp"
    #dhcpcd_eth0="…"

    descomentar esa linea.



  • Solucionado, se ve que el problema radicaba en que no me cargaba bien el modulo ( que para el que le interese , de esa tarjeta es el b44 ) , y tampoco me lo cogia mediante dhcp , aunque si que lo tenia configurado como tal porque el ifconfig no podia inicializar la targeta. Bueno de todo se aprende, ahora ya se como hacerlo mejor en un futuro. Gracias I3gOr



  • Hola, otra opcion es si no quieres que te arranque el dhcp por defecto por que alguna vez no tienes el cable de red instalado y te tarda un rato en detectar que no hay cable, en el net.eth0 lo dejas para que te active la eth con ip fija y una vez arrancado como root ejecutas el comando dhcpcd, que lo que hace es negociar la asignacion de ip con el server.

    Saludox: Rolling.


Accede para responder
 

Has perdido la conexión. Reconectando a Hardlimit.