Configurar tarjeta nvidia



  • a ver
    esto me trae por la calle de la amargura
    he intentado configurar mi nvidia fx5200 (creo que es una geforce 5 no?)
    he seguido paso a paso lo que se ha comentado en este foro y algun manual por ahi, pero no se por que razon, intento arrancar de nuevo las Xs y no funciona
    el problema es que no se que tocar en el XF86Config
    vayamos por pasos:
    descomento la linea #load glx
    luego en la seccion device que tengo qeu modfiicar?, el nombre del modulo en modules.autoload es nvidia, por lo que cambio nv por nvidia, y que mas?

    Section "Device"
    Identifier "NVidia GeForce 2 MX/200"
    Driver "nvidia"
    Option "NvAGP" "2"
    Option "AGPMode" "4"

    esto es lo que me pone en un manual, claro en identifier pongo lo que me salga, si mi tarjeta tiene agp 8x donde lo cambio? o que es lo que falla aqui? la cantidad de memoria (128 megas en mi caso) es necesario?
    a ver si alguien m pone su archivo o me explica



  • que error te da las X si pones

    startx &> pepe.txt redireccionas la salida de errores a pepe.txt
    adjunta copia o pega pepe txt para examinarlo

    haz un lsmod (como root)

    debe aparecerte el modulo nvidia si no haces un

    modprobe nvidia

    te dara un warning modulo no gpl tainting kernel (al ser el modulo propietario los desarrolladores del nucleo no se hacen resposables de incompatibilidades del modulo con otras partes del kernel como el framebuffer (no lo actives en el nucleo pq casca mas que una escopeta caña con el modulo nvidia))

    y con lsmod comprueba que lo cargas

    si tu kernel es de la serie 2.6

    debes mirar en /etc/modules.autoload.d/2.6

    ya que la carga de modulos varia de un kernel a otro



  • vaya, parece que funciona jejejej hago un glxinfo y me salen muchos numeros, eso es buena señal
    en el manual que mire el tio tenia una geforce 2 y tenia puesta esta configuracion
    Section "Device"
    Identifier "NVidia GeForce 2 MX/200"
    Driver "nvidia"
    Option "NvAGP" "2"
    Option "AGPMode" "4"
    EndSection

    yo puse lo mismo, osea uqe supongo que el agpmode y el nvagp es lo que hacia uqe no me iniciase
    que valores tengo uqe poner, mi tarjeta es agp 8x y tiene 128 megas de memoria grafica, es necesario poner el tipo de agp y la cantidad de memoria?
    ahora mismo tengo esta configuracion
    Section "Device"
    Identifier "NVIDIA GeForce"
    Driver "nvidia"
    #VideoRam 131072

    Insert Clocks lines here if appropriate

    EndSection
    si es necesario el nvagp y el agpmode, que pongo, el agp sera 8 no? y el nvagp qeu es la version del chip?

    PD: tras poner esto en marcha…. hay letras uqe se me ven borrosas, como si el driver no estuviese bien, hace una franja vertical que tiene las letras borrosas, el color poco definido en cambio el resto si se ve bien
    a que puede ser debido?



  • A tu problema no se muy bien a que es debido, pero asegurate k en el kernel, en la seccion de graficos no este el modulo de la "Riva TNT", asegurate de que este solo la "VESA"

    Salu2!



  • fuf el nvagp depende de tu placa base (el chipset) ya que algunos modos del driver de nvidia son imcompatibles con segun que placa tengas
    el readme esta aqui

    ftp://download.nvidia.com/XFree86/Linux-x86/1.0-5336/README

    Option "NvAGP" "integer"
    Configure AGP support. Integer argument can be one of:
    0 : disable agp
    1 : use NVIDIA's internal AGP support, if possible
    2 : use AGPGART, if possible
    3 : use any agp support (try AGPGART, then NVIDIA's AGP)
    Please note that NVIDIA's internal AGP support cannot
    work if AGPGART is either statically compiled into your
    kernel or is built as a module, but loaded into your
    kernel (some distributions load AGPGART into the kernel
    at boot up). Default: 3 (the default was 1 until after
    1.0-1251).

    aqui tienes una lista de problemas con nvidia

    http://www.cyber.com.au/users/ashridah/nvidia_tsg.html
    http://www3.sk.sympatico.ca/johngee/lin14.html

    busca tu chipset si es viejo si no busca la opcion recomendada con tu placa

    el que las fuentes aparezcan borrosas puede ser el antialiasing en las fuentes desactivalo a ver


Accede para responder
 

Has perdido la conexión. Reconectando a Hardlimit.