"bloqueos" estraños relacionados con /mnt



  • Wenas, vereis tengo un problema.. y eske resulta que al acceder al cd, cdrw o al disco de windows (por eso deduzco k es algo relacionado con el mnt) … se pone la pantalla d un color raro y se sale del modo grafico, y entra al control de acceso de login en modo texto, y si pulsas una tecla, o el raton o esperas unos segundos nose exactamente (sin poner usuario ni contraseña ni na).. pos vuelve al modo grafico como si ubieras blokeado la sesion, yt pide la contraseña, y es k no se xq puede ser... pero no se pueden esuchar cds a traves de programas, ni copiar cds, ni ver divx ni na, xq cada 2 x 3 esta blokeandose con esa movida.. sabeis a k se puede deber???



  • pues no se uqe habras echo, algun programa o algo que hayas tocado antes de que te ocurriese eso, y si viesemos el fstab tambien seria interesante



  • pues eso que descrives es lo mismo que pasa cuando haces
    como root
    killall X

    me huele a que las X se mueren pq deficiete configuracion de targeta grafica es quizas una nvidia



  • Pos la tarjeta k tengo es una ati, y la detecta como ati, en caunto a lo de tokar no e tokao na, de hecho hace tiempo reinstale x algun problemila y desde ese momento tnego muchhoo cuidao con lo k toko, pa no joer na, y me va to bien, a excepcion de esa movida rara. Y he comprobado tambien que si desde una consola entro al disco duro del windows pasa lo mismo, no se si sto servira de algo.

    Respecto al fstab ese, aki tengo lo k pone:

    /dev/hdb1 / ext3 defaults 1 1
    none /dev/pts devpts mode=0620 0 0
    /dev/hdb6 /home ext3 defaults 1 2
    none /mnt/cdrom supermount dev=/dev/hdc,fs=auto,ro,–,iocharset=iso8859-15,codepage=850,umask=0 0 0
    none /mnt/cdrom2 supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-15,codepage=850,umask=0 0 0
    none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-15,sync,codepage=850,umask=0 0 0
    /dev/hda1 /mnt/windows vfat iocharset=iso8859-15,codepage=850,umask=0 0 0
    none /proc proc defaults 0 0
    /dev/hdb5 swap swap defaults 0 0

    AVer si me podeis exar un mano, muchas gracias y saludos.



  • Y respecto al killallx ese, ni conocia eso yo, asike no lo e tocao jeje. saludos



  • Pero sucede solamente al mover archivos de ahi no? es decir, al montar y desmontar va bien?. Como tienes el DMA de los lectores? es posible que algo que se haya tocado por ahí los moviera.

    Lo que resulta raro es que aunque parecen caer las X, por lo que dices no te tira la sesión porque te vuelve a la misma no?. Prueba a arrancar de inicio sin entorno gráfico ni nada y prueba como root a ver lo que pasa.



  • a ver el fstab parece correcto tu particion win es ntfs o fat
    si es fat esta bien si es ntfs no y puede ser la causa del problema

    despues de que ocurra el problema haz un
    cat /var/log/XFree86.0.log |tail
    para ver los mensajes de las X y ver que pasa con ella

    tb es util ver los mensajes del kernel
    cat /var/log/messages | tail

    y nos lo pegas aqui please a ver si con eso nos enteramos

    tb puedes probar a montar manualmente para ver si el nucleo da algun mensaje

    nota si no tienes claro si win es fat o ntfs pues monta como auto y haz un

    df -Th
    para ver los sistemas de archivos montados la salida ha de parecerse a esto
    S.ficheros Tipo Tamaño Usado Disp Uso% Montado en
    /dev/hda9 ext3 9,7G 8,4G 757M 92% /
    /dev/hda5 ext3 236M 6,4M 217M 3% /boot
    /dev/hda6 ext3 236M 84M 141M 38% /var
    /dev/hda8 ext3 62G 56G 5,9G 91% /home
    /dev/hda1 vfat 40G 25G 15G 63% /mnt/windows
    none tmpfs 569M 0 569M 0% /dev/shm
    bash-2.05b$

    que el source te acompañe



  • Glasst:
    Pos veamos.. es cuando intento leer algo de un cdrom o del disco de windows, vamos que es entrar y se "blokea" o lo k coño sea esa movida.. Y bueno utilizo la mdk y los monta solo. Y la sesion no la cierra, eske es como si le das a "blokear" k t pide luego la contraseña, pos igual, pero sigue en la misma sesion y con los programas o carpetas abiertos.

    Meninas92:
    Pues es fat, por lo tanto eso sta bien..
    Una cosa… cuando me suceda eso.. Esribo esto en una consola na mas que lo desblokee no??
    cat /var/log/Xfree86.0.log | tai y sto de TAil?? como lo pongo??? con la | esa tb??? y lo del kernel igual no?? Bueno pos ara voi a probar aver k me dice..

    El caso, es que no se como desmontarlo... xq como no soi mu viejo con sto de linux.. y tanta facilida en window$ pos claro.. jeje.. pero una cosa, m dijeron k probara a desmontar desde el scritoio, y al darle me salia un mensaje de error de algo umount y tal.. y tonces a lo ke intentao desmontar se poen un candaito al lao del icono y ya me parece k no funciona asta k reinicio sesion o el pc, no stoi seguro.. salduos y gracias.



  • Veamos…

    [alvaro@localhost alvaro]$ cat /var/log/XFree86.0.log | tail
    () Option "Emulate3Timeout" "50"
    (
    ) Mouse1: Emulate3Buttons, Emulate3Timeout: 50
    (==) Mouse1: Buttons: 3
    (II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
    (II) Mouse1: ps2EnableDataReporting: succeeded
    xf86KbdEvents Resource temporarily unavailable
    (II) PM Event received: System Suspend Request
    (II) Mouse1: ps2EnableDataReporting: succeeded
    (II) Open APM successful
    (II) Mouse1: ps2EnableDataReporting: succeeded

    Este otro he entrado como root porke sta denegado…

    [root@localhost alvaro]# cat /var/log/messages | tail
    May 3 14:53:10 localhost xinetd[2220]: bind failed (Cannot assign requested address (errno = 99)). service = sgi_fam
    May 3 14:53:10 localhost xinetd[2220]: xinetd Version 2.3.10 started with libwrap options compiled in.
    May 3 14:53:10 localhost xinetd[2220]: Started working: 0 available services
    May 3 14:53:12 localhost xinetd: xinetd startup succeeded
    May 3 14:53:13 localhost kernel: devfs_mk_dir(snd): using old entry in dir: c11695c0 ""
    May 3 14:53:27 localhost network: Setting network parameters: succeeded
    May 3 14:53:28 localhost network: Bringing up loopback interface: succeeded
    May 3 12:53:30 localhost apmd[892]: Normal Resume
    May 3 12:53:31 localhost apmd[892]: Battery: -1%, absent (+0% over 0:00:43), ? to empty
    may 3 12:54:18 localhost su(pam_unix)[2424]: session opened for user root by alvaro(uid=501)

    Veamos k me podeis contar acerca d estos dos personajillos… muxas graciass y asludos



  • el nucleo parace hacer uso de apm para controlar el uso de la bateria es un portatil???

    May 3 12:53:30 localhost apmd[892]: Normal Resume
    May 3 12:53:31 localhost apmd[892]: Battery: -1%, absent (+0% over 0:00:43), ? to empty

    prueba a desabilitar el soporte apm no vaya a ser que suspenda la sesion y

    el posible daño colateral que puedes tener es tener que apagar el ordenata a mano

    como root si te gusta la consola

    /etc/init.d/apmd stop

    si eres mandrakero al cien por cien

    vel a configurar su computadora en configuracion y luego busca servicios y desabilita apmd del arranque y detenlo a ver si eso soluciona el tema

    otra posibilidad es que supermount este dando porsaco (supermount no esta incluido en el kernel es un parche y como tal no esta muy testeado (no esta probado con todas las unidades fabricantes …))

    estoi casi seguro de que tienes un portatil ya que huele a hardware raro (el hardware portatil es especial)



  • Pos siento llevarte la contraria pero es de sobre mesa…:confused:
    Que movidas tio... dos cosas... El daño colateral puede sufrirse debido a que esto continue asi? o a que pare el apm?? Y para volver a activarlo, por si las moscas, en vez de stop que deberia poner??
    Y lo de supermount pos nose.. la solución podrai ser montar manual?? xq no tengo ni idea..
    El caso esque ayer curiosamente...justo antes de salir el login grafico, paso lo mismoo!! :rabieta: salio el color raro y se piro a la consola, para volver al instante al login grafico...:muerto: , cosa que hoy no, tambien hayu que decir que antes de ayer se fue la luz y se apago por las malas el sistema.. gracias



  • que las X (el entorno grafico se te muere)

    pero no se pq ocurre estoy desconcertado

    bash-2.05b$ cat daemon.log | grep X | tail
    oct 18 21:14:00 localhost gdm[1091]: Failed to start X server several times in a short time period; disabling display :0
    oct 18 21:24:24 localhost gdm[1096]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
    oct 18 21:24:26 localhost gdm[1098]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
    oct 18 21:24:30 localhost gdm[1100]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
    oct 18 21:24:34 localhost gdm[1102]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
    oct 18 21:24:34 localhost gdm[1094]: deal_with_x_crashes: Running the XKeepsCrashing script
    oct 18 21:24:35 localhost gdm[1094]: Failed to start X server several times in a short time period; disabling display :0
    oct 19 03:19:35 localhost gdm[1084]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
    Mar 21 00:42:59 localhost gdm[3886]: La pantalla :0 está ocupada. Ya hay otro servidor X en ejecución.
    Apr 15 22:28:15 localhost gdm[3256]: gdm_slave_xioerror_handler: ha ocurrido un error fatal de X - Reiniciando :0
    bash-2.05b$

    mis X se resetearon hace poco mira a ver en /var/log/daemon.log si hay algo asi a ver si te da otro mensaje ???

    la pregunta que es ese algo quizas las X no esten bien configuradas o algo te este haciendo la puñeta



  • métele un tail -f /var/log/syslog en una consola y haz que pete a ver que te sale ahí



  • Publicado originalmente por meninas92

    **mis X se resetearon hace poco mira a ver en /var/log/daemon.log si hay algo asi a ver si te da otro mensaje ???

    la pregunta que es ese algo quizas las X no esten bien configuradas o algo te este haciendo la puñeta**

    Puess ese fichero yo no lo tengo en Mandrake…

    Publicado originalmente por josefu
    **métele un tail -f /var/log/syslog en una consola y haz que pete a ver que te sale ahí
    **

    Que pete el que? las X? :confused:



  • prueba a instalarte la ultima 10.0 o si no puedes bajarla la 9.2 que esta bastante bien es la que uso en el curro

    pq creo que es la manera mas rapida de acabar con tu problema quizas sea mas facil pillarte una 10.0 de alguna revista que estan testeadas a ver si va a ser que la bajaste mal de inet y por eso te da porsaco



  • Bueno…aver lo que hago, aun asi.. Me gustaría probar si puede ser que con tanta movida aqui fuera alo mejor por algo d eso que tambien me han hablado del supuer mount y leches, pero bueno el caso eske me gustaria probar a cambiarlo y tal, pero es que es demasiado diferente a lo que yo habia visto y no se como hay tanta cosa... Lo siguiente es lo que tengo ahora mismo en /etc/fstab:

    /dev/hdb1 / ext3 defaults 1 1
    none /dev/pts devpts mode=0620 0 0
    /dev/hdb6 /home ext3 defaults 1 2
    none /mnt/cdrom supermount dev=/dev/hdc,fs=auto,ro,--,iocharset=iso8859-15,codepage=850,umask=0 0 0
    none /mnt/cdrom2 supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-15,codepage=850,umask=0 0 0
    none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-15,sync,codepage=850,umask=0 0 0
    /dev/hda1 /mnt/windows vfat iocharset=iso8859-15,codepage=850,umask=0 0 0
    none /proc proc defaults 0 0
    /dev/hdb5 swap swap defaults 0 0

    Y asi como quiero dejarlo:

    /dev/hdb1 / ext3 defaults 1 1
    /dev/hdb6 /home ext3 defaults 1 2
    /dev/fd0 /floppy auto user,noauto 0 0
    /dev/hdc /mnt/cdrom iso8859-15 user,noauto 0 0
    /dev/scd0 /mnt/cdrw iso8859-15 user,noauto 0 0
    /dev/hdb5 swap swap defaults 0 0
    /dev/hda1 /mnt/windows vfat user,noauto 0 0

    Haber si me podeis decir si sta bien asi, he visto que en el viejo el windows, tiene un formato iso y eso porque?? no seria vfat??? y que significa eso de codepage?? umask?? sync?? ro?? y poque pone none?? y el formato ext3, no seria ext2?? y proc?? y pts?? juer perdonad por todas las preguntas pero esque yo habia mirao manuales y tal y coño no ponia na de lo que tengo yo..

    Muchisimasss gracias si teneis ganas de contestarme. saludos y gracias d nuevo.



  • el umask sirve para que otros puedan ver el fichero concretamente umask=0 es que todo el mundo pueda ver el cd y acceder a el

    ext2 + journaling = ext3

    iso9660 es el formato estandard de los cds

    codepage 850 es la tabla de codigos del teclado europea esto se le pasa a supermount para que no te ponga moñotos ni cosas raras cuando vea una ññ

    no toques ni /proc ni /dev/pts dejalos como estan por lo demas añade el umak=0 a los dispositivos que quieras que sean accesibles por todos

    porcierto si te arrepientes es mejor tener copia del fstab

    sync es para sincronizar el medio en un disquete es obbio si lo modificas el sistema lo sincroniza cada x segundos

    ro es readonly solo lectura

    para mas informacion sobre las opciones de mount

    man mount
    info mount

    prueba a pillarte una mandrake que no sea bajada pq puede ser que no la bajaste bien



  • Ei tio gracias por contestar, ya esta clarito jeje, pos me la copio bluesman. Pero weno, aver si consigo otra version o otra distribucion, xq tengo aki la linex, pero eske nose… no me parece... mu wena... saludos y gracias


Accede para responder
 

Has perdido la conexión. Reconectando a Hardlimit.