Ayuda: Errores con phpnuke


  • 0

    Hace poco he subido mi web en php nuke al servidor de miarroba.com (donde antes la tenia en html) y tras comprobar que todo funcionaba bien en local vi que al subirla no funcionaba casi nada.
    En el modulo de noticias me aparece esto (y las noticias no salen):

    Warning: mysql_fetch_row(): supplied argument is not a valid MySQL result resource in /home/webcindario/forenaits/includes/sql_layer.php on line 286

    Al intentar entrar en el foro me sale este otro error:

    phpBB : Error Crítico Could not obtain lastvisit data from user table DEBUG MODE SQL Error : 1146 Table 'forenaits.nuke_users' doesn't exist SELECT * FROM nuke_users WHERE user_id = '1' Line : 101 File : /home/webcindario/forenaits/includes/sessions.php

    Si no me equivoco son todo errores de la base de datos, pero no se como arreglarlo.He subido al servidor todo excepto algunos modulos que no uso (pero esto no creo que afecte a nada) y unos archivos que el servidor no me deja subir que son .htaccess ¿para que sirven?

    En cuanto a la base de datos, hice un respaldo de la web funcionando en local y desde el admin de miarroba abri ese .sql para meter las tablas.Creo que es el procedimiento correcto pero me daba un error aunque despues creaba las tablas.

    A ver si alguien me puede ayudar en algo, que tengo la web tirada…:vayatela:
    Ciao!



  • 1

    Me da la sensación de que no puede leer la base de datos. Asegúrate de que en el config.php tienes los datos correctos. Los datos a poner seguramente te los mandaron en un correo, pero no como ponerlo en el config.php. Puedes preguntar en el foro correspondiente de miarroba, o al menos buscar casos similares, que seguro que encuentras algo. En su momento yo monté un PHP-Nuke en ese hosting, pero de memoria no recuerdo. De todos modos puedes ponerlo aquí, que de algo me acordaré.

    Saludos.



  • 2

    El config.php esta bien cambiado, es sencillo de hacer pero creo que el problema como bien dices es de la base de datos.Mira esta rama para mas informacion,es de una web sobre nuke donde pregunte aunque no me han resuelto el problema:
    http://www.psicoconsultas.net/modules.php?name=Forums&file=viewtopic&t=905&sid=2ad24430345aaf8d92d5894e975c6fc1
    Gracias por responder, de momento voy a cambiar de hosting a ver que pasa.
    Ciao!



  • 3

    No parece ser cosa del config.php, no. He buscado por foros y webs y parece totalmente correcto. También podrías probar a eliminar el espacio web desde el panel de control y crearlo de nuevo. Desde ahí empezar de cero. También puedes hacer lo que has dicho, por ejemplo en Lycos, y si todo rula bién volver a intentarlo en miarroba, que es mejor hosting en mi opinion. (por el tema de la publicidad).

    Saludos.



  • 4

    Estoy esperando que me activen la cuenta en almacenweb.com para subir ahi la web ya que parecen serios, la publicidad no molesta (popup) y me dan el doble de espacio.Veremos que tal va en velocidad pq miarroba.com en eso no me gusta nada.
    Ciao!





Has perdido la conexión. Reconectando a Hardlimit.