Tengo problemas instalando glibc, alguien sabe como se hace?


  • 0

    Hola a todos, es toy tratando de instalar glibc 2.3.2 y de verdad no lo he conseguido como tal, me encontre con algo llamado glibc-common-2.3.2-11.9 que es necesitado tambien por glibc-2.3.2-11 pero el segundo me pide al primero y el primero me da el siguiente error:

    [root@kitana packages]# rpm -i glibc-common-2.3.2-11.9.i386.rpm
    error: failed dependencies:
    glibc < 2.3.2 conflicts with glibc-common-2.3.2-11.9

    y si intento darle a otro me sale esto:

    [root@kitana packages]# rpm -i glibc-2.3.2-11.9.i686.rpm
    error: failed dependencies:
    glibc-common = 2.3.2-11.9 is needed by glibc-2.3.2-11.9

    yo lo que pienso es lo siguiente, que el primero me da conflictos con glibc 2.3.2, pero de donde coño lo saca no se :confused: porque yo no he montado esa biblioteca, tengo la por default de mandrake 9.0 que es la version 2.2.5.

    si alguien al menos me puede explicar por favor que significa el primer error que me da (el del paquete glibc-common) por que a mi por los momentos me comio, le estare muy agradecido. :dormido:



  • 1

    pues instala los dos a la vez:p:

    rpm -Uvh glibc-common-2.3.2-11.9.i386.rpm glibc-2.3.2-11.9.i686.rpm



  • 2

    rpm -Uvh glibc-common-2.3.2-11.9.i386.rpm glibc-2.3.2-11.9.i686.rpm
    error: failed dependencies:
    glibc = 2.2.5-16mdk is needed by glibc-devel-2.2.5-16mdk
    glibc = 2.2.5 is needed by locales-2.3.1.3-7mdk
    glibc = 2.2.5 is needed by locales-2.3.1.3-7mdk
    glibc = 2.2.5-16mdk is needed by glibc-utils-2.2.5-16mdk

    me imagino que son los de la distribucion, pero no cargo los cd's en este momento, se los preste a un pana, em cuanto los tenga trato de montar todo eso y vuelvo a intentar, gracias.



  • 3

    Otra solución es instalarte apt-get para rpm, que es similar al apt-get de debian y con sólo hacer apt-get install glibc te debería instalar la última versión con todas sus dependencias. Así es como instalo yo casi todo, es mucho más cómodo que resolver las dependencias a mano;)



  • 4

    Sabes bluesman que me pusiste a buscar eso de apt y encontre justo lo que necesitada:

    urpmi ya que uso mandrake (hay una especie de apt para red hat, pero no para mandrake segun vi, para eso esta el urpmi)

    El detalle esta en que me tendre que ir a casa de un amigo por que mi proveedor de internet me cobra por megas descargados :muerto: y si le doy play a eso me guindan.

    nada mas le di urpmi al glibc y ya me queria actualizar la distro, me asusto namas ver en la lista de cosas que iba a actualizar al g++, ahi arrugue, y mejor me aguanto a que el pana me preste su conexion, que es ilimitada.

    Gracias un millon por todo.



  • 5
    ¡Esta publicación está eliminada!


  • 6

    Bueno muchachos, lo que encontre esta en este sitio

    http://www.linuca.org/body.phtml?nIdNoticia=57

    si usan mandrake 9.0, tienen internet y los cds de mdk, entonces monten urpmi desde el mandrake control center y luego sigan las instrucciones que estan en el links que les estoy poniendo arriba.

    de alli en adelante la tarea de instalar nuevo software en nuestro mandrake es pan comido.

    Chau y suerte



  • 7

    once and again!

    No se si estoy pagando el noviciado pero tengo problemas de nuevo.

    resulta que el urpmi no es tan genio como yo esperaba y me esta instalando una nueva version de linux, ya he bajado alrededor de 1.5 GB y siguen los problemas.

    Ahora me dice que /usr/bin/php es requerido por tal y cual paquete, y he tratado de bajar php de lo que hay en los espejos de rpms, pero a pesar de que me esta bajando mas de un giga en informacion para resolver dependencias.

    creo (es decir, estoy seguro) que estoy metiendo la pata.

    el asunto es como resolver ese problema, yo ya tenia instalado php, de hecho el apache esta corriendo bien los php, tons no entiendo a que se refiere el programa urpmi de que se necesita /usr/bin/php, lo busque a pata y ahi esta, incluso lo ejecute a ver que hacia (nada aparentemente), no se si es un interprete de comandos, probe algunos de php que pongo en os scripts y nada, no se de berdad que es asi que por las dudas mande a instalar todo lo nuevo de php, pero me urpmi quiere montar hasta tuxracer (es bueno pero no es lo que nesecito ahorita).

    Pido ayuda a la providencia del foro para que me saquen la pata del barro una vez mas, gracias.



  • 8

    tenías que haber probado apt-get;)… ahora ya has entrado en el infierno de las dependencias :risitas:. Esas cosas se pueden resolver por lógica si la has cascado con pocos paquetes, pero si ya te ha instalado un montón.... lo mejor va a ser que actualices todo:p



  • 9

    a la gran chuca!

    de pana que tengo ganas de actualizar todo, ya me esta obstinando esto, ahora estoy buscando a ver de donde me bajo el mandrake 10, tu sabes bluesman de donde lo puedo bajar?, por que al parecer no se puede for free desde madrake.org, o es que no revise bien.





Has perdido la conexión. Reconectando a Hardlimit.