Prueba y compara el rendimiento de tu PC con nuestro banco de pruebas.

Problema con MIDI



  • Esto es una cosa que siempre se me ha resistido en Debian :o, no puedo reproducir archivos midi.

    Vamos a ver: uso ALSA, esta bien configurado, para el midi uso Rosegarden 4, y estos son los módulos que tengo:

    osiris:/etc/modprobe.d# lsmod
    Module                  Size  Used by
    snd_emu10k1_synth       8704  4
    snd_emux_synth         39424  5 snd_emu10k1_synth
    snd_seq_virmidi         7168  1 snd_emux_synth
    snd_seq_midi_emul       8320  1 snd_emux_synth
    snd_emu10k1            96648  12 snd_emu10k1_synth
    snd_util_mem            4992  2 snd_emux_synth,snd_emu10k1
    snd_hwdep               8992  2 snd_emux_synth,snd_emu10k1
    nls_iso8859_1           4992  1
    nvidia               3925660  12
    msr                     4224  0
    cpuid                   3584  0
    intel_mch_agp           9232  0
    intel_agp              18076  1
    agpgart                28588  3 nvidia,intel_mch_agp,intel_agp
    i830                   75444  0
    vfat                   13440  0
    fat                    42144  1 vfat
    usb_storage            46976  0
    rtc                    12744  0
    osiris:/etc/modprobe.d#    
    

    Tengo una SB Live 5.1 con el chip emu10k1, como se puede ver. A ver si me podéis ayudar, es que en teoría funciona, vamos, no me da ningún error ni nada, y la cancion empieza y tal pero no se oye nada.
    Yo he pensado que podria ser algo relacionado con el volumen, pero he probado todo lo k tengo en el mixer y nada, aunque tampoco se exactamente cómo subir y bajar el volumen del midi.

    Weno, eso es todo, espero que alguien del foro haya configurado esto en su linux 😛



  • Vale arreglado, es lo que tiene ser autodidacta… xD

    Este manual esta genial, me ha abierto los ojos, aunque la respuesta la tenía delante de mis ojos, habia cargado unos soundfonts inadecuados...

    http://es.tldp.org/LinuxFocus/pub/mirror/LinuxFocus/Castellano/September2002/article259.shtml



  • Ojalá todos los problemas se solucionasen en 21 minutos xD


Accede para responder