Windows XP solo me reconoce 3GB de 4GB que tengo pero la BIOS si me lo reconoce



  • He puesto 4 modulos de 1 GB KINGSTON en la placa base ASUS A8N SLI DELUXE y cuanod he configurado la BIOS no me ha dado ningún problema y me ha reconocido los 4 módulos correctamente y ponía que tenía 4 GB de RAM

    He puesto el CPU-Z y también me dice que tengo 4096 MB RAM

    Y he puesto otros programas que también me reconocen correctamente los 4 GB y no hay problema

    Pero ahora como Xpuerto me ha preguntado si me había reconocido correctamente EL WINDOWS los 4 GB pues yo estaba seguro que si, porque todos los demás programas reconocían que tengo 4 GB, y me he llevado una GRAN SORPRESA :o al ver que SOLO ME RECONOCE 3GB !!!!! :| :confused:

    O sea que cuando le doy a Propiedades de mi PC o en el Administrador de tareas de windows me pone en lo de memoria física que tengo 3 GB !!!! :confused: :rabieta:

    ¿ Como es que en la BIOS y en los programas que he visto de información del hardware me pone que tengo 4 GB y en el windows no ? : :| :confused: :o

    Por cierto he puesto el 3D Mark 2006 y también me pone que solo tengo 3 GB de RAM

    Supongo que tendré que buscar información para ver si hay que poner algún parche o algo así

    ¿ A alguien mas le ha pasado esto ?

    He querido buscar en el foro pero como no se pueden poner busquedas de tres letras (3GB y 4GB) pues no he encontrado ninguna rama relacionada.



  • Yo diria que es el Windows.

    Al final tanto hablar del x64 que he pasado unos cuantos beenchs con el normal, he formatado el disco y me he puesto a instalar el x64. Luego cuento que tal.


  • Admin honoris causa



  • **EDITADO: Mientras estaba escribiendo este post, packosoft te me has adelantado y me has dado una estupenda web con una solución MUCHAS GRACIAS
    **
    –------------------------------------------------
    Pues buscando información en google no he encontrado nada aún y por eso puse esta rama, pero ahora he mirado en la web de microsoft y he encontrado esto.

    A description of the 4 GB RAM Tuning feature and the Physical Address Extension switch

    http://support.microsoft.com/default.aspx?scid=kb;en-us;291988

    http://www.microsoft.com/whdc/system/platform/server/PAE/PAEmem.mspx

    O sea que parece que el Windows XP solo puede reconocer un máximo de 4 GB y que si se ponen más de 3 GB hay que activar en el registro la extensión PAE (Physical Adress Extension) para que reconozca los 4GB y que esto hay que ponerlo en el boot.ini



  • ¿Incompatibilidad Placa con RAM?
    http://www.forospc.com/vbulletin/showthread.php?t=105739

    Según dicen aquí es posible que solo se pueda reconocer 3 GB ?????????????????????????????

    ¿Es por la placa base? ¿ pero si en la BIOS me dice que tengo 4 GB?

    Y en la estupenda web que ha puesto packosoft (gracias otra vez por ese enlace) dice lo siguiente:

    Debido, sobre todo, a que el oscurantismo de ciertos fabricantes de hardware roza lo que yo llamaría"estafa por omisión de información", está claro que si una placa madre se anuncia para soportar 4 o más GB de memoria, debería poder direccionarlos cualquier sistema operativo con dicha capacidad.

    Pero parece, a la vista de lo que sucede, que lo que quieren decir es que les puedes pinchar 4 GB. Sólo eso.
    Y que perderás memoria: típicamente 1 GB en las actuales placas madre. Pero esto no se dice (o se dice en algún manual técnico en la letra pequeña).

    Tendré que probar si activando el PAE me funciona o no, aunuqe según dice en el enlace de packosoft, no va a funcionar si tengo el SP2 puesto :( :vayatela:

    Sistemas operativos de 32 bits:

    W2000 / W2003 / XP / XP-SP1: Usar /PAE en el boot.ini
    XP-SP2: no se puede usar toda la memoria instalada. Tipicamente pueden usarse de 2,5 GB a 3,5 GB. :llorar:

    ¿ es que entonces no puedo poner 4 GB con Windows XP SP2 32 bit? :rabieta:

    ¿ Tengo que poner necesariamente el Windows 64 bit para que me pueda reconocer los 4 GB ? :susto:

    Sistemas operativos de 64 bits:

    No es necesario hacer nada excepto lo comentado al principio de este capítulo. Si el chipset y BIOS lo soportan y además el sistema operativo conoce el chipset y puede remapearlo, lo hará. En otro caso es imposible usar toda la memoria.



  • La gente que trabaja en MS no son tontos (del todo) y si han sacado la versión x64 es por algo.

    Hasta hace poco era raro ver ordenadores "domesticos" con mas de 1 GB, por tanto no aparecian este tipo de "problemas".

    Fijate en la publicidad de MS:

    http://www.microsoft.com/windowsxp/64bit/evaluation/top5.mspx

    mejor con IE ;D

    Bueno ya he instalado el x64 y ahora estoy acabando de actualizar y instalar drivers.


  • MODERADOR

    Si ejecutas el Blend Test del Prime95 y miras en el administrador de tareas (procesos), cúanta ram te está utilizando SpaceRay? Podrias mirarlo?



  • Buscando mas cosas he visto esto otro sobre los Dual core de AMD y los 4 GB

    http://www.xbitlabs.com/articles/cpu/display/athlon64-e3-mem_2.html

    Y dice que hasta la versión E había ciertos problemas pero según creo esto se refiere ¿ solo a la velocidad y lo de cambiar 1T por 2T?

    He mirado en el CPU-Z y me pone que el mio es de la familia F, supongo que familia se refiere a la versión del chip, por lo que es mejor que la E de la web de arriba

    ¿ porque en el CPU-Z si me pone que tengo 4096 MB? ¿ es porque accede directamente a la información de la BIOS sin hacer caso a lo que diga el windows?

    @krampak:

    Si ejecutas el Blend Test del Prime95 y miras en el administrador de tareas (procesos), cúanta ram te está utilizando SpaceRay? Podrias mirarlo?

    Pues si puedo mirarlo, lo pruebo y te digo lo que me pone



  • @krampak:

    Si ejecutas el Blend Test del Prime95 y miras en el administrador de tareas (procesos), cúanta ram te está utilizando SpaceRay? Podrias mirarlo?

    Pues ya he puesto el Prime95 con Blend test del torture test y ya lleva un rato y ha hecho ya 5 test, y me según pone en el administrador de tareas pone que prime95.exe está usando 1.437.948 KB, y el CPU solo se esta usando al 50% pero funcionando los dos nucleos

    Y pone uso de PF = 1,62 GB


  • MODERADOR

    Que raro, eso es lo que me pilla a mi con 2GB de ram. Bueno, pues nada.



  • El programa usa la memoria que le indica el SO. No hay mas.

    He comparado los resultados 32 bit / 64 bit aquí:

    http://www.hardlimit.com/forum/showpost.php?p=345015&postcount=9

    Y aquí:

    http://www.hardlimit.com/forum/showpost.php?p=344994&postcount=14



  • @krampak:

    Que raro, eso es lo que me pilla a mi con 2GB de ram. Bueno, pues nada.

    Pues si es raro que solo use 1.5 GB teniendo 4 GB, o bueno 3 GB comoo dice el windows, supongo que tendría que usar 2,5 GB y no 1,5 GB

    He estado mirando mas cosas y todavía no he encontrado una solución

    Al parecer no puedo usar lo del PAE porque solo es para MAS de 4 GB y solo es bueno usarlo con 64 bit

    Voy a poner otros programas para ver si alguno consigue reconocer los 4 GB sin leerlo de la BIOS que si los reconoce

    Ahora creo que tengo que ir buscando en internet la posible causa y ver si hay alguna solución posible para esto

    Posibles causas

    Causa 1 - El controlador de memoria del Microprocesador que al ser un Dual Core de AMD lleva el controlador dentro del chip y es responsable de gestionar la memoria, y puede que solo reconozca 3 GB y el windows me dice lo que le dice el chip. Tal vez exista algún parche para esto y que pueda reconocer 4 GB.

    Causa 2 - Algún problema con la placa base y que aunque en la BIOS me ponga que reconoce bien los 4 GB haya luego alguna incompatibilidad con el windows o alguna cosa. La BIOS es la 1015, y ya está disponible la 1016 pero no la voy a cambiar hasta saber si es necesario o no.

    Causa 3 - Que sea el windows el que no reconoce los 4 GB y que como se dice en el enlace que puso packosoft si se tiene actualizado a SP2 puede que no se pueda poner a no ser que se use el windows 64bit. Tal vez haya algún nuevo parche o driver que pueda gestionar de manera correcta los 4 GB.

    Lo raro es que microsoft certifica que con Windows XP Profesional 32 bit solo se pueden poner 4 GB y esta limitado a esta cantidad de memoria, pero dicen que si que funciona correctamente con 4 GB y debería de reconocer toda la memoria, el problema es si se tienen mas de 4 GB y no solo 4 GB.

    Pues voy a investigar a ver lo que encuentro


Accede para responder
 

Has perdido la conexión. Reconectando a Hardlimit.