Problema con linux


  • 0

    Buenas a todos. Soy nuevo en el foro y mi pregunta es:
    Yo he intentado instalar linux en mi pc, es una conroe E6600, plaba base P5B delux, hd segeate 320gb sata2, 2gb de ram. Las distros que he intentado instalar a sido mandriva y ubuntu, arrancar arranca bien, pero resulta que cuando carga los archivos para instalar y tal, se queda un rato sin hace nada y me dice que inserte el cd o dvd como si no lo tuviera metido.
    Se que es por cosa de la controladora jmicron, es para ver si hay ya alguna forma de como instalarlo o no.

    Salu2! Muchas Gracias.



  • 1

    Según he visto en google:

    Here is what is wrong with the ASUS P5B series: the JMicron PATA/IDE controller is not yet supported under Linux. Two or three of the people in charge of building/maintaining the Linux kernel have now admitted that they made a "stupid error" overlooking the JMicron.

    Patches are already out and anyone interested should google about a bit for "Linux JMicron patch".Whether these are of any use will obviously depend on your level of technical expertise. If you are very much a newbie as I am, they are merely, as we say in Dutch, "a patch on a wooden leg". So all I can do for now is wait for the final version of 2.6.18. I hear that it will feature in the next Ubuntu but then that one is not expected to come out before the end of October. So only two more months to go…

    O lo que es lo msimo, que la controladora IDE de tu placa no está soportada por el kernel linux. Hay algunos parches para kernel, pero si estás empezando con linux lo mas sencillo es que esperes un par de meses hasta que salga la nueva revisión del kernel (la 2.6.18) que si que traerá soporte para la JMicron. Es eso o cambiarse de placa, lo cual dudo mucho que estes dispuesto a hacer por instalar linux :risitas:

    Si solo quieres instalarlo hay una posible solución:

    Well, I've finally managed to get a distribution installed, in spite of the Jmicron issue with the Asus P5B. I think it was on a Dutch or Belgian site that someone pointed out that it was perfectly possible to install Fedora Core 5 so I gave it a try and - HECK YES - it works! Not out of the box but you need only the following boot parameter:

    all-generic-ide irqpoll

    (the irqpoll suppresses the error messages generated by irq17 when you go all-generic-ide).

    One other thing to remember is that Fedora Core 5 does not have support for the Realtek Gigabit on the mobo but you can download a driver from their site. It has taken me some time to figure out how to get it working but it now does. And yet another: the all-generic-ide works only during install; whenever you reboot Fedora and you want it to discover your CD/DVD, you need to use the boot parameter again. There must be a way of setting once and for all but I am still looking…

    Pero cada vez que reinicies seguirás en las mismas si no le pasas el parametro cada vez que arranque el sistema…



  • 2

    Pues nada, me esperare a que salga la nueva revision del kernel.

    Salu2! Gracias



  • 3

    Acabo de bajarme el Feisty ya definitivo y el problema ahora es el siguiente…

    Arranco el pc, carga el cd y eso... (aunque saliéndome errores como "ata3.00: failed to set xfermode") pero carga. Me sale el escritorio y todo bien, pero le doy a instalar y solo me da opción en un disco duro que tengo conectado al IDE, al SATA nada de na.

    Supongo que será del jmicron de los cojones... qué puedo hacer? He pensado conectar el disco este a un puerto sata que controla el southbridge, pero como la grabadora la controla también el jmicron no sé si funcionará luego y si funcionará el disco que está al IDE.

    Mi equipo es el de la firma, a ver si me podéis echar una mano, que estoy ya muy quemado... ya llevo casi 2 meses sin oler linux...

    Saludos!

    PD: En la BIOS tengo "USB Keyboard Support: disabled" y "USB Keyboard Support: disabled" ya que leí por ahí que podía tener algo que ver.



  • 4

    Yo tengo configurado el SATA como IDE en la BIOS, prueba a poner el SATA como SATA en la BIOS que por lo que he leído puede influir.

    Prueba también a poner el disco en la controladora SATA del southbridge.

    ¿Qué kernel usa Feisty? Es que me extraña, porque con el 2.6.18-4 de Debian funciona todo sin problemas.



  • 5

    @FASerrano:

    ¿Qué kernel usa Feisty? Es que me extraña, porque con el 2.6.18-4 de Debian funciona todo sin problemas.

    2.6.20 Igual si lo recompilas funciona ;) A mi me toco recompilar para que me pillara el core 2 duo, y la wifi como dios manda ;) y eso con la 2.6.17. A ver si cuando llegue a casa ya esta la feisty calentita y recien descargada :p



  • 6

    @FASerrano:

    Yo tengo configurado el SATA como IDE en la BIOS, prueba a poner el SATA como SATA en la BIOS que por lo que he leído puede influir.

    Prueba también a poner el disco en la controladora SATA del southbridge.

    Hola FASerrano. ¿Tú tienes conectado el disco al SATA del Jmicron y te funciona?

    Lo del SATA como IDE, eso no veo ninguna opción por mi BIOS :nono: .

    Voy a conectar el disco a la otra controladora para probar, pues.

    Gracias y un saludo.

    EDITO: Mierda, no estaba conectado al Jmicron sino al controlador de Intel. ¿Ahora qué? x'DDD ¿Lo dejo en este? ¿Lo pongo en el Jmicron? o_0

    Está conectado al SATA4 que pone que ahí debe conectarse el primer dispositivo. ¿Quizás sea que lo que no reconozca es el southbridge? Porque el disco duro conectado al IDE (controlado po jmicron) sí me sale a la hora de particionar en la instalación. …. :rolleyes:

    Aquí mas claro:
    attachment_p_404757_0_sata.gif



  • 7

    Bueno, lo he conectado al puerto controlado por Jmicron y ahora mismo estoy hablando desde Sabayon, voy a instalar Ubuntu.

    Gracias a todos, saludos.



  • 8

    Como llevo tiempo sin venir por aqui, pues no he visto las constetaciones. Y al leer lo de poner el sta como sata, me ha venido la pregunta como ponerlo sata? mi placa es una p5b delux, y supongo que los puertos satas controlados por el southbridge son los de color rojo y los negros por la jmicron no?

    Salu2!



  • 9

    En la BIOS, en la primera pantalla, sale la opción para configurar los SATA como IDE, AHCI y otra opción que no recuerdo. Si lo pones en AHCI lo configuras como SATA (requiere que le metas los drivers vía disquete al instalar el XP, por ej.).

    Los puertos SATA, sinceramente, ignoro cuales son los del southbridge y cuales los Jmicron porque aún no he tenido problemas con ellos (salvo lo del Jmicron IDE y la red, todo normal).



  • 10

    @taurboy:

    mi placa es una p5b delux, y supongo que los puertos satas controlados por el southbridge son los de color rojo y los negros por la jmicron no?

    pues no, si te fijas en la placa veras 6 conectores sata jutos 4 rojo y 2 negros, estos son controlados por la controladora intel los rojos son para conectar unidades de boteables y los negros para datos, los que controla la jmicron, son el e-sata que hay en la parte trasera, un sata que hay cerca de la ranura pci-e suelto tambien controla el canal ide (que es lo que aa dado algun problema a alguna distro asi como aqlgunos bootcd tipo hirens por ejemplo que no llevaran esa controladora jmicron y se intentasen ejecutar en esta placa con una unidad optica ide).

    si ya tienes el xp instalado para poner los sata en vez de ide como sata (ahci), le tienes que dar los drivers antes, ya que si no lo haces y los seleccionas como ahci (sata) no te arrancara windows, creo que hay un post en el subforo de almacenamiento de como hacerlo

    yo he instalado ahora el kubuntu 7.04 dvd en un equipo con la p5b dlx y ningun problema por ahora, de hecho, ahora estoy rulando el live de ubuntu 7.04 para ver diferencias



  • 11

    Pues cuando formate, le metere los drivers para poder poner el sta en ahci. Los drivers son los que se crea el disket, vamos con los que viene en el cd de asus verdad? Que viene la opcion de crear un diskete con los controladores de jmicron. Al ponerlos en achi hay alguna mejora en el rendimiento o solo sirve para que vaya el linux y para cuando diga de hacer raid.

    Salu2! Gracias.





Has perdido la conexión. Reconectando a Hardlimit.