Instalacion de drivers para GeForce4 i Audigy Platinum en Red Hat v7.3


  • 0

    Buenas, tengo Red Hat v7.3 i queria instalar los drivers de una Audigy Platinum i de una S/U/M/A GeForce 4 Ti4200.

    Tengo problemas ya que no me se mover bien en el modo consola…..

    Si alguien me puede guiar i tal, me ayudaria muchisimo.

    Tengo los drivers de los dos dispositivos pero el problema esta en instalarlos.

    Muchas gracias.



  • 1

    Buenas,

    Te voy a intentar hacer una guía bastante fácil, lo que pasa es que ya no tengo ni una NVidia ni una Audigy, así que no se si seguirá siendo igual el método…

    NVidia,
    Si te has bajado los RPM nada tan fácil como:
    1- Entra como root
    2- rpm -i nombre.del.archivo.rpm (para ambos)
    3- edita el archivo /etc/X11/XF86Config-4 y busca la linea donde pone... Driver "nvidia" y cámbialo por Driver "nv" (o al revés, no recuerdo jeje).

    En teoría ya debería funcionar.

    Audigy,
    1- Desempaqueta el tarball (archivo.tar.gz)
    tar xvfz archivo.tar.gz (o tar xvfj si es un .tar.bz2)
    2- Entra en el directorio que ha creado y pon:
    ./configure
    make
    y
    make install

    Creo que para la audigy hay que hacer este proceso con algún que otro módulo que trae, así que nunca está de más mirarte el archivo llamado INSTALL o README donde te dirá paso a paso que debes hacer, ya verás como te sale.



  • 2

    Muchas gracias tio, o sea, resumiendo, tengo k poner esto

    Para Nvidia:

    (entro como root)

    rpm -i archivo1.rpm
    rpm -i archivo2.rpm
    edit /etc/X11/XF86Config
    (cambiar linia nvidia por nv)

    Ok, pero para cerrar el xserver pongo xkill? o no hace falta? o ke? :rolleyes:

    Para Audigy:

    tar xvfz archivo.tar.gz
    carpetanuevacreada
    ./configure
    make
    make install

    Ufff k lio, bueno si de paso me dices k kieren decir los comandos i eso, jejeje, asin ya lo se para el proximo dia :D

    Gracias tio



  • 3

    Sí, en principio es así (sobretodo con los de la NVidia).

    Lo que me parece que los de la Audigy tienen algo más de complicación, más que nada porque hay que cargarlo como módulo al arrancar.
    Por cierto, ten en cuenta que debes tener el paquete de las cabeceras del kernel (justo el de la versión que uses) instalado para compilar ambos drivers :p

    De todas formas antes de probar los de la Audigy haz esto como root:
    modprobe emu10k1
    y luego prueba a hacer sonar algo :)



  • 4

    Bueno, a ver k tal me va, como no controlo mucho supongo k no me saldra…:D i me parece k lo tengo mal instalado, me va mal desde el dia k actualize el kernel con noseke del Red Hat (actualizaciones, estilo windowsupdate :D )

    Gracias tio, saludos!



  • 5

    Gracias por la respuesta, mañana tengo pensado instalarme RH 7.3 y justo tengo una GF4 y una Audigy :)



  • 6

    Pues acaban de salir nuevos drivers de NVidia (1.0-3123) que mejoran el soporte para GF4 entre otras cosas :cool:



  • 7

    Ya lo tengo instalado y funcionando :)

    Aqui tienes los drivers de la Audigy

    http://sourceforge.net/projects/emu10k1

    Los de la GF4 los puedes encontrar en la web de nvidia.com, por cierto el rmp del driver del kernel bajete el .i686 no el .i386



  • 8

    Ok, por cierto, ya tienes las dos cosas rulando ok??

    k kabron, yo lo intente el otro dia i me volvi loco, me parece k la particion es demasiado pekenya i no puedo bajarme nada!! k a saco!, a ver si le meto mas capacidad i lo intento a ver k tal…

    oye DOICE si no lo consigo podrias hacerme una guia paso a paso para sindromes? :D

    Eske me daria rabia k no me lo pudiera meter nunca xD

    Gracias igualmente



  • 9

    Jodo, los de la Audigy me costaron echarlos a andar :P los de la GF4 son facilillos de instalar.

    Voy a explicarte un poquillo como lo hice:

    · GF4

    En la pagina de nvidia tienes los ficheros e instrucciones para instalarte los drivers, como te veo un poco verde de linux y por defecto el RH no te instala el lynx te paso el comando para bajartelos, dando por hecho que durante la instalación hayas configurado bien tu conexion a internet, sino tb te explico como hacerlo:

    El driver son dos partes, por un lado el driver del kernel y por otro el GLX que intuyo será el openGL.

    Escribe este comando en la shell:

    Driver Kernel:

    Si tienes un Athlon:
    wget http://download.nvidia.com/XFree86_40/1.0-3123/NVIDIA_kernel-1.0-3123.rh73up_2.4.18_10.athlon.rpm

    Si tienes un P4:
    wget http://download.nvidia.com/XFree86_40/1.0-3123/NVIDIA_kernel-1.0-3123.rh73up.i686.rpm

    Driver GLX:

    wget http://download.nvidia.com/XFree86_40/1.0-3123/NVIDIA_GLX-1.0-3123.i386.rpm

    Una vez que te los bajes tienes que escribir estos comandos:

    Si tienes un Athlon:
    rpm -ivh NVIDIA_kernel-1.0-3123.rh73up_2.4.18_10.athlon.rpm

    Si tienes P4:
    rpm -ivh NVIDIA_kernel-1.0-3123.rh73up.i686.rpm

    Eso para el driver del kernel, ahora para el GLX:

    rpm -ivh NVIDIA_GLX-1.0-3123.i386.rpm


    En caso de que no tengas conexion a internet en linux te recomiendo que te los bajes de internet en windows y desde linux accedas a la particion de windoze.

    Escribe este comando:

    mkdir /mnt/c
    creamos un directorio donde montar la unidad

    mount -t vfat /dev/hda1 /mnt/c
    suponiendo que la particion sea fat y sea la primera siendo tu disco duro master en ide1 :P. Si la particion es ntfs cambia vfat por ntfs.

    Una vez lo montes podras acceder a esa particion desde /mnt/c como si fuera parte de ese directorio.


    Si no te ha dado ningun problema durante la instalacion ya deberías de tener los drivers instalados.

    Ahora tenemos que modificar un fichero de configuracion para decirle que use los nuevos drivers:

    /etc/X11/XF86Config-4

    ese es el path y el nombre del fichero, ahora te toca modificarlo y vas a tener q usar vi :D, vi es un programa editor de texto, te aconsejo que mires en google un manual de vi y te lo imprimas, la primera vez que lo usas es bastante frustrante y cuesta un poco hacerse a como funciona, hay otros editores de texto menos traumaticos para los usuarios de windows pero no me acuerdo de como se llaman ;)

    Pues bien, tienes que buscar por el fichero hasta que lleges a esta parte:

    Section "Device"
    Identier "NVIDIA GEForce 4 (generic)"
    Driver "vesa"

    Cambia vesa por nvidia, quizas te aparezca nv en lugar de vesa, cambialo por nvidia igualmente.

    Ahora busca esto:

    Section "Module"

    Si no tienes esta línea, añádela:
    Load "glx"

    Y quita estos dos modulos:
    Load "dri"
    Load "GLcore"

    Guarda el fichero y vuelve a la shell y ejetuca este comando:

    startx

    Alehop! :) ya deberias de estar en gnome, si por una casualidad te diese un error diciendote que no puede cargar el nvidia kernel, reinicia linux con el comando reboot y pruebalo otra vez. Si no funciona a la proxima dímelo, que te explico como arreglarlo y me estoy extendiendo un webo.

    · Audigy

    Ahora vamos con la Audigy que me ha costado un par de reinstalaciones del RH por follarme el kernel.
    En la página del driver pone que hay que recompilar el kernel y blablabla, yo no lo hago y me funciona.

    Bajate este fichero, con wget como antes:

    wget http://belnet.dl.sourceforge.net/sourceforge/emu10k1/emu10k1-v0.19a.tar.bz2

    ahora descomprimelo:
    bunzip2 emu10k1-v0.19a.tar.bz2

    y desempaquetalo:
    tar -xvf emu10k1-v0.19a.tar.bz2

    ahora tendrás un directorio llamado emu10k1-v0.19a

    Me volví loco para echarlo a andar hasta que di con el problema, que te lo resumo en un comando y no te caliento la cabeza con los detalles :)

    Si tienes Athlon:
    cp /usr/src/linux2.4/configs/kernel-2.4.18-athlon.config /usr/src/linux-2.4.18-3/.config

    Si tienes P4:
    cp /usr/src/linux2.4/configs/kernel-2.4.18-i686.config /usr/src/linux-2.4.18-3/.config

    Ahora escribe estos comandos (estando en el directorio antes mencionado):

    make clean; make; make; make install

    make tools; make install-tools

    Ya tienes instalados los modulos para tu audigy, ahora solo queda un comando por hacer:

    sndconfig

    Te saldrá un menu diciendote que ha detectado tu audigy le dices qu la configure y el programa acaba, ya deberias de tener tu audigy funcionando en linux :D

    PD, soy bastante novatillo en linux, asi que si alguien ve algun error en mi explicacion por favor corregirme ;)



  • 10

    Buà k bien!! como te lo has currado!! vaya crack! gracias tio!, pero una cosa :D para instalar los drivers de nvidia tengo k cerrar el "X" no? como se hace para que no te entre directamente al entorno grafico?

    Esto seria mi ultimo problema, muchas gracias por gastar tu tiempo en esto, muchas gracias tio!



  • 11

    De na, intento ayudar todo lo que puedo si controlo el tema :)

    Por defecto creo que no te entrará en el entorno gráfico, puesto q el X11 no va bien con las GF4 y el driver vesa, te aparecerá la shell a pelo, una vez que pongas el driver y ejecutes la X ya si que te cambia y cada vez que te metas en RH se mete en las X



  • 12

    Pero si yo hace 2 meses k tengo el RH i puedo entrar en el entorno grafico, lo k pasa eske los drivers son de una gefurzia generica i no de mi kerida S/U/M/A :D

    Cada vez k entro a linux me chuta el entorno grafico, o sea k primero tendria k pararlo, luego instalar el Driver i luego starx :D

    Menudo maestro jeje, contestame esto plizzz



  • 13

    Haz el proceso de instalacion desde una shell en las X, luego pulsa CRTL+ALT+BACKSPACE para reiniciar las X y que cargen los drivers nuevos.



  • 14

    Ok, aunke supongo k la "shell" esta, sera la consola.

    Ok gracias



  • 15

    Pues si, supones bien :)



  • 16

    Ok, supongo k ya esta todo aclarado :D

    Ayer por la noche la lie con el server…le meti una RH pero tenia paketes erroneos en el cd i tuve k reiniciar la instalacion 3 veces :( :mad: ... luego puse instalacion pa servidor i ala, a cascarla!, tengo problemas con la tele (el VIAC3 tiene salida tele integrada i no tengo otra pantalla, i no veo bien, supongo k seran los herzios pero mire iestaban a 60...es mu raro, con Windows perfecto, pero con Linux se ve mal...(no me volveria a canviar, eh...xDDD)

    Saludos!!!



  • 17

    A mi tb me ha pasado lo de los problemas de la instalacion, tengo tres paquetes estropeados que tengo que quitarlos para que me funcione la instalacion.
    Lo de la tasa de refresco no se como va, la verdad es que 60Hz es una putada pq te dejas los ojos.

    Por cierto, ponte los drivers de la GF4 que van de lujo, tengo instalados el RTCW y la demo del UT2003 y van cojonudos!!!



  • 18

    Uff que bien!! ya tengo ganas, pero mas problemas, me cargao el boot.ini de windows :D :D estoy hasta los huevos voy a formatear entero el HD!! :p

    No puedo ponerla a mas de 60Hz pq mi tele no lo soporta es tope de vieja…

    Por cierto, como se cambia la resolucion del escritorio? pa poner 1280x960 por ejemplo (es como lo tengo en Win)...

    Salu2





Has perdido la conexión. Reconectando a Hardlimit.