Problema de permisos


  • 0

    necesito una ayudita, a ver si a vosotros os pasa lo mismo en la rasp.

    Los archivos que descargo desde el transmission pertenecen al usuario debian-transmission y viene marcado por defecto que sea solo el el que pueda escribir/modificar esos archivos, es un coñazo, porque por sftp o smb no puedo borrar los archivos que ya me he descargado… y tampoco desde pcmanfm ejecutado a través de ssh...
    Tengo que hacerlo desde root y desde comandos y es un coñazo...

    En el archivo de settings.jason no encuentro nada al respecto...

    Ya de paso, sabéis de alguna forma de desactivar la papelera de reciclaje de todos los usuarios desde la consola?



  • 1

    No se exactamente como lo tendrás configurado. En mi caso con la raspberry no recuerdo ni haber visto nada del usuario debian-transmission, seguramente porque no me influyó para nada en al configuración de todo.

    Lo único que tuve que hacer es configurar la nueva ruta en settings.json y creo que puse como propietario de la carpeta donde se montaba el disco externo (/mnt/descargas) al usuario 'pi' y creo que nada más. Con esto así podía modificar y borrar el contenido descargado por SMB.



  • 2

    No se si esto te servira, pero con el comando 'umask' puedes cambiar los permisos por defecto y supongo que asi podrias borrarlos.



  • 3

    Si, ya se que cambiando los permisos se borra. Es lo que estoy haciendo ahora, pero claro, hacerlo cada vez que descargo algo es muy tedioso.

    Voy a ver si cambiando los permisos de carpeta…

    Edito: La carpeta esta en 777. El problema es que los archivos que crea el transmission solo los puede escribir/borrar el mismo, es decir, el usuario transmission-debian (que es el transmission).

    He buscado por google, y lo que encuentro no es como lo que me pasa a mi... :wall:



  • 4

    Logueandote con transmision-debian, y cambiando el umask de ese usuario te deberia crear los nuevos archivos con los permisos que tu quieres.

    El umask es un valor que se aplica a directorios y archivos nuevos, si umask tiene el valor 122, los archivos se crearan por defecto con permisos 777 - 122 = 655

    Estoy escribiendo de memoria pero creo que funcionaba asi. Y aparte creo que si reinicias, el valor se restablecia, aunque no estoy muy seguro.

    Poniendo el umask a 000, los archivos que te descargues nuevos tendran permisos 777.



  • 5

    Pero cual es la contraseña del usuario debian-transmission?



  • 6

    No se si esa es la solución mas sencilla, pero por si lo quieres intentar lo que tienes que hacer es ponerle una contraseña a ese usuario:

    sudo passwd debian-transmission
    

    y a partir de entonces podrás loguearte con el, pero no se, me da a mi que tiene que ser algo mas sencillo que se nos pasa.



  • 7

    Aún cambiando la pass no puedo conectarme:

    Kromann-AIR:~ ingeniebrio24$ ssh debian-transmission@192.168.1.24
    debian-transmission@192.168.1.24's password:

    The programs included with the Debian system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.

    Debian comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
    applicable law.

    Welcome

    • Documentation:

    6 packages can be updated.
    6 updates are security updates.

    The programs included with the Ubuntu system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.

    Debian comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
    applicable law.

    Last login: Mon Mar 25 21:32:34 2013 from 192.168.1.15
    Could not chdir to home directory /home/debian-transmission: No such file or directory
    Connection to 192.168.1.24 closed.
    Kromann-AIR:~ ingeniebrio24$



  • 8

    Según he visto esto en Forocoches:

    Instalar Transmissión (probado en Raspbmc)

    • Crear una carpeta para almacenar las descargas (enchufando el HD al pc, o mediante ftp).

    • Entrar en modo consola. Pulsar botón apagar en xmbc y la opción salir del menu emergente, una vez hecho esto pulsar boton ESCAPE repetidamente. Ya en la consola introducir usuario y contraseña.

    • Instalar tasnmission-daemon : "sudo apt-get install transmission-daemon".

    • Parar demonio: "sudo /etc/init.d/transmission-daemon stop"

    • Editar el fichero settings.json : "sudo nano /etc/transmission-daemon/settings.json":
      cambiar "rpc-whitelist": "127.0.0.1" a "..."
      cambiar "rpc-password": "contraseña",
      cambiar "rpc-username": "usuario",
      cambiar directorio de descargas "download-dir" por el que hemos creado en el paso 1, ej: “/media/usb0/descargas”,

    • CRTL + X para guardar.

    • Restaurar demonio: "sudo /etc/init.d/transmission-daemon start"

    • Dar permisos al directorio de descargas :
      "sudo chmod g+rw /media/usb0/descargas" (o todos los permisos con sudo chmod 777…)
      "sudo chgrp -R debian-transmission /media/usb0/descargas"

    • Restaurar xbmc

    Para añadir y ver el estado de las descargas desde el navegador "ipDelRaspberry:9091" con el usuario y contraseña del fichero settings.json.

    Fuente: [LIVE] HOW-TO get BitTorrent download/management via WebUI Guide working on XBMC Live

    hacen al grupo debian-transmission propietario del directorio de descargas, no se yo entonces si valdría con meter al usuario 'pi' en ese grupo.

    La verdad es que yo también me hago un lío de narices con los permisos, sobre todo en Apache o Lighttp.





Has perdido la conexión. Reconectando a Hardlimit.