W10 AU deja fuera de combate las webcams.


  • 0

    Tal y como expone éste artículo en ArsTechnica, al parecer la última actualización del flamante sistema operativo de los de Redmond deja inutilizadas las webcams conectadas tanto por USB como por IP.
    Según se explica, el problema radica en cómo el SO gestiona el acceso a los recursos de los dispositivos en cuestión; anteriormente, el dispositivo era utilizado en exclusiva por una sola aplicación, impidiendo el acceso a otras que lo necesitaran a menos que la primera se cerrara.
    W10, por el contrario, sí permite compartir el acceso a tales dispositivos de forma simultánea, implantando lo que se ha venido a llamar Windows Camera Frame Server, incorporado en la versión 1607.
    Es éste servicio, cuyo mal funcionamiento se debe a un error no reportado referente a la compresión de datos, el causante del problema.



  • 1

    Joer, no recuerdo un Windows con tantos problemas. Ese en concreto no me afecta, pero ya me da miedo arrancar Windows no vaya a joderme también Linux Mint como me hizo la TH2.



  • 2

    A la espera del parche que arregle el desaguisado por parte de Microsoft, se ha publicado una solución no oficial al problema:
    (Cortapega de WccFTech)

    • En primer lugar, ejecutar el editor del registro. ("Win+R", teclear regedit y pulsar "Intro")
    • Desplegar HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows Media Foundation > Platform.
    • Dentro de Platform pulsamos con el botón derecho para acceder al menú Nuevo y seleccionar Valor de DWORD (32-bit)
    • Nombrar el valor como EnableFrameServerMode y darle un valor de 0.

    A partir de aquí es sólo para la version de 64 bits de Windows.

    • Desplegar HKEY_LOCAL_MACHINE > SOFTWARE > WOW6432Node > Microsoft > Windows Media Foundation > Platform
    • Igual que anteriormente, añadimos un valor DWORD y lo nombramos como EnableFrameServerMode e igualmente le damos un valor de 0.

    Una vez reiniciemos, deberíamos ser capaces de acceder a nuestras cámaras con normalidad.





Has perdido la conexión. Reconectando a Hardlimit.