Prueba y compara el rendimiento de tu PC con nuestro banco de pruebas.

Cambiar la resolucion



  • Bueno, pues mi problema es que he instalado Mandrake 9.1 con el Virtual PC ya que estoy empezando con linux y de momento lo tengo instalado así. El problema es que he ido a cambiar la resolución de la pantalla en mandrake y la he puesto a 1024 x 768 y 15 bit de profundidad de color y ahora no arranca. Estoy prácticamente seguro que es porque el Virtual PC simula tener una tarjeta gráfica S3 en plan peete que te cagas y entonces no debe de aguantar el modo de pantalla que le he puesto. He arrancado en el modo seguro en modo texto pero no encuentro donde configurar la resolución con la que quiero que arranque el KDE o el GNOME.

    Una ayudita…........



  • Prueba escribiendo esto "XFree86 setup" (sin comillas), con esto configuras un montón de cosas relacionadas con el entorno gráfico (entre ellas, la resolución:p)



  • Hola, has de editar el archivo /etc/X11/XF86Config y cambiar en el default la primera resolucion por la que quieras, ahora tendras 1024x768 esa la dejas parale final y delante poner 800x600 por ejemplo, si quieres cambiar el color pon el dafult a la calidad de color que quieras.

    Saludox: Rolling.



  • Bueno, pues estoy en estos momentos mirando el archivo que me has dicho, Rolling y no se exactamente donde te refieres.
    Hay una primera parte llamada section "Monitor" en la que no creo que tenga nada que ver, solo aparecen las caracteristicas del monitor.
    Luego está section "Device" en la que como me imaginaba pone que detecta una S3 en vez de mi GeForce2:
    Identifier "device1"
    VendorName "S3 Inc."
    BoardName "S3 Trio64 (generic)"
    VideoRam 4096
    Option "power_saver"

    Y luego está la seccion "Screen" que me imagino es la que me importa.
    En esta pone que el color esta a 15 bits por defecto pero no pone ninguna resolucion. Y luego en la subseccion de 15 bits de color estan las resoluciones 1024x768, 800x600 y 640x480.

    Voy a poner por defecto 8 bits y en la subseccion de 8 bits voy a eliminar la resolucion de 1024. Espero que funcione.



  • Pos no, he puesto por defecto a 8 bits y le he puesto que en 8 bits solo soporte 800x600 y 640x480 (bueno, creo que he hecho eso) y al arrancar cuando devería ya entrar en KDE se pone a 1024x768 y se cuelga.

    Ayudarrrrrrrrrrrrr😕



  • Hola, mira solo hay que cambiar esto:

    Y luego está la seccion "Screen" que me imagino es la que me importa.
    En esta pone que el color esta a 15 bits por defecto pero no pone ninguna resolucion. Y luego en la subseccion de 15 bits de color estan las resoluciones 1024x768, 800x600 y 640x480.

    Esto ultimo es el orden de carga de resoluciones, entonces por defecto te carga 1024x768, si quieres 800x600 debe estar asi: "800x600" "640x480" "1024x768" (por ejempo) siempre te carga la resolucion que tienes puesta la primera.

    Al margen de esto si tienes y gforce y metes un controlador de s3 creo que se te cuelga por eso, no creo que sean compatibles (pero prueba).

    Saludox: Rolling.



  • Pues eso es lo que hize y no funcionaba. Al final volvi a instalarlo. Y lo de la S3 esque no hay mas remedio ya que el VirtualPC simula tener una S3.

    Gracias de todas formas.



  • pon 16 bits…i una resolucion de 800x600, supongo k arrancara...prueba asi:

    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"Generic Video Card"
    	Monitor		"Generic Monitor"
    	DefaultDepth	16
    	SubSection "Display"
    		Depth		16
    		Modes		"800x600"
    	EndSubSection
    EndSection
    
    

    Tambien tendrias k tener cuidado en la seccion donde se ponen los herzios i demas…

    Suerte! 😛

    Salu2!



  • No se, ya está reinstalado y lo tengo a 800x600x16. Me gustaría tener a 1024x768 ya que es a lo que estoy acostumbrado y a 800x600 me parece todo enorme pero bueno, para eso tendré que hacer una instalación normal. A ver si le hecho una tarde y lo hago.

    De todas formas hize lo que dice marcalj solo que puse 8 bits en vez de 16 y no funcionaba. Igual habia petado otra cosa…....no se.

    Gracias de todas formas chicos.


Accede para responder