Radeon9000 en RedHat 9.0


  • 0

    Despues de unos dias intentando configurar esta version de RedHat para modo gráfico, pos ke no puedo!!!!
    A ver si alguien me echa una mano y me puede decir como configurar las X para ke me entre en modo grafico, la cuestion es ke la radeon9000 me la reconoce, pero a la hora de acer el startx, pos da un error y no inicica en modo grafico!! me estoy volviendo loko ya!!

    saludos



  • 1

    se me olvidaba, me he bajado los drivers de ATI "fglrx-glc22", pero no consigo instalarlos, cuando los intento ejecutar con rpm -i <driver>, pos me dice no se ke de ke no encuentra glob, joer ke lio!! esta es mi primera instalacion de linux y me estoy volviendo loko!! y lo ultimo, e mirao por aki, y e leido ke ejecute fgrlxconfig para poder cambiar las opciones de video, pero na, ke no lo encuentro por ningun lao y ya no se ke acer!!
    UNA AYUUUUUUDA</driver>



  • 2

    a mi me paso lo mismo con una 9500 y el tema es el siguiente…
    los drivers de ati vienen para xfree 4.1 o 4.2 y un sistema basado en libc2.2 y la redhat 9 (q me costo 1 dia bajar) trae xfree 4.3.noseque y esta basado en libc2.3...por eso te dira q tururu los drivers asi q a esperar q ati saque unos drivers mas actualizados o usar una distro mas vieja...yo ahora tengo una debian 3 (woody pa los amigos) y la grafica me va de pm



  • 3

    y con la devian 3 ni un problema de drivers ni nada? es ke si es eso me la cambio pero rapidamente…. porke me estoy volviendo un poko mas loko aun, jeje!! tambien e leido por ahi ke con la mandrake 9.1 no da ningun problema, asi ke me parece ke voy a cambiar...
    muchas gracias

    Saludos



  • 4

    mi me paso lo mismo con una 9500 y el tema es el siguiente…
    los drivers de ati vienen para xfree 4.1 o 4.2 y un sistema basado en libc2.2 y la redhat 9 (q me costo 1 dia bajar) trae xfree 4.3.noseque y esta basado en libc2.3...por eso te dira q tururu los drivers asi q a esperar q ati saque unos drivers mas actualizados o usar una distro mas vieja...yo ahora tengo una debian 3 (woody pa los amigos) y la grafica me va de pm

    umm..para xfree 4.3 ya hay drivers..
    http://www.schneider-digital.de/html/download_ati.html la ultima version 2.9.12

    un saludo.



  • 5

    Publicado originalmente por l3g0r
    **

    mi me paso lo mismo con una 9500 y el tema es el siguiente…
    los drivers de ati vienen para xfree 4.1 o 4.2 y un sistema basado en libc2.2 y la redhat 9 (q me costo 1 dia bajar) trae xfree 4.3.noseque y esta basado en libc2.3...por eso te dira q tururu los drivers asi q a esperar q ati saque unos drivers mas actualizados o usar una distro mas vieja...yo ahora tengo una debian 3 (woody pa los amigos) y la grafica me va de pm

    umm..para xfree 4.3 ya hay drivers..
    http://www.schneider-digital.de/html/download_ati.html la ultima version 2.9.12

    un saludo.

    acabas de hacerme el tio mas feliz del mundo l3g0r :D :D :D :D :D :D
    a instalar una redhat 9 se ha dicho

    **



  • 6

    ya tengo instalados los drivers, aora ya me entra en el escritorio!! pero es ke me pasa lo siguiente: ejecuto "fglrxinfo" y todo de pm, me reconoce la radeon 9000 y toa la leche, pero si ejecuto "fglrxconfig" y activo el puerto AGP (agpgart), pues se me raya y no me sale nada, me tocó reinstalar; ademas, cuando estoy en el escritorio, en las propiedades de la pantalla, me coje los drivers pero no me reconoce la tarjeta de video, me pone desconocida… y los colores me salen como atenuados, eso porke es? porke ya no se ke mas tocar, una ayuuuuuuuuda!!

    saludos



  • 7

    galvan cuales has bajado??

    a ver si lo arreglo de una vez :P

    SAlu2

    EDITADO: ya he bajado los 4.3, a ver si lo instalo



  • 8

    Estoy con la version 4.3 de XF86 en Mandrake 9.1y tras instalar los drivers de ati todo sin problemas, salvo q los colores se ven de una manera muy rara, como con mucho brillo,he probado a ponerle diverentes resoluciones y numero de colores,pero na de na siguen los colores raros, me parece qw voy a tener q meterle los drivers vesa otra vez q estos no daban ningun problema. Si a alguien le pasa lo de los colores y logra resolverlo q eche una manita please.



  • 9

    a mi me pasa lo mismo leo, y yo e instalao redhat 9.0, los colores me salen con mucho brillo tambien y al final acabas medio ciego!! como cambias a modo VESA? cambiandolo desde las propiedades y ya esta? o acen falta algunos drivers? si me dices ke en modo vesa se ve bien me lo cambio yo tambien, porke tener los colores asi en una mierda!!

    SALUDOS



  • 10

    Pues lo de cambiar a modo vesa para mi fue muy sencillo, ya q la mandrake me instalo por defecto este modo y tan solo tuve q hacer copia de seguridad del fichero XF86Config-4 antes de ejecutar el fglrxconfig, siento mucho no poder darte excesiva informacion por q la verdad es q estoy empezando a aprender a usar linux y por eso tras varias instalaciones de debian,linex y knoppix pase a usar mandrake, q me funciona (al menos a mi) todo a la primera y tiene unas herramientas de configuración muy sencillas de usar, incluso para alguien q tiene tan poquita idea como yo.Asi q fue instalarlo y empezar a cacharrear y leer mucho para procurar no meter la pata en exceso. En modo vesa me funciona todo correctamente y se ven los colores bien.

    Si alguno tiene informacion de como quitar lo de los colores brillantes echar una manita ;)



  • 11

    Pues parece q he encontrado una forma de mitigar al menos lo de los colores brillantes. Para hacerlo hay q usar un panel de control q viene con el driver y se instala en /usr/X11R6/bin y el archivo se llama fireglcontrol.qt3.gcc3.2 Tras usarlo (estando dentro del servidor gráfico) nos muestra un panel de control con informacion de nuestra tarjeta, la posibilidad de activar la opcion de varios monitores y adjustment, q desde alli podemos modificar gamma correction. A mi los valores q me funcionan son de 0.20 para los tres colores. Con este ajuste es posible seguir trasteando sin dejarse los ojos :) pero aun noto falta de nitidez en pantalla, seguire trasteando a ver si hay manera. Se agradece cualquier tipo de ayuda. ;)

    En modo vesa se sigue viendo mucho mejor



  • 12

    Otro problema q tengo con los drivers de ati,si toco la correccion gamma para no dejarme los ojos con el brillo de los colores en las X al salir de estas y entrar en modo consola no se ve apenas el contraste de las letras con el fondo. Asi q he decidido cambiar a modo vesa, a ver si alguien con una ati radeon 9000 le funciona este driver en las Xfree 4.3 correctramente y echa un cablecito.



  • 13

    a mi me pasa lo mismo leo, yo al final tambien e decidio cambiar a modo VESA, aunke aora parece ke tengo mucho parpadeo en el monitor para los colores claros!! eso sabes porke puede ser?

    saludos



  • 14

    Lo del parpadeo del monitor puede ser debido a la fracuencia de refresco q le tienes puesto,a mi ahora mismo m va bien pero alguien puede decirme como cambiar la frecuencia de refresco de las X? por ejemplo mi monitor admite 85Hz a 1024x768 pero las x me lo pone a 50 y quisiera subirla un poco.



  • 15

    pues no tienes más que echarle un vistazo al /etc/X11/XF86Config y mirar como tienes el monitor, eso sí tienes que saber el refresco vertical y la sincronización horizontal, aquí te pongo mi configuración del monitor, pero la mía está a 75Hz:

    Section "Monitor"
            Identifier   "Monitor0"
            VendorName   "Monitor Vendor"
            ModelName    "StudioWorks"
            DisplaySize  280        210
            HorizSync    30.0 - 61.0
            VertRefresh  50.0 - 120.0
            Option      "dpms"
    EndSection
    
    


  • 16

    Me acabo de instalar los drivers en la red hat 9.0 y me salen los colores perfectamente, no he tenido que tocar nada y el Open GL va como un tiro de rápido



  • 17

    bufff, acabo de probar la demo del ut2003 y va que te cagas, aunque hecho de menos el overclock:( ¿Cómo puedo overclockear mi ati en linux?



  • 18

    bluesman, he mirado el archivo XF86Config y lo tengo todo bien, con los refrescos ke tocan, pero me sigue parpadeando, no se porke será!! otra cosa, ke grafica tienes?? yo tengo una radeon 9000 y tengo los problemas con los colores, ke me salen como con mucho brillo!! otra cosilla: cuando instalaste los drivers y ejecutaste el fglrxconfig, activaste el agpgart? yo si lo activo se me raya y se me ve la pantalla negra (me tocó reinstalar porke no me entraba ni en modo consola)

    bueno, a ver si soy capaz de configurar bien las x de una vez, porke aora estoy en modo vesa!!

    salu2



  • 19

    Pues tengo una 8500LE, que me la reconoce perfectamente, después de instalar los drivers hice fglrxconfig y no activé el agpgart. Lo hice así y me va de vicio, no veas como va el ut2003 y el wolfenstein, mejor que en win.





Has perdido la conexión. Reconectando a Hardlimit.