Gentoo…problemas con el escritorio..


  • 0

    Despues de muchos intentos consegui instalar gentoo, con acceleracion 3d…...pero....cuando estaba jugando a enemy-territory se atasco. Y ahora no me arranca el escritorio...:susto:

    Fatal server error:
    Cannot open log file "/var/log/XFree86.0.log"

    When reporting a problem related to a server crash, please send
    the full server output, not just the last messages.
    Please report problems to xfree86@xfree86.org.

    giving up.
    xinit: No such file or directory (errno 2): unable to connect to X server
    xinit: No such process (errno 3): Server error.

    alguna solucion? solo por atascarse las x ya se jode todo:vayatela: (antes andaba bien asta que se atasco con el juego).

    Un saludo.



  • 1

    El juego habra desconfigurado algo de las xfree o del drivers…

    Intenta reinstalar los drivers de la grafica.
    Si es nvidia:
    emerge nvidia-kernel
    emerge nvidia-glx
    Si es ati ni idea :confused: xD

    Si pones startx que salida te da?

    Para asegurarse de que es un problema de drivers edita el XF86conf (/etc/X11/) y pone de driver vesa en la seccion device:

    Section "Device"
    Identifier "name"
    Driver "vesa"
    entries

    EndSection

    Si haciendo esto te inicia te aseguras de k las xfree estan bien (y te evitas volver a emergerlas que son un webo de horas :D )

    salu2!



  • 2

    1- tengo ati 9500@9700
    emerge ati-drivers ..pero sigue igual

    2- el error ke e puesto es cundo ago startx

    voy a probar instalar otra vez xfree86….luego a la noche cuando duermo...que esto de compilar suele tardar bastante:):risitas:

    Un saludo.



  • 3

    umm creo ke la liado gorda….:susto:

    aber los modulos ke se me cargan al inicio tampoco me andan...(nvnet..) tengo que quitarlos
    rmmod nvnet
    insmod nvnet

    y entonces si funciona y eso:confused: ?

    luego tambien e intentado mirar si estaba el archivo , el que dice Cannot open log file "/var/log/XFree86.0.log"

    pues entro en /var/log….ago un ls-l y ...:

    ls: cups: Permission denied
    ls: pwdfail: Permission denied
    ls: XFree86.0.log: Permission denied
    ls: emerge.log: Permission denied
    ls: lastlog: Permission denied
    ls: XFree86.0.log.old: Permission denied
    ls: kernel: Permission denied
    ls: everything: Permission denied
    ls: telnet: Permission denied

    eso como "root".:vayatela:

    creo que la e liadoooo gordaa….:rabieta: :rabieta: :rabieta: ke coño pasa ...con lo que me a costado poner todo ahora no ba:vayatela: :nono:

    Un saludo.



  • 4

    las x no se han desconfigurado (seguro) este solo es un problema endemico de win
    lo que ocurre es que no se ha terminado apropiadamente un programa
    me extraña mucho que como raiz no puedes leer un archivo (es imposible)
    prueba a eliminar el XFree86.0.log.old para que lo cree de nuevo y tirar p'alante de todas maneras como pone en tu log prueba a

    When reporting a problem related to a server crash, please send
    the full server output, not just the last messages.
    Please report problems to xfree86@xfree86.org.

    cuando informes de un problema debido a un fallo en el servidor porfavor envie la salida completa del servidor no el ultimo mensaje



  • 5

    pues nose..e estado mirando y parece que a algunos archivos se les a cambiado los permisos:susto:
    no me deja cambiar los permisos de los archivos… por ejemplo:XFree86.0.log

    cuando estaba jugando a wolf...estaba como root:rolleyes: (cuando se atasco)
    tengo reiserFs y el kernel 2.4.22..

    pasa algo raro con los archivos creo que hay esta el problema....que no tengo permiso..

    me da ami que tendre que empezar otra vez la instalacion....:muerto:

    Un saludo.



  • 6

    Publicado originalmente por l3g0r
    **cuando estaba jugando a wolf…estaba como root :rolleyes: (cuando se atasco)
    tengo reiserFs y el kernel 2.4.22..
    **

    Uf, entonces esta chungo… el ReiserFs es muy sensible y si ademas jugabas como root.. :vayatela:

    Weno, yo no se que hacer para ayudarte, solo te recomiendo que si tienes que reinstalar gentoo lo hagas con este script:

    http://glis.sourceforge.net/

    Es muy sencilla la instalacion ;)

    salu2!



  • 7

    gracias por el script:sisi:.
    con este script te configura el make.conf?

    Un saludo.



  • 8

    Sip, todo queda configurado al final de la instalacion :sisi:





Has perdido la conexión. Reconectando a Hardlimit.