No me funca el LCD(hd44780)


  • 0

    Hola a todos, antes ke nada, el sitio es genial, asi ke felicitaciones a sus creadores.
    Bueno, soy de Argentina y aca me resulto casi imposible encontrar LCDs, no HAY! (menos ahora con el 4$ = 1 USS), asi que opte por la mas peligrosa, barata y malvada opcion de todas:
    me tope con un LCD hermoso de 20x2 justo cuando iba caminando… encontre un telefono publico de ******* y bue!
    en menos de 8 minutos ya tenia el lcd en mis manos...(no recomiendo hacerlo ya que se requiere de hacer algo de ruido y algo de idea, ademas es ilegal!!!!!)

    en fin conecte todos los cables en la manera en la cual se explica en un articulo de esta pagina, pero no funca
    NO LOGRO VER ESE MALDITO RENGLON ACTIVADO CUANDO ALIMENTO EL LCD!!!!!!, o sea: cuando le doy power, no hace nada...
    QUE PASA?
    los cables estan bien...(si es que estan bien publicados, aunque creo que si)
    Bueno, mis preguntas son,ademas,las siguentes...
    1.¿deberia resignarme y dejar de producir inconvenientes a la empresa?
    2.Puede ser que mi modelo no encienda o muestre señales de vida cuando lo prendo?(es un Optrex con el Hd44780A00 y es de 20x2 con luz, 16 pines)
    3.¿me equivoco y en realidad no tiene por que hacer nada cuando lo enciendo, en realidad es un programa el que lo hace mostrar eso?
    4.¿habre quemado el LCD?(mm...)(dificil quemar 2 veces lo mismo...)(si es asi, ¿hay alguna manera de saber si esta quemado?)
    5.¿que programa me recomiendan para manejar el lcd?(el lcdriver es excelente, debido a que programo en Visual Basic, y el driver tiene el dll ya hecho para que funcione...)
    Bueno, me excedi un poco, pero estoy desesperado!!!!!!!!!!!!!!!
    hace ya como 3 meses que vengo renegando y no logro nada!!!!
    Lo quiero poner(cuando funcione) en mi F-100, pero si no funca ni me gasto en poner la PC arriba, no vale la pena una PC sin visualizacion!
    Bueno, hasta la proxima!!!!
    Bytes!



  • 1

    pero le has metido el programa smartie??? te digo ese poruqe es el que yo utilizo… no se como dices que "a lo mejor es un programa lo que le hace funcionar..." si le has metido dimelo y segiremos en contacto...

    paus2k@hotmail.com



  • 2

    Pues, a lo que me refiero diciendo que lo hace funcionar es a que lo hace mostrar esa liñita rellena, o sea mas tecnico activa los 7x3 puntos de los veinte caracteres de arriba!
    No me funciona, tengo 2 lcds y ninguno funciona, el programa smartie no lo conozco pero ya mismo intento conseguirlo…
    Antes que nada gracias por todo
    bytes



  • 3

    el programa de los puertos port95?
    epp en la bios?
    que esquema seguiste?
    Windows, linux version?

    lamento acribillarte a preguntas pero… es la unica forma



  • 4

    A mi me paso lo mismo y era porque tenía el contraste al minimo!!!

    Con ese LCD te devería funcionar

    El Smartie esta en http://www.rendo.dekooi.nl/~fjbgp/smartie/ que por cierto haber si sacan la nueva versión de una p. vez y arreglan el fallo en el XP

    Dinos más datos..



  • 5

    Pero de la retroiluminacion que se kite, que los de ****fonica… como ke no tienen luz en las cabinas...

    (Weno vale la luz fluorescente que hay en el techo de estas... :D )

    Yo tambien estoy montado el LCD y el programa ese ke hay que pedirle a MAZ lo tiene alguien? Esk pa ke me lo ruleis! :p



  • 6

    Bueno, no! el port95 sirve?
    lo baje hace unos dias pero no me parecio gran cosa,
    el lcd "era" de ****com, no de ****fonica, ademas , aca (argentina) lo de ****fonica tambien tienen luz pero son de 16x2, por eso opte por el otro….
    bueno, volvamos a lo nuestro...
    todo ok Shilmar, no me molesta responder...SI ESTO ES UN FORO!!!!
    segui los dos esquemas shilmar,bajo windows Me,pero bajo 98se tampoco quiso...
    ni idea lo ke es la epp shilmar, explica!!!!!!
    K74:
    Segun lei en otro lado, el contraste esta al maximo cuando tiras el pin 3 a tierra, y al minimo en 5v.
    ¿medio ilogico eso no? pero bue!
    ahi lo baje al smartie, vamos a ver...
    mi pregunta ke hasta ahora nadie respondio es la siguente:
    Yo tengo el lcd con todos los cables conectados, excepto el pin2(el que lo alimenta), el LCD conectado al LPT1, y todo listo
    AHORA, conecto el pin 2 al positivo(numero 4) del moltex(¿era asi?) y ¿TIENE QUE APARECER LA LINEA DE ARRIBA NEGRA(o sea activada)? o ¿el display no tiene por que hacer nada, no da señales de vida?
    bueno, disculpen si tarde, pero esta pagina no me manda mas los mails para avisar que me responden, estare mas alerta!!
    como siempre
    Bytes BrunoF-01100100(o sea 100 en binario 8 bits sin signo, creo ke era asi en binario, ha pasado ya tanto tiempo...)



  • 7

    EStube averiguando sobre ese lcd, fijate que el que seria el pin 16 es el 1, o sea va al revez



  • 8

    cheeeeeeeee, me explicas detalladamente como sacarlo…...pq no puedo



  • 9

    Sí, tiene que aparecer la línea negra al alimentar el LCD. Lo hace él solo, y no un programa….



  • 10

    En este aparece una rayita, ah..ya lo consegui y me anda de 10



  • 11

    Bueno pibe, realmente con esto te solucione la vida… aca te voy a poner el link del datasheet de un display igual, si te fijas las conecciones utilizadas son totalmente diferentes, o sea, ponele, para la luz lo controlas con el 1 y 2, aca te dice bien cual es cual, y lo puenteas como en el esquema de amd4ever solo que siguiendo los pines que te dice en el pdf este, es muy facil, y se ve tremendo en mi pc jajaj, y le hize lo de dar vuelta el plastico, fondo negro letras verdes queda sensacional...
    EL Link aca =)



  • 12

    esto es un poco offtopic pero illegalStuffCor como se hace lo de dar la vuelta al plastico y q se vean las letras en verde y el fondo negro??alguie sabe si eso se puede con el de microcontroladores??de 20x4 es que yo abri el mio y habia x hay un plastico pero estaba pegado y me acojono despegarlo.

    SALU2





Has perdido la conexión. Reconectando a Hardlimit.