Configurar eth0 con DHCP



  • Tengo por fin mi tarjeta de red detectada por mi debian y se con el commando "ifconfig" asignarle una IP, una mascara de red y cosas por el estilo, pero esque este interfaz tiene que estar configurado por DHCP y eso si que no se como se hace.

    En mandrake o SUSE hay un centro de control en el que se puede configurar todo esto, pero en debian solo encuentro un centro de control mas "ligero" (no pide pass de root ni na) en el que no se puede configurar nada de nada de esto.



  • Pues para configurar tu tarjeta de red (eth0) con DHCP tienes que modificar el archivo /etc/network/interfaces

    Si editas ese archivo tienes que tener aalgo parecido a esto (este es mi /etc/network/interfaces):

    –------------------------------------------------------------------------------------

    /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

    The loopback interface

    automatically added when upgrading

    auto lo eth0
    iface lo inet loopback

    iface eth0 inet static
    address 192.168.1.4
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1

    Debes de modificar la línea "iface eth0 inet static" y cambiarla por "iface eth0 inet dhcp". Las líneas que hacen referencia a la mascar ade red, gateway, etc... comentala o eliminala. A modo de ejemplo el archivo anterior podría quedar así::


    /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

    The loopback interface

    automatically added when upgrading

    auto lo eth0
    iface lo inet loopback

    iface eth0 inet dhcp

    address 192.168.1.4

    netmask 255.255.255.0

    network 192.168.1.0

    broadcast 192.168.1.255

    gateway 192.168.1.1


    Saludoss



  • Bueno, he echo esto que me has dicho pero no me pilla automáticamente un IP la tarjeta.

    He probado con un "ifconfig eth0 down" y "ifconfig eth0 up" y nada.

    He reiniciado y tampoco.

    Hay algo que me falta, que puede ser?



  • No estoy seguro.. pero creo que el probleme viene que si durante la instalación de debian no configuras la tarjeta de red con dhcp, no se instala el cliente dhcp. ¿alguien puede confirmarlo?

    Te dejo un enlace que te será de utilidad. http://www.onlytools.org/docs/dhcp.php

    Saludoss



  • Con esto:

    auto eth0
    iface eth0 inet dhcp
    
    ```Debería funcionar ya, bajas la interfaz (ifdown eth0), la subes (ifup eth0) y entonces debería ejecutarse él sólo el 'dhclient' que es el que pide ip.


  • Como bien ha dicho josefu, necesitas el "dhclient".

    Esto es un cliente de DHCP. Al dar de alta la tarjeta con "ifup eh0" se llama al dhclient que es el encargado de obtener todos los datos de la configuración de la red automáticamente.



  • Bueno, pues como no sabia si ya era problema de la red o el cable-modem y queria arrancar de nuevo el xmule instale mandrake en otra particion y funciona perfectamente.

    Entonces ahora estoy intentando volver a arrancar debian para probar las cosas que me habeis dicho pero no lo consigo.

    Las particiones de debian las tengo montadas en mandrake de la siguiente forma:
    /debian
    /debian/boot
    /debianhome

    En el lilo.conf he añadido:

    **
    image=/debian/boot/bzImage
    label=debian
    read-only
    **

    Arranco, elijo debian y lo empieza a arrancar pero me da el siguiente kernel panic:
    No Init found . Try passing init=option to kernel

    Que es lo que me falta??? Le tengo que indicar en algún lado la particion raiz (osea: "/debian")????



  • Bueno, ya he arreglado lo del LILO.

    He reinstalado debian seleccionando dhcp en la instalacion pero sigo igual, no me coje la IP.

    He mirado el /etc/network/interfaces y pone exactamente lo que dice josefu.

    Me he mirado el enlace que me ha puesto Rockman y hay una cosa que no tira bien.

    Al ejecutar dhclient deberían salir unos mensajitos pero no sale nada. Simplemente acepta el comando y no dice nada.

    Puede que con alguna version más moderna de este cliente funcione??



  • Despues de que dhclient termine, comprueba la configuración con "ifconfig -a" y comprueba que eth0 tenga asociada una dirección ip.



  • De momento tengo aparcado el tema ya que estoy tirando con mandrake pero al final instale el paquete actualizado.

    Entonces al ejecutar el cliente me daba un error y me decia que seguramente me faltaban dos modulos del kernel. Lo recompilé con esos modulos y me da el mismo error. Desde ahí lo tengo aparcado ya que estoy con otras cosas, pero en breve me pondré otra vez a darle vueltas.



  • Nunca he usado dhcp, pero si no recuerdo mal, para pedir una Ip habia que ejecutar
    #dhcpcd eth0

    ademas en el archivo de interfaces de red (normalmente /etc/conf.d/net )
    deberias tener alguna linea que ponga
    iface_eth0 =" tu ip bla bla bla."

    Comentala y en su lugar pones
    iface_eth0 ="dhcp"

    Como te digo hablo de memoria.

    Suerte

    Un slaudo.



  • Bueno, pues he vuelto a recompilar por 5ª o 6ª vez el kernel y he metido dos o tres modulos más y ahora si que ya me pilla la IP perfectamente.

    Joer, esque esto de linux a mi cada vez me mola más pero hay que tener paciencia para parar un tren. Normal que muchas gente le tire para atras.


Accede para responder
 

Has perdido la conexión. Reconectando a Hardlimit.