Me voy a instalar Gentoo!


  • 0

    Bueno, pues este será mi segundo intento pero espero no tener ningún problema ya que ahora en vez de seguir un manual anticuado en español, seguiré las actualiazadas instrucciones de inglés (menuda putada cuando supe que era por eso jeje).

    Ahora mismo estoy apunto de desconectarme para reiniciar e instalar Gentoo así que si no sabeis nada mas de mi durante las próximas 48 horas es que he perecido en el intento :muerto:

    Ya he resuelto por el Messenger y el Jabber las pocas dudas que me quedaban aunque todavía tengo una…

    Durante la instalación permite instalar paquetes adicionales orientados especificamente a hardware como por ejemplo los drivers para nforce, los de la audigy/live, los de la ati, etc...

    Y yo pense, pos me instalo los emu10k1 para mi Audigy, mira que bien... pero trasteando por la página de los drivers veo que están menos actualizados que los drivers para Audigy de ALSA... así que aunque no los voy a instalar hasta que no tenga ya el sistema, me gustaría ir sabiendo vuestras opiniones al respecto porque francamente no se que elegir.

    Bueno eso es todo, un saludo y deseadme suerte! :)

    PD: Menuda revolución GNUera de gentooza últimamente por el foro no? xD



  • 1

    Yo seguiré con mi debian ;)

    Suerte



  • 2

    Pues por ahora es con la distribucion que mas estoy durando (aparte de que me lleve 2 semanas para compilar el nucleo.. pero bueno) Y tras varios intentos de instalacion he llegado a la mas estable :)

    De todas formas me faltan algunos retoques, que poco a poco iré arreglando (por ejemplo todavia me sigue dando el kernel al iniciar un error de que el modprob no encuentra el modulo /dev/rtc…), de todas formas para instalar gentoo es necesario tener una buena conexion de internet, por que sino no merece la pena (yo con ADSL y algunas veces me pienso el instalar algunas cosas pesadas... por que entre descargar 50 mb y luego ponerse a compilarlos :D:D:D)

    Y nada, por ahora todo perfect y muy rapido :) La verdad que es de las mejores distribuciones que he conocido una vez que lo tienes todo bien configurado (aunque cualquiera bien configurada es parecida o igual a esta... :rolleyes: )

    Pues nada, animarte a que lo hagas y aunque falles que sigas intentandolo, y si tienes dudas, creo que hay 3 personas (yo me incluyo) que usan gentoo en estos foros :)

    PD: Anoche puse la webcam y ya me funciona :) Toy aprendiendo y se nota



  • 3

    Bueno, en realidad lo tengo desde ayer… pero me tiré toda la noche emergiendo para tener un sistema decente (todavía me quedan semanas emergiendo hasta tenerlo todo a pedir de boca pero lo confieso, en realidad me encanga xD

    La verdad es que no se si es por el ReiserFS, por el kernel compilado a medida o yo que se, me da igual... el caso es que la diferencia de velocidad no es brutal pero se nota claramente. Configurar las X desde la consola no fue para tanto y en una hora ya tenía configurado el sonido con ALSA, la rueda del ratón funcionando y la conexión a Internet configurada... el resto fue emerger y emerger :)

    Que os voy a decir, que he encontrado todo lo que me esperaba de el y que por el momento me encanta, por fin puedo decir que lo tengo!

    No obstante instalarlo no fue un camino de rosas y tuve que lidiar con algún que otro imprevisto, por ejemplo grub me daba un fallo de segmentación y tuve que usar lilo y corregir algunas cosas que no están bien en la guía, pero por lo demás el segundo intento no ha sido tan traumático :)

    Todavía me queda buscar por ahi como se hace para que detecte la grabadora como tal (era algo de añadir una línea al lilo y de activar la emulación scsi pero no recuerdo exactamente) y solucionar un problema tonto con el fondo del escritorio.

    Ese problema tonto con el escritorio es que no me deja poner un fondo de escritorio, asi de simple. Me dí cuenta cuando al cargar mi tema personalizado lo cargaba todo menos el fondo que se quedaba de color plano. El caso es que para poner un fondo se usa el comando Esetroot (también está bsetbg pero depende del primero) así que trasladé el comando que se usa en el "style" a un terminal para ver que error me daba:

    root@mkstation membris # Esetroot -c /home/membris/.fluxbox/backgrounds/darklight.jpg
    Esetroot: Unable to load image file "/home/membris/.fluxbox/backgrounds/darklight.jpg".

    Como usuario normal también me da ese mismo error. Y es curioso porque he probado con otras imágenes que tengo por aquí. Tengo instalado libjpeg correctamente y no tengo ni idea de porqué puede ser. Al parecer este comando forma parte del paquete Eterm (casualmente el terminal que uso) y dicho terminal tampoco me obedece cuando le quiero poner un fondo a la consola o ponerlo transparente… estoy desconcertado!



  • 4

    Todavía me queda buscar por ahi como se hace para que detecte la grabadora como tal (era algo de añadir una línea al lilo y de activar la emulación scsi pero no recuerdo exactamente) y solucionar un problema tonto con el fondo del escritorio.

    para esto tienes que añadir, por ejemplo, esto:

    append="hdc=ide-scsi hdd=ide-scsi"
    
    ```Ejecutas lilo, reinicias y si tienes el modulo cargado (ide-scsi) te las emulará sin problemas.


  • 5

    Pues yo no tengo eso en módulo, o sea, tengo lo de IDE-SCSI compilado al kernel, y no pongo esa línea al LiLo (almenos no la he puesto yo :D) y me rula sin problemas… Salu2



  • 6

    Yo igual ELFO, tengo las opciones de emulacion SCSI compiladas como modulos, y puedo grabar con el k3b sin problemas, sin cambiar nada en el arranque, tan solo con cargar lso modulos:
    ide-scsi
    sg
    sr_mod
    scsi_mod

    Un saludo.



  • 7

    Buenas, como has dejado la variable USE ???

    Esque no se como dejarla finalmente, de momento la dejare por defecto (LiveCD Athlon XP) i ya veremos mas adelante como va.

    Salu2!



  • 8

    Por si te sirve de algo, esta es mi actual variable USE, aunque cambia por dias segun descubro nuevas cosas:
    USE="X kde qt cups usb -gnome -gtk -gtk2 truetype oggvorbis -doc -debug nls opengl -ldap mozilla -mozcalendar -moznoirc -moznomail -postgres alsa"

    Lo mejor es cada vez que quieras instalar un programa, hacer un "emerge -pv paquete" para ver que opciones soporta, y asi poco a poco vas personalizando tu variable.

    Los CFLAGS los tengo asi para mi AMD XP2400+:
    CHOST="i686-pc-linux-gnu"
    CFLAGS="-march=athlon-mp -O2 -pipe -fomit-frame-pointer -ffast-math"
    CXXFLAGS="-march=athlon-mp -O3 -pipe -fomit-frame-pointer -ffast-math"

    Asi optimizo con -O2 los programas escritos en C, y con -O3 los escritos en C++.

    Saludos.



  • 9

    me puedes explicar un poco mejor como va esto de las optimizaciones en C i C++, pq uno 02 i el otro 03

    i las otras unciones: "-fomit-frame-pointer" y "-ffast-math"

    Gracias.

    EDITADO: Tambien tengo otro problema…bueno, no pasa nada, pero me moskea, al iniciar se monta el /dev/hda1 en /boot, y luego se desmonta solito... que hago mal?```
    /boot line for /etc/fstab

    /dev/hda1 /boot ext2 noauto,noatime 1 2



  • 10

    Pues tienes bastante bien explicado y en castellano el tema del "menos o dos" -O2 y "menos o tres" -O3 (no cerodos o cerotres ;) ) en este hilo el foro de gentoo :
    http://forums.gentoo.org/viewtopic.php?t=107462
    Por supuesto, imprescindible leerse el documento http://www.gentoo.org/doc/en/use-howto.xml para entender un poco la variable USE.

    En cuanto al boot, no haces nada mal, hace justo lo que se supone que debe de hacer. Es decir, solo estar montada en el arranque y luego desmontarse.

    Se hace por doble seguridad:
    -Para evitar corrupciones en el arranque: Si no esta montada, no se puede corromper en caso de fallo, por ejemplo, del suministro electrico.
    -Para evitar que un usuario "malintencionado" cambie nada y asi ponga en peligro el arranque de la maquina. Si no esta montada no lo puede hacer.

    Aunque yo no soy partidario de la particon boot, no porque sea mala, sino porque si tienes un sistema de ficheros con journaling (ReiserFS,Ext3,…) y no estas en entorno empresarial o de servidores ( vamos si lo usas "pa tu casa") es mas comodo (pero menos seguro) no usar un punto de montaje a parte para el boot. Yo personalmente nunca lo he usado, ni siquiera para mi server publico de internet, pero mas que nada por pereza.

    Un saludo.



  • 11

    Ok entendido, si necesito poner otro kernel o algo, tendre k montar la particion i yasta.

    Sobre las optimizaciones, bueno ya lo hare cuando tenga el sistema listo, ya se que es una contradiccion alomejor, pero me kiero esperar a poderlo gozar un poco, aun no esta todo instalado.

    Ya esta el sistema en si, i los ALSA rulando perfectamente…

    Ahora esta liado con el KDE i sus miles de programas k trae, jeje

    Una cosa que no me quedo clara es que cuando segui la guia para instalar ALSA, al recompilar el kernel para quitar los modulos de sonido que no usaria, no copia la nueva imagen en la particion boot.

    Es mas, en la carpeta ...../arch/i386/boot/ no hay el "bzImage" del kernel, donde esta el "nuevo" kernel?

    Aun no he reseteado desde entonces, los ALSA funcionan de muerte, pero no se si realmente funcionara al reiniciar, el "viejo" kerne tiene mas modulos puestos, pero claro, eske no se como funciona...si no los cargas no se activan? o como va?

    Salu2!



  • 12

    Por cierto…

    KDM o GDM? o XDM?

    Cual es mejor, mas bonito, etc?

    Salu2!



  • 13

    Despues del

    make dep && make clean && make bzImage && make modules && make modules_install

    tienes que montar la particion /boot y copiar en ella la nueva imagen:

    mount /boot

    cd /boot

    cp bzImage bzImage.vieja (por si las moscas)

    añade en el gestor de arraque que uses una linea para poder arrancar con bzImage.vieja (por si las moscas)

    cp /usr/src/linux/arch/i386/boot/bzImage /boot

    umount /boot

    Aunque yo lo tengo precisamente al reves. Tengo un bzImage.XXXX (el bueno) y una entrada para él y para el bzImage a secas en el grub.conf, asi cada vez que recompilo no me toca renombrar.

    En cuanto a los de las optimizaciones, no te esperes. ten en cuenta que todo lo que te vallas a instalar ahora si no las tienes, no estara optimizado.

    Si realmente "lo quieres disfrutar" es precisamente por las optimizaciones por las que debes de empezar!!! (Rima y todo ;) )

    En cuanto al ALSA, que suerte tienes, a mi no me ha gustado nada. Se escucha bastante peor que lso emu10k1 oficiales, al menos en mi SB live 5.1, asi es que he vuelto a la ultiam version de los OSS.

    Saludos.



  • 14

    Bueno las optimizaciones ya lo hare, prefiero tenerlo todo ok durante un tiempo i como tengo k cambiar disco duro (poner el Linux en el RAID) pues ya lo hare en su momento, jeje.

    Sobre lo del kernel, es eso lo que hago yo tambien, pero al volverlo a compilar no esta otra vez el bxImage en la carpeta …./arch/i386/boot/ asi que

    Te pongo lo del manual del ALSA en Gentoo:```
    Code listing 2.1: Kernel configuration

    cd /usr/src/linux

    cp .config ~/

    make mrproper

    cp ~/.config .

    make menuconfig

    Now select Sound Card Support as Module (M) and deselect all other sound drivers. Exit and say Y to save your kernel configuration. After that, build the modules:

    Code listing 2.2: Kernel compilation

    make dep clean

    make modules modules_install

    
    Alomejor es ese "mrproper" que la lia, jeje, no se para k sirve...


  • 15

    El MrProper es una broma de los creadores del kernel. La regla MrProprer (Don Limpio para los amigos) es para borrar todos los objetos creados al compliar el kernel: los temporales, lis binarios, los modulos las configuraciones… incluso el propio kernel. Vamos, como un "make clean" pero con una limpieza mas a fondo (de ahi que le den el nombre delconocido prducto de limpieza :D) Si has hecho un "make mrproper" es logico que no te aparezca el bzImage, pues lo has borrado al ejecutar esa regla. Necesitaras volver a recompilarlo, para ello usa el ".config" que salvastes en uno de los pasos de la instalacion de alsa que comentas.

    Sobre esto que se me habia olvidado contestar:

    Publicado originalmente por marcalj
    Por cierto…
    KDM o GDM? o XDM?
    Cual es mejor, mas bonito, etc?
    Salu2!

    XDM es el mas cutre y basico, ademas de ser el servicio lanzador de los otros 2.
    KDM se integra en KDE, es decir, lo puedes manejar y configurar desde kde, y tiene el aspecto de éste.
    GDM e slo mismo pero para GNOME.

    logicamnete KDM y GDM son mucho ams "bonitos" que el XDM.

    Edita /etc/rc.conf para que ponga DISPLAYMANAGER="kdm" (o GDM si usas GNOME)
    Luego haz un
    #rc-update add xdm default
    para que se cargue al inicio la proxima vez que reinicies.

    puesto que estamos en linux y eso de reiniciar es cosa de los "windowseros" ,si no quires esperar a verlo en funcionamiento ejecuta

    /etc/init.d/xdm start

    Es posible que cada vez que entres en un terminal despues de haber activado el login grafico, veas el prompt del bash mal, para volver a tenerlo como siempre, basta con añadir
    "source /etc/profile" al archivo ~/.bashrc

    Saludos.

    PD:gentoo rulezzzzz



  • 16

    Buenas, os hablo da desde KDE…

    He hecho lo del KDM, pero me inicia uno, supuestamente KDM realmente feo, como el lilo en default, como lo tengo ahora :vayatela: ...

    Me keria instalar el mozilla firebird, el cabron se ha estado 50 minutos compilando i no hay binario para ejecutarlo...necesito el mozilla? no lo ha instalado...

    I mas cosas, bueno, primero kiero tener tiempo para trastear, que esto de estar liado con esto mientras toy de examenes es malo, jeje.

    Gracias por todo.

    PD: una cosa que me preocupa es que no puedo autentificarme como root desde KDE...cuando me pide la confirmacion i tal, me deniega el acceso, i con el comando "su" en consola igual... ni en modo consola tipo ctrl+alt+f1, no me deja...pero haciendo login si...k raro, no?

    Salu2!



  • 17

    PD: una cosa que me preocupa es que no puedo autentificarme como root desde KDE…cuando me pide la confirmacion i tal, me deniega el acceso, i con el comando "su" en consola igual... ni en modo consola tipo ctrl+alt+f1, no me deja...pero haciendo login si...k raro, no?

    No se como esta configurado en gentoo, pero en los *BSD hay tradición de hacer un grupo de usuarios llamado wheel, y sólo los usuarios que pernezcan a ese grupo podrán hacerse root mediante su.
    Mirate tu /etc/group a ver si existe el grupo wheel, si existe, probablemente será eso; añade tu usuario a ese grupo y prueba a ver.



  • 18

    Con lo que te a dicho josefu tiene que funcionar.Yo tube el mismo problema:p link



  • 19

    jeje gracias, yasta solucionado!! a ver si me pasan mas cosas raras…

    El Firebird aun no hay forma de ejecutarlo... he instalado el mozilla i no veo nada para ejecutar el Firebird...





Has perdido la conexión. Reconectando a Hardlimit.