Problemas para controlar el volumen en Gnome


  • Veteranos HL

    Holas!. Hace ya alguna semanita que intento quedarme fijo en una distro y esta es Debian Sarge, aunque la voy actualizando con repositorios Sid. Con el hardware me pierdo un poco, porque en Mandrake las cosas se hacían más a lo Windows, aunque también fallaban más a lo Windows xD.

    Uno de los problemillas que tengo ahora es con el applet de control de volumen de Gnome 2.6. Al moverlo se vuelve otra vez a poner en silencio como si tuviera muelle. He intentado abr¡r el 'Control de volumen' con el botón derecho del ratón y me dice 'No se han encontrado elementos y/o dispositivos de mezclador.'. Lo raro es que debe existir y no lo encuntra o algo así, porque he abierto el Kmix (si, Kmix en Gnome) y parece ir bién, aunque ya he eliminado cualquier vestigio de KDE. El sonido va perfecto y puedo controlar el volumen con la barra de volumen de Totem y XMMS (configurado con el plug-in de esound, porque con OSS y Alsa no va).

    Salu2 y gracias!.



  • ¿Qué driver de sonido has compilado en el kernel y que versión del kernel estás utilizando? Porque puede que ese applet sea para un driver específico y al no tenerlo te diga eso… Salu2


  • Veteranos HL

    Ahora no estoy en mi ordenador. El kernel no lo compilé yo, es el que me ha puesto Sarge, un 2.4.x. En cuanto al sonido creo que utiliza driver Alsa. De todos modos ayer al arrancar vi que daba algún error, aunque no se como pararlo para ver el error correctamente o donde se guarda el log de arranque (tampoco he buscado). Esta noche seguiré probando, ya que ayer por fín conseguí hacer funcionar mi multifunción como impresora y escaner y ahora toca el sonido. Con esto e instalando la aceleración 3D ya tendría todo lo referente al hardware perfecto :).

    Salu2!.



  • Para ver los mensajes de inicio teclea:

    dmesg


  • Veteranos HL

    @DaViD0123456789:

    Para ver los mensajes de inicio teclea:

    dmesg

    Gracias!, si es que Linux es la pera ;).

    Antes de saber este comando pude ver a la velocidad del rayo un problema con Alsa. Quité los paquetes para reinstalarlos de nuevo y al instalarlos esta es la salida de Synaptic:

    Configurando alsa-base (1.0.6a-3) ...
    depmod: *** Unresolved symbols in /lib/modules/2.4.26-1-386/alsa/snd-pdaudiocf.o
    depmod: *** Unresolved symbols in /lib/modules/2.4.26-1-386/alsa/snd-vx-cs.o
    
    Configurando alsa-modules-2.4.26-1-386 (1.0.5a+1) ....
    depmod: *** Unresolved symbols in /lib/modules/2.4.26-1-386/alsa/snd-pdaudiocf.o
    depmod: *** Unresolved symbols in /lib/modules/2.4.26-1-386/alsa/snd-vx-cs.o
    No configuration file found for ALSA 1.0.
    

    No se si va a ser un problema de configuración del Kernel o que. Además nunca llego a desinstalar el alsa-modules.

    Salu2!.


  • Veteranos HL

    Bueno, que sepais que el sonido brilla ahora por su ausencia :rabieta:. Bueno, no del todo, ya que hay un sonidillo que recuerda a las señales que recibían del espacio en Contact xD.

    Bueno, parece que con dmesg no salen los mensajes de error de Alsa al inicio, pero podría asegurar al 99% que el problema está ahí, aunque no se por donde meterle mano :llorar:.

    Salu2!.



  • Si quieres un kernel precompilado donde es casi seguro que todo funcionará, instala el 2.6.8 que hay en sarge. Yo lo he instalado en algunas máquinas por falta de ganas de recompilar y todo funcionaba.
    apt-get install kernel-image-2.6.8-1-686
    y sigue las instrucciones que te dice: añadir una línea al lilo en la sección del kernel correspondiente y añadir otra línea al archivo /etc/kernel-img.conf (no existe, crealo)
    Luego añades tu usuario al grupo 'audio', ejecutas 'alsaconf' y a correr.
    Luego si no te funcionan las X's, seguramente será porque no se ha cargado el módulo para el puerto PS/2; ejecuta 'modconf' y elige el modulo (creo que estaba en la sección input) para que se carge en cada arranque y ya debería funcionar todo.


  • Veteranos HL

    Pués parece la mejor opción en un principio. Lo malo es que uso Grub (viene por defecto), pero siempre puedo "migrarlo" ;).

    Salu2!.

    Editado: Ya he migrado a LILO. De todos modos pensaba hacerlo algún día, porque con este me manejo para poder recuperar el arranque. Eso si, me da a elegir entre cuatro pantallas para el arranque gráfico y he elegido la de Debian, ¡que cosa más fea! :risitas:. Ya lo cambiaré más adelante.


  • Veteranos HL

    Ok, he instalado el Kernel 2.6.8-1-686 sin el más mínimo problema. Al ejecutar alsaconf me detecta el chip de sonido y dice que va guardar los cambios en los correspondientes archivos de configuración, inicializar y poner los volúmenes por defecto del mezclador. Esta es la salida que me da:

    Loading driver...
    Starting ALSA.../etc/init.d/alsa: Error: alsactl restore failed with message 'alsactl: load_state:1134: No soundcards found...'.
    done.
    Setting default volumes...
    Saving the mixer setup used for this in /var/lib/alsa/asound.state.
    /usr/sbin/alsactl: save_state:1061: No soundcards found...
    
    ===============================================================================
    
     Now ALSA is ready to use.
     For adjustment of volumes, use your favorite mixer.
    
     Have a lot of fun!
    

    Así que me la detecta primero y luego dice que no la encuentra :o. Por si acaso he probado el sonido en Windows y todo perfecto.


  • Veteranos HL

    Pués probando cosas al final me cargué el Gnome y luego las X (es que no me puedo estar quieto xD). Esta mañana antes de irme a currar le he hecho un apt-get dist-upgrade y me he ido. Cuando he vuelto para comer me arrancaban las X pero el Gnome seguía sin ir (cargaba pero le faltaba el panel y otras cosas). Total, como sabía lo que le faltaba más o menos se lo he instalado con apt-get. Todo funcionando bién, y como ahora no había ningún controlador de sonido he instalado alsa de nuevo, alsaconf al canto y… funciona!!!. Ahora solo faltaba reinstalar el applet de control de volumen de Gnome. Lo reinstalé y control de volumen listo funcionando como debería haber sido.

    Para mi que todo era por un conflicto de paquetes, algo donde debí meter la pata. Por lo menos he aprendido algo más sobre Debian, tengo LILO en vez de Grub, un Kernel 2.6.8 y definitavamente mi Debian Sarge ya es Sid. Ahora a comprobar que todo lo demás funcione.

    Saludos y gracias!.


Accede para responder
 

Has perdido la conexión. Reconectando a Hardlimit.