Error HIMEM.sys al instalar W98SE


  • 0

    Buenas, al hacer la instalacion de win98se en un portatil, cuando completa la copia de datos y reinicia por 1º vez, me da un error de "himem.sys falta o esta corrupto", la cosa es que he probado con 2 versiones de win98, 2 discos duros distintos, he copiado el himem.sys de varios ordenadores con wl mismo win98se y otras versiones y aun asi me sigue dando el mismo error. El portatil es un Compaq Presario 1400 y viene por defecto con winmillennium y le he instalado con exito win2k y varias distribuciones de linux. No se me ocurre nada mas que hacer ¿Es posible que el mismo portatil no deje instalar win98?
    Saludos.



  • 1

    Te recomiendo hacer tres cosillas: la primera es hacer un clear CMOS; en mi compaq armada 1750 me soluciono infinidad de problemas de todo tipo y con todos los sistemas operativos conocidos por el hombre. Por otra parte si vas a instalar windows 98 te recomiendo que uses el sistema de archivos FAT32 y no FAT16. Por ultimo y no por eso menos importante estaria bien que le pasaras el memtest (el de microsoft y el x86 para asegurarse). La verdad es que dudo muchisimo que Compaq haya capado el portatil de forma que no se pueda instalar win98 porque winme es identico en funcionamiento interno y como has dicho este si corria bien.

    Suerte.



  • 2

    Buenas. ¿Con clear CMOS te refieres a resetear la bios?¿Como lo hago en un portatil? El sistema de archivos es FAT32, pero con el partition magic me daba error de bad filesystem type. Lo del memtest parece mas prometedor. Muchas gracias por responder y un saludo.



  • 3

    Si, resetear la bios. En mi portatil pulsando FN + F11 repetidas veces justo al encenderlo se resetea. Luego te dira que si quieres guardar los cambios y le tienes que decir que si. Eso que te dice el partition magic de bad filesystem type podria ser la causa. Prueba a deshacer la particion con el fdisk y luego a rehacerla con la misma utilidad. Despues le haces un formateo normal (no rapido). Si el partition magic te sigue dando el mismo error prueba con una utilidad de SeaGate llamada "noseque" Starter, que consiste en hacer ceros en toda la unidad incluida la tabla de particiones, el sector de arranque, etc… es como un formateo a bajo nivel, pero sin ser agresivo en abosluto para la integridad logica ni fisica de la unidad. Si despues de esto te sigue dando el mismo error con el pmagic ya debe ser cosa de la controladora o probablemente de la memoria ram. Dices que has usado dos discos duros y me reulta extraño pensar que los dos estan estropeados, pero no pierdes nada por probar.

    De todas formas tiene pinta de ser la memoria RAM.

    Suerte.



  • 4

    Me temo que la memoria tampoco va a ser. Tenia por ahi unos modulos de memoria viejos (32mb, 64mb y 128mb) los cuales he probado con el mismo resultado. El error en concreto es el siguiente:

    ERROR: no se puede controlar linea A20
    No se instalo el controlador XMS

    y mas abajo pone

    No se encuentra HIMEM.SYS
    asegurese de que el archivo esta en el directorio windows

    Probare con lo de resetear la bios.
    Un saludo.



  • 5

    Que raro. ¿Has comprado que el archivo himem.sys se encuentre en el directorio Windows? En ultima instancia podrias bajarte la version de Windows 98 SE que hay en el e-Mule (si es que no lo has probado ya). ¿En que directorio y particion instalas Windows?

    La verdad es que no se me ocurre nada mas :nono:



  • 6

    Pues si que estaba, y no solo eso, esque he probado a bajarle el himem.sys de internet y meterle de otro ordenador que tengo en casa y nada. Tambien he probado lo del otro windows. Lo he intentado instalar en las particiones c:, d: y e:. Lo de formatear la bios no funciona, he intentado con los paremetros por defecto pero sigue igual. Le he pasado el diagnostico de sistema de compaq y me sale todo perfecto. A mi tampoco se me ocurre nada mas que probar. :rolleyes:
    Saludos y gracias.





Has perdido la conexión. Reconectando a Hardlimit.