Prueba y compara el rendimiento de tu PC con nuestro banco de pruebas.

KB896256\. ¿Error de Windows ó defecto fabricación X2?



  • No he encontrado nada en el foro sobre la desincronía entre procesadores que sufrimos los que usamos un AMD X2 con Windows XP 32/64.

    Por lo que he leído, tras unas horas encendido el PC y con algunos programas/juegos que requieren un uso intensivo de CPU se prooduce una ralentización y repentina aceleración del sistema.

    En el foro de AMD:
    Dual-core Issues

    Microsoft saca este parche:
    http://support.microsoft.com/?id=896256

    Hay bastantes personas que están teniendo problemas de aceleración/ralentización repentina de juegos y he podido leer que se ha centrado la discusión en si la cagada es de MS o es de AMD. No parece que la placa, la memoria, los drivers ni la gráfica base tenga relación con este asunto, lo único que se sabe es que muchos usuarios de AMD X2 que tienen su equipo durante horas encendido sufren este problema y que por ahora no hay solución.

    Yo lo he notado en un protector de pantalla OpenGL que de repente va a saltitos y de repente va a toda leche.

    ¿De verdad que a nadie en este foro le ocurre esto?



  • si a mi me ocurre y a otro chaval tambien pregunto, pero vasta con darla al juego la afinidad a uno de los cores
    saliudos


  • Admin honoris causa

    yo he notado algo parecido con el NFSMW, pero lo achacaba a la cantidad de mierda que tiene mi windows, a ver si formateo y vuelvo a probarlo



  • Yo he reinstalado pensando lo mismo que tu y no veas qué cara se me quedó cuando me ocurrió lo mismo con el equipo limpito …...
    No tiene muy buena pinta, encima esa actualización de MS que cito está disponible en Inglés pero si la quieres en Español tienes que llamar a MS. Llamé y me han dicho que como mi Windows es OEM (y gracias.....) que el soporte me lo tenía que dar el Fabricante y que si quería el parche ...... 99€.
    Sin palabras.


  • Admin honoris causa

    mañana si me acuerdo llamaré desde el curro a ver que me cuentan. De todos modos ahí habla de la situacion de tener ahorro de energia activado y yo tengo el C&Q desactivado



  • Yo también tengo desactivado el Cool&Quiet, no tengo el driver AMD ni el parche.
    Tampoco influye el OC, sin él mi PC hace lo mismo. El problema surge cuando dejas el PC encendido horas y en ese trancurso hay algo que use mucho la CPU (en mi caso un salvapantallas) pero con el emule todo el día encendido a mi me pasa siempre. No llega a bloquearse pero ya he visto que el Firefox le cuesta responder, que mis máquinas VMware se quedan medio lelas, una movida.
    Por ahora no han encontrado ninguna solución y lo que me extraña es que AMD dice que no hay ningún problema y MS ha sacado ese parche pero que tampoco soluciona el tema. Esto puede salir en los periódicos si se confirma un error en el diseño de los X2 (en los Pentium dual core no se da el error).
    Ave maría purísima.


  • Admin honoris causa

    Os lo he colgado ya descomprimido:

    Estimado cliente,

    A continuación, le facilito el hotfix nº 896256 para Windows XP. Tenga en cuenta que los hotfixes no tienen soporte gratuito, se instalan bajo su propia responsabilidad. En caso que pasara cualquier cosa después de la instalación, tendrá que contratar un incidente al 902-197-198.

    Le adjunto un numero de caso para facilitar la localización de su incidente en posteriores llamadas :

    Reciba un cordial saludo.

    Dpto. Técnico de Microsoft Ibérica

    KB Article Number(s): 896256
    Language: Spanish
    Platform: i386

    http://personales.ya.com/packo/HL/WindowsXP-KB896256-v3-x86-ESN.exe


  • Admin honoris causa

    sobra decir que no me responsabilizo de la utilizacion de dicho parche



  • Esto es mucho más de lo que esperaba.
    Te lo agradezco de verdad, voy a probarlo a ver si mejora algo.
    Llevo varios días leyendo sobre este tema y hay todo tipo de soluciones.

    -Desctivar C&Q, por supuesto.
    -Actualizar los drivers AMD
    -Forzar la afinidad de un programa para que se ejecute en un sólo core.
    -Desactivar la LAN PCIe de marvell (presente en muchas placas) y usar la tarjeta PCI
    -Posible problema de los drivers de Marvell v3.82
    -Desactivar el sonido en placa por un posible problema de los drivers Realtek

    En fin, que me lleva unos días probar todo esto pero nadie ha dicho "Por fin". Parece más un problema del windows que de diseño de X2 pero el problema se centra en la ejecución de algunos juegos que se ejecutan en monoprocesador y que en un ambiente de 2 procesadores no funcionan bien.

    Pakosoft, te agradezco de verdad tu ayuda.
    Instalo este parche (que no he encontrado en ningún sitio) y te cuento.

    Un saludo.



  • espero ke sea error de microsoft
    por ke para conseguir mi X2 3800+ he tenido ke viejar por tierra (es ke no tenago pa avion) desde santa cruz bolivia hasta Buenos aires Argentina…. y me cobraron 410$us en galerias jardin por ke no conosco mas.....



  • osmanv3, menudo esfuerzo amigo. No es ni comparable, pero si tengo que ir hasta Madrid (a 600Km de aquí) a comprar algo ….... ya tendría que tener muchas ganas. ¿Has hecho 1500Km (+ -) para comprar un procesador?, sólo por eso te lo hubiese mandado yo desde España. Increíble.

    Bueno,
    he probado el parche que nos ha dejado Pakosoft (gracias una vez más) y he modificado el registro tal y como dice MS aquí y se han corregido mis problemas.
    Buff, cada vez se centra más el problema:

    • Afecta principalmente a juegos y concretamente a juegos que no han sido diseñados para vivir en un sistema multiprocesador.
    • El error consiste en que los juegos obtienen velocidades de procesador distintas cuando preguntan a uno y otro core (negative delta issue). Los juegos ejecutan una instrucción ensamblador que pregunta primero a un micro qué velocidad tiene y luego al otro. Los resultados son distintos y se produce el error (principalmente el juego no carga).
    • Con juegos modernos (HL) no parece que ocurra este defecto. Con aplicaciones multi hilo no ocurre este fallo.
    • No parece un defecto de diseño en los AMD X2. Se habla de este problema desde Agosto de 2005 y nada indica que sea un defecto hardware (aunque en los Pentium dual core no hay tal problema). Esto nos deja más tranquilos a los que tenemos este micro.
    • El parche soluciona el problema en algunos juegos pero en otros no.
    • En algunos de estos se arregla forzando la ejecución del juego a 1 de los 2 micros.
    • Windows 32/64 están ambos afectados por este problema y MS está trabajando en un nuevo parche para corregir este asunto.

    Este problema de Windows va camino de convertirse en el más consultado de toda la historia de windows.

    Sigo leyendo sobre este tema pero me he quedado más tranquilo tras un par de días. El lunes mismo estaba pensando: virgencita, virgencita, que no sea un error de fabricación.



  • Pakosoft,
    mi equipo va como la seda tras instalar el parche KB896256 que nos conseguiste. Suave como recién instalado.

    Gracias de nuevo.


  • Admin honoris causa

    me alegro que lo hayas solucionado 😉



  • Buf, me alegra saber todo esto que comentais sobre el tema AMD x2 64…

    empezaba a asustarme...: instalo windows (dos veces, una en 32 bits y otra en 64... que la desinstalaré, pq me parece que es una tomadura de pelo por los comentarios que he visto por ahí...), actualizo drivers de todo todito... pongo el BF2... y venga ralentizaciones... probaremos lo que se pueda, con el parche o con lo que pillemos, si no, nos vamos a reir. No conociá la posibilidad de asignar doble o monoprocesador a diferentes tareas, cuadno llegue a casa (además del capuchinno... xD) intentaré mirar el tema este de asignar tareas... y si no parche al canto. Si el parche de packosoft ha funcionado a jorgep lo probaremos! Quizá está por ahí la solución...

    La verdad es que no soy un gran entendido (menos de lo que me gustaría serlo, la verdad... pero no hay nunca tiempo para todo) en la gran mayoría de cosas que comentais, pero es muy apreciable todo lo que haceis en este foro y como podeis ayudar a gente que tiene problemas, que de primeras parecen algo insondeable... Muchas gracias a todos!



  • Me había alegrado demasiado temprano… he probado las dos alternativas (afinidad del procesador y parchear windows) y nada de nada... que deprimente... ya no sé qué hacer, la verdad... pero bueno, a ver si encontramos la solución!

    gracias a todos!



  • Estaba pensando en comprar un ordenata con un 3800+ x2 pero…visto lo visto me lo estoy pensando...

    Veremos como termina esto...

    PD: Seguro que es culpa de mocosoft...

    ¿¿Alguien ha probado de jugar en linux?? Por ejemplo al Wolfenstein - Enemy Territory (os lo podeis de su página oficial, es gratis, online y…cojonudo!!)
    Tal vez eso esclarecería las cosas.

    Saludos! 🍺 🍺



  • En linux no ocurre este problema, almenos yo no lo tengo, solo he probado con el doom3 y los salvapantallas openGL funcionan bien, asi que va a ser que no es un problema de Amd 😛

    Pd : Esto no viene a cuento, pero si algun moderador lo lee, me gustaria saber si es posible cambiar el nick de la cuenta.



  • Pues no era el core… supongo.

    El otro día fui a cambiar el dual core por un 64 bits "normalito" (el 4000 a 2,4 ghz, aproveché que tenia problemas pensando que era un problema de compatibilidad de la CPU con windows y los juegos para, con la diferencia de precio de la CPU pillarme una tarjeta de sonido decentita, cosa que hice). Mi sorpresa ayer en instalar todo el sistema operativo nuevecito era comprobar que nada de nada... los mismos problemas de con el x2 seguian pasando ayer... Conclusión: la tarjeta gráfica? No lo veo muy normal pero también podría ser...

    Tengo todos los drivers actualizados excepto los que tengo ahora bajando de la tarjeta gráfica, que son 120 megas y se tirará rato...

    Mientras jugaba y esperaba el cuelgue he puesto el administrador de tareas de windows para ver qué tal... rendimiento al 100% durante... 50 segundos seguidos? y el archivo de paginación en 1,4 gb... con tanto material para procesar no me extraña que empiece a dar saltos. Pienso que alomejor en los dual core se ven más los saltos porque uno de los procesadores puede "aburrirse" o recuperar un poco eltiempo perdido del otro...

    Mañana iré a cambiar la tarjeta gráfica, y si no era problema de esta, es decir, que sigue pasando lo mismo... pues no se, tiro el juego por la ventana o algo así 😛

    Hasta la vista, espero que no tengais muchos problemillas! 😉



  • Pues mira que es raro. Un formateo que tal?



  • @Nightwalker:

    Pues mira que es raro. Un formateo que tal?

    ya está formateado ya… todo de cero..., sólo he instalado drivers y el firefox 😛 yo no se el resto de gente qué tal lo tiene pero bueno...


Accede para responder