Ayuda Instalación Freeswitch-Fusionpbx


  • 0

    :verguen:
    Hola , encantado de conoceros.
    Buscando en la web dí con esto, ví varias guías y manuales sobre linux, raspberry etc., interesante.
    Escribo aquí desppues de buscar y buscar, por que no sé por donde tirar y a ver si alguien me puede ayudar.

    Resulta que tengo una Raspberry Pi 3, y quiero instalar Fresswitch-Fusionpbx y no veo la forma, despues de hacer muchos intentos, siguiendo guías y scripts que al final dan error.
    A ver si alguien me puede orientar o decir alguna guía.

    Yo primero lo que hago, copio la imagen Raspbian-Jessie a la sdcard, después accedo vía SSH por puerto 22. login: pi, pass: raspberry

    Y sigo la guía, pero al final da error. he visto esto:

    1- cd /usr/src

    2- sudo wget https://raw.githubusercontent.com/fusionpbx/fusionpbx- scripts/master/install/debian/install_fusionpbx.sh

    3- sudo chmod 755 install_fusionpbx.sh

    4- sudo ./install_fusionpbx.sh install-both auto

    Se empieza a instalar, pide contraseña base de datos, pero al final da error.

    He probado muchas veces con guiones parecidos pero me da error.

    Agradecería que alguien me pudiera ayudar, o decir procedimiento.

    Muchas gracias por todo. :verguen:



  • 1

    ¿Qué base de datos estás usando? En la wiki del proyecto recomiendan usar SQLite o Postgres.



  • 2

    Muchas gracias por contestarme.
    Si, utilizo la base de datos Postgresql 9.0 creo, que se instala por defecto, cuando instalo este script:

    si utilizo este script:

    Con FS 1.4.26 más antigua se instala pero no funciona cuando voy hacer prueba de llamada, es decir desde windows "Jitsi" a movil android con Csipsimple y al revés, si se registran correctamente pero no hacen llamada, previamente configurado las extensiones, en el panel de Fusionpbx vía web.

    Con la version FS 1.6.0 mas nueva no se instala, da error al final despues de pedir clave para la base datos, y también por defecto utiliza Postgresql, no sé si el script está mal…, la verdad yo no soy experto.

    Quizás con la versión más nueva se hayan corregido errores y se puedan hacer llamadas.

    He visto su blog, y hago lo que usted dice, pero no funciona.
    También le he puesto una IP fija, etc.
    Muchas gracias por su interes.
    :verguen:



  • 3

    ¿Tienes el sistema completamente actualizado (tanto el firmware como Raspbian)?



  • 4

    Si, está actualizado, yo creo que puede ser más bien de configuración en el panel web, yo lo quiero para poder hablar solo movil android a movil android.
    Hablo de la versión FS 1.4.26
    Una cosa rara es que en red local si hace llamada y suena tanto
    Win jitsi a movil como al revés, pero llamadas externas no hace llamada ni suena, registrarse si se registran bién.

    Gracias.



  • 5

    Probablemente necesitas redireccionar los puertos en el router para recibir conexiones externas. Prueba redireccionando estos rangos de puertos a la IP de tu Raspberry Pi: 5060 - 5090 para SIP tanto en TCP como UDP y 16384 - 32768 en UDP para el protocolo RTP.



  • 6

    Muchas gracias por responderme otra vez.
    He estado abriendo puertos en el router todo bién menos el intervalo 16384-32768 no me deja.
    Hablé con el soporte de Vodafone y me dijeron que ahí en ese intervalo había puertos reservados.
    No obstante le voy adjuntar imágenes de configuración básica que he intentado hacer y tambien del Router que es de Vodafone.

    Utiliza el ntpd y Postgresql.

    Antes hace tiempo con una versión creo que más pequeña se podía hacer llamadas y recibir tango PC-Win-Jitsi a movil android y al revés, y también movil a movil android con Csipsimple, (sin proveedores VoIP ni SIP), solo teniendo conexión movil 3G o lo que sea, y la configuración era mas o menos esta que le adjunto, no entiendo y funcionaba.

    Ahora con la version FS.1.4.26 no funciona, solo en local si hace llamada y recibe, no entiendo la verdad de que puede ser.

    Yo creía que con la version FS. 1.6.0 sería mas fácil por corregir más fallos.
    Pero con la 1.6.0 no se instala.
    :verguen:
    attachment_p_568508_0_ntpd-listado-puertos.jpg
    attachment_p_568508_1_router-vodafone-nat-puertos.jpg
    attachment_p_568508_2_advanced-domains.jpg
    attachment_p_568508_3_advanced-sip-profiles.jpg
    attachment_p_568508_4_advanced-variables.jpg
    attachment_p_568508_5_status-sip-status.jpg



  • 7

    Pues la verdad es que me he quedado sin ideas. Seguramente se trate de un bug porque has seguido los pasos propuestos por los mismos desarrolladores. La cuestión es si es posible solucionarlo de una forma más o menos sencillas.

    A ver si algún otro forero te puede echar una mano.



  • 8

    Muchas gracias por tú interes.
    Puede ser lo que tú dices, no sé….
    Ya te digo, en red local si funciona, pero hacia fuera no, llamadas externas no.
    Puede algún puerto, no sé, pero como saber que puerto ?

    En el rango de puertos que me pusistes (16384-32768) puede que aquí esté el problema, este rango no lo admite el router por que hay algunos que están ocupados.
    También probé a activar el DMZ pero nada, no va.

    A ver si alguien de por aquí puede hechar algo de luz o conoce algún manual, o guión o lo que sea, que aclare algo.
    Muchas gracias por todo.





Has perdido la conexión. Reconectando a Hardlimit.