No puedo montar una particion FAT, ayuda!


  • 0

    Buenas, estoy montando un server en mi casa i tengo 4 discos duros..uno hay una particion Windows i el Linux i los otros 3 son particiones FAT32.

    Al iniciar el kernel, bueno mirar…:

    VP_IDE: VIA vt8231 (rev 10) IDE UDMA100 controller on pci00:11.1
    ide0: BM-DMA at 0xd000-0xd007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xd008-0xd00f, BIOS settings: hdc:DMA, hdd:DMA
    hda: ST320011A, ATA DISK drive
    hdb: ST340810A, ATA DISK drive
    hdc: ST340810A, ATA DISK drive
    hdd: ST340810A, ATA DISK drive

    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    ide1 at 0x170-0x177,0x376 on irq 15
    hda: 39102336 sectors (20020 MB) w/2048KiB Cache, CHS=38792/16/63, UDMA(100)
    hdb: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=4865/255/63, UDMA(100)
    hdd: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=77545/16/63, UDMA(100)

    ide-floppy driver 0.99.newide
    Partition check:
    hda: hda1 hda2 hda3 hda4 < hda5 hda6 hda7 hda8 >
    hdb: hdb1
    hdd: [PTBL] [4865/255/63] hdd1

    Floppy drive(s): fd0 is unknown type 15 (usb?), fd1 is unknown type 12 (usb?)
    floppy0: no floppy controllers found
    NET4: Frame Diverter 0.46
    RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
    ide-floppy driver 0.99.newide
    md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
    md: Autodetecting RAID arrays.
    md: autorun …
    md: ... autorun DONE.

    i mas abajo

    SCSI subsystem driver Revision: 1.00
    scsi0 : SCSI host adapter emulation for IDE ATAPI devices


    Es como si me detectara un disco scsi, no?? es muy raro. Pq me detecta los 4 como IDE pero solamente mira 3....

    Tambien el el grub.conf me ponia esto:

    title Red Hat Linux (2.4.18-14)
    root (hd0,1)
    kernel /vmlinuz-2.4.18-14 ro root=LABEL=/ hdc=ide-scsi
    initrd /initrd-2.4.18-14.img
    title DOS
    rootnoverify (hd0,0)
    chainloader +1

    –------

    No se como solucionarlo.....aydarme!!!! :( :( :(

    Es un viaC3 800MHz....no se k mas añadir..

    Gacias por adelantado.



  • 1

    Hola, eso de que te los detecte con emulacion SCSI es normal, lo que necesitamos saber es que particion quieres montar, o si tienes raid.

    Para montar es asi:

    En /mnt/ debes tener el directorio donde vas a montar el volumen, por ejemplo winxp, y el comando es:

    mount -t vfat /dev/hda? /mnt/winxp por ejemplo

    • mount – comando para montar como sabras.
    • -t parametro para definir el tipo de sistema de ficheros.
    • vfat (ntfs, smbfs, ext2,...) sistema de ficheros a montar.
    • /dev directorio de dispositivos.
    • hd disco duro ide.
    • hd (a,b,c,d) las letras son para identificar primario: maestro, esclavo, y secundario: maestro, esclavo en ese orden.
    • hd(a,b,c,d)(1,2,3,4,5,....) los numeros son para identificar el numero de particion del disco.
    • /mnt/ es el directorio donde normalmente se montan los volumenes.
    • /mnt/(windows, windows2, floppy, cdrom,...) estos entre parentesis son nombre de directorios inventados por ti o que te asigna el sistema dependiendo de los distribucion en la montarias cada uno de los volumenes, disquetera, cdrom, otros discos duros......

    Si lo tienes en raid priemro has de instalar el raid, bla bla bla es igual, pero lleva algun paso mas.

    A ver si te vale.

    Saludox: Rolling.



  • 2

    Buenas tio, la cuestion es otra, yo ya se montar, puedo montar solamente 3 discos duros (hda, hdb, hdd) pero el hdc no me deja :confused:

    No tengo raid son dos ranuras ide normales i corrientes, es un ViaC3 Epia…no tiene raid ni disketera :p

    Pq es normal k me detecte Raid si no tengo? i como puedo solucionarlo?

    Buaaa :( vaya kk!! no se pq me pasa estooo....

    Salu2!



  • 3

    Ahora recuerdo otra cosa…cuando instale el Linux tenia en la eanura IDE1 tenia 2 discos duros...i en la ranura 2 tenia un lector de cd (k se corresponde al "hdc" k no me reconoce). O sea k el problema debe estar alli...ahora el CD no esta, pero me lo debe de detectar de alguna otra forma de tal manera k como no esta el CD pues nada..i k le jodan al disco duro....

    Puede ser eso? hay solucion??



  • 4

    Hola, bueno es sencillo:

    Afina el kernel un poquito que me da que lo tienes como te lo instalo la disto y luego lo recompilas, y ya que haces esto lo puedes actualizar a la ultima version estable 2.4.20, la cual puedes descargar desde ftp.kernel.org. logg: anonymous pass: anonymous. Si no sabes como hacerlo postealo que te cuento, no es muy complicado y asi aprendes ;)

    Saludox: Rolling.



  • 5

    Hola Rolling, jeje pos muchas gracias, si k estaria interesado igualmente. Bueno lo k hice es formatear i volver a instalarlo todo de nuevo pero con un CD normal….ahora ya va bien :D

    Explicame eso de recompilar el kernel i esas cosas plis! aki mismo o se abre otra rama??

    alu2 i gracias!



  • 6

    Hola pues a ver si te doy una iniciacion.

    1º Debes abrir una consola como root.
    2º Ir al directorio /usr/src/linux (aqui se deberian encontrar los fuentes del kernel si no estan descargalos de ftp.kernel.org)
    3º Hay que configurar los parametros del kernel, para ello hay varias utilidades:

    • La mas rudimentaria y menos amistosa es 'make config' la cual simplemente te va preguntando si quieres activar una opcion o no.

    • La segunda y mas amistosa es 'make menuconfig' esta te despliega un menu donde todas las opciones estan ordenadas por categorias.

    En ambas puedes seleccionar las opciones de dos formas, incluyendolas en el propio kernel (marcandolas con un '*') o como modulos (marcandolas con una 'M'), la caracteristica que tiene el añadirlas como modulos que se cargan en el momento de utilizarlas y no siempre.
    De cualquiera de estas formas debes seleccionar las opciones que quieres tener operativas y las que se coresponden con el hardware de tu maquina.

    4º El siguiente paso es 'make dep' para crear las dependencias.
    5º 'Make clean' para borrar los archivos innecesarios.
    6º 'Make bzlilo' para que las opciones activadas se cargen en el arraque del sistema.
    7º Si has activado alguna opcion como modulo debes tambien ejecutar los siguientes comandos 'make modules' y 'make module_install'.

    ¡Yata! Ojo que no te de ningun error sobretodo la hacer el bzlilo pues entonces al arrancar te dara error o no te arrancara. Esta opcion es la que mas te tardara en compilar, asi que ten paciencia.

    Suerte.

    Saludox: Rolling.





Has perdido la conexión. Reconectando a Hardlimit.