Como corregir el error de los ultimos drivers nvida para chipsets nforce2


  • 0

    ¿Soy yo o la ultima version de los drivers tiene un error?
    Al tratar de instalar los drivers NVIDIA_nforce-1.0-0248.tar.gz para mi epox8RDA+ me paso lo siguiente:
    (me ha tocado hacerlo al modo tradicional, ya que no hay paquetes para debian por problemas de licencias)

    make

    make -C nvnet
    make[1]: Entering directory /usr/src/nforce/nvnet' cc -c -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/lib/modules/2.4.19/build/include -DMODVERSIONS -include /lib/modules/2.4.19/build/include/linux/modversions.h nvnet.c cc1: Invalid option-falign-functions=4'
    make[1]: *** [nvnet.o] Error 1
    make[1]: Leaving directory `/usr/src/nforce/nvnet'
    make: *** [nvnet_make] Error 2

    He revisado la version anterior del driver, y me he dado cuenta que no es mas que un error de sinaxis, en el makefile de nvnet hay una linea que pone
    -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4
    Y en la anterior version ponia esto
    -mpreferred-stack-boundary=2 -march=i686 -malign-functions=4 \

    Para el que no se halla dado cuenta, el cambio consiste en cambiar falign por malign.

    Una vez cambiado se soluciona el probelma de la red, pero para el adudio da todavia mas problemas. Como yo tengo una creative 5.1 no me hace falta este drivers, asi es que en vez de solucionarlo he comentado todas las lineas del makefile principal que se refieren al audio y ya esta, mi tarjeta de red integrada funcionando sin problemas.

    modprobe nvnet y ya esta.

    Espero que le sea util a alguien.

    Un saludo

    PD:Si alguien sabe como solucioanr los porblemas del audio que lo postee, porque nunca se sabe cuando va a ser util.
    PD2:¿Como se pueden cometer esos errores tan tontos y tan grandes?



  • 1

    con las versiones superiores de gcc 2.95 no da problemas…gcc2.95 da fallo

    para ver el compilador que tienes..gcc -v
    Un saludo.



  • 2

    ups se me olvidaba…los ultimos ademas no son esos...NVIDIA_nforce-1.0-0256.tar.gz es el nuevo..



  • 3

    Joer, si me los baje la semana pasada, si que se dan prisa en sacar unos nuevos. Ahora mismo me los bajo para ver que tal.

    Gracias por la info.

    Un saludo.

    PD: Mi version:
    $ gcc -v
    Reading specs from /usr/lib/gcc-lib/i386-linux/2.95.4/specs
    gcc version 2.95.4 20011002 (Debian prerelease)



  • 4

    l3g0r , ¿donde puedo conseguir esos drivers?, es que por mas que miro en http://www.nvidia.com/view.asp?IO=linux los mas modernos que encuentro son los que he dicho:
    nForce Drivers
    Latest Version: 1.0-0248

    ¿Son oficiales? A ver si me dices donde bajarlos, porque me interesa leer el changes.log

    Garcias de antemano.

    Un saludo.



  • 5

    drivers :D

    cambios:
    Release Highlights for 1.0-0256:

    Added SPDIF support to audio driver
    Updated binary packages for latest releases of Red Hat Linux kernels
    Changed audio driver to be self contained source file based off i810_audio driver.
    Fixed problem with compiler arguments between gcc3.X and gcc2.X
    Changed installation script to use lowest available number when enumerating network and audio devices in modles.conf
    Added FAQ section to release notes.

    Un saludo.



  • 6

    Gracias tio, ya estan instalados, tal y como ponen "Fixed problem with compiler arguments between gcc3.X and gcc2.X" ya esta corregido el problema por el que inicie el post. Ademas ya me compila el audio, aunque de momento no lo necesite, bueno es saberlo.
    Sigo sin saber como los has encontrado, porque al ir a DownloadDrivers->Linux & BSD Drivers me sigue apareciendo los antiguos. Igual es cosa del proxy cache.

    Un saludo!!!



  • 7

    lo vi en un foro, http://www.nforcershq.com
    Dicen por hay que los de win..tambien ban a salir pronto.

    Un saludo.



  • 8

    Hablando de estos drivers. Veo que ya tienen el soporte para spdif, pero funciona el soundstorm??





Has perdido la conexión. Reconectando a Hardlimit.