Servidor FTP en 3com 812 Como???



  • Pues eso utilizo el Server U pero no soy capaz de hacer rular el servidor FTp con el firm que tengo en eestos momentos en el router que es el 2.1.2, con el antiguo 1.1.7 solo con activar el NAPT y poner la ip externa y privada me rulaba, ahora vienen separados en PAT y NAT = SuperNAT pero hago lo mismo que lo nterior y no me rula. ALguna idea???? Lo mas seguro es que este haciendo algo mal, un cablecito por favor. Asias.:p



  • mmm has porbado de meter ke direccion las peticiones de entrada al router por el puerto 80 a un PC concreto(IP)?? yo solo hice eso… peor ya hace mucho y no me acuerdo ni del menu del router xD



  • Si no tienes abierto el puerto 21 del router, y enrutado a un puerto del equipo, no te funcionara.

    Mascara



  • dioossss ke pecado me he confundido de puertos!!!!!! el 80 es web xDDD el ftp es 21 lol



  • Un error lo tiene cualquiera :p :D :D :D

    Mascara



  • Publicado originalmente por mascara
    **Si no tienes abierto el puerto 21 del router, y enrutado a un puerto del equipo, no te funcionara.

    Mascara**

    Mascara sera que abro el 21 (lo tengo abierto) y lo redirecciono a la ip del ekipo que tengo puesto el server (tb lo tengo hecho). Eso si lo tengo activado en el PAT (Port Address Translation) al lado me aparecen las casillas de TCP y UDP. Lo tengo abierto en TCP el 21 y redireccionado a 172.26.0.2 que es la ip de mi ekipo donde tengo el FTP. Pero si hago esto e intento conectarme me dice que me akueste. He probado a activar tb el NAP (Network Addres Protocol) y al activarlo me aparecen dos casillas a su lado [IP Addresses Assignment con Dynamic y Static]. Me voy a estática ya que tengo ip fija , me aparece public ip address es decir mi ip externa, la pongo y le doy a ADD. Luego en ese mismo sitio dispong de la opción de modify y delete y pulso sobre la ip que puse anteriormente y me aparece otra ventana con public y private ip address y pongo mi ip publica y privada. Luego hay que modificar el Enable Remote Sites para que todo rule y salvo los cambios pero ni asi me rula. Todo esto anterior es con el firmware 2.1.2. No se que estoy haciendo mal y la verdad es que me jode cantidad.



  • En principio, parece que lo que haces esta bien. No deberias tener problemas. De todas formas, la manera mas sencilla, es que buscases un tutorial.
    En este enlace los tienes muy completos

    A partir de aqui, intentar seguir los pasos uno a uno, a ver si es que te dejas algo por el camino.

    Mascara



  • Gracias Máscara me voy a mirar el tutorial ahora mismo, es que lo queria poner para pasarle a un colega el 2.45 de los driver de nforce para que los probara.



  • A mandar :) de ahi saque los manuales para configurar todos los routers que he configurado. Suelen estar muy bien explicados y sencillos de entender paso a paso.

    Que haya suerte.

    Mascara



  • el cliente lo tienes que conectar en pasive sino con adsl no funciona el ftp…¿curioso verdad? pero es lo que pasa con las cosas por atm...aparte configurar solamente el pat por que quieres que todo lo que llege al router por su puerto 21 lo envie al ftpsrv por el puerto 21, el nat en este caso no es necesario

    Y con eso ya estaria



  • El cliente lo conecto en passive mode DaRkSiDe, asi que no se de que puede ser por eso postee a ver si a mi se me escapaba algo pero es que no se que puede ser con el anterior firm del router el 1.1.7 activando NAPT ahora ta dividio en NAP y PAT me funciona y abriendo el puerto correspondiente, claro. No se de que pude ser no lo entiendo.:nono:



  • En ese caso y como parche temporal usa el default workstation



  • Pasate por esta pagina Yo te recomendaría que quitaras todos los filtro que pudiera llevar el router por defecto. Intenté montar un servidor Web hace unos meses y no lo logré hasta que borré un filtro que tenía puesto para el puerto 80.
    Un saludo



  • Buenas
    Una observación tonta pero que hay que tener en cuenta.
    Cuando pruevas si funciona…... lo haces desde tu propio ordenador???
    Si es así no te funcionará nunca ya que al poner tu ip publica en el CLIENTE ftp iras a parar al router solamente, no a la maquina donde debes llegar.
    Solo lo puedes probar desde fuera, desde otro equipo de internet, nunca desde tu red local.
    Supongo que a estas alturas esta aclaración parece un poco tonta, pero hay que tenerla en cuenta.
    Ya diras algo!



  • Blanqui tienees toda la razón, pero no habria ninguna manera ed probarlo desde mi propia maquina??? o desde otra que tengo en la LAN. No podria acceder desde localhost??? Es que tmpoco puedo estar llamando a gente para que lo pruebe desde fuera. Bueno gracias y saludos blanqui.:p



  • Bueno, lo puedes provar metiendo la dirección ip de la máquina donde está el servidor, pero eso no te asegura que desde fuera funcione. Si haciendolo así ya no te funciona, no es problema del router, algo tienes mal configurado en el servidor ftp.


Accede para responder
 

Has perdido la conexión. Reconectando a Hardlimit.