Xmule


  • 0

    A ver si me podeis echar una maneja, he instalado mdk9.1 y la verdad es la primera vez que me meto con un mdk, antes siempre habia estado con debian.

    A pesar de el cambio me gusta bastante esta version (aunque la slack 9.1 tiene muy buena pinta tambien :p)

    Pero bueno al tema, he intentado (y digo intentado) de todas formas instalar el jodio xmule y no lo consigo, he probado con las rpm pero no me hace nada, segun mi consola se queda instalado pero luego no tengo el xmule por ningun lado, he probado tambien a instalarlo manualmente con el tar correspondiente pero nada tampoco, me pide dependencias que tengo instaladas pero me las sigue pidiendo.

    Asi que pediria que si alguien me pudiera decir paso a paso como lo instalo en esta distro en concreto porque estoy ya desesperado (y falto de sueño) y ya puestos a pedir que me diga los nombres de los paquetes que habeis instalado vosotros a ver si es que me he confundido yo.

    Muchas gracias.



  • 1

    SATAN, ¿te has pasado de una Debian a una Mandrake? Eso es un pecado!! :D Prueba a instalar las RPMs y luego haz un locate xmule, a ver que te sale. Un saludo



  • 2

    Pues yo siempre lo instalaba por medio de un tar, creo que no hay que compilarlo ni nada, asi que lo de las dependencias… no sé, por lo menos el tar que me bajé yo no había que compilarlo, haz un "urpmi xmule" a ver si sale. De todas maneras ahora prefiero hacer el apt-get install:p

    EDITADO: por cierto, ahora cuando intento hacer algo con el apt-get, se me queda parado en [Waiting for headers] y no sale de ahi:confused: tengo las fuentes mal? o que pasa?



  • 3

    Aish bluesman… haz antes un apt-get update a ver si se te resuelve...



  • 4

    eso ya lo habia hecho antes pero se quedaba igual, en [Waiting for headers]:confused:



  • 5

    Vale, ya funciona supongo que el mirror de españa estará mal, porque he cambiado las fuentes al sitio oficial de debian y si funciona



  • 6

    SATAN, ¿te has pasado de una Debian a una Mandrake?

    Pues si, ahora el equipo lo va a usar tb mi novia bastante y no quiere ni ver debiar, prefiere algo mas sencillo, que se le va a hacer.

    Probare el locate, pero ya digo que instalo las rpm y nada de nada, no me aparece el xmule por ningun lado.



  • 7

    Bajate el apt-rpm, es la caña, y seguro que con eso te funciona, además podrás usarlo como en la debian:sisi:



  • 8

    Estoy probando otra vez, he probado con urpmi pero me da un error de dependencia de una libreria.

    Creo que son problemas con las wxwindows, a ver si consigo solucionarlo porque estoy harto ya.



  • 9

    Ah si, es que tienes que tener instalada la librería libwxgtk2.4



  • 10

    Si ahora es encontrar la jodia libreria que en el unico sitio donde la he encontrado esta caido porque no me conecta.



  • 11

    Pues nada este mandrake se quiere reir de mi, instalo el paquete me dice que se necesita la libreria libwx_gtk-2.4.so.0 pero miro en /usr/lib y la muy puta esta ahi asi que lo dejo un rato porque me estoy poniendo de mala leche.



  • 12

    A lo mejor tu versión rpm de xmule depende de una libwx_gtk-2.4 más moderna de la q traia mdk.
    Bajate la última versión de esa libreria y prueba a ver si es eso.



  • 13

    Pooooooooooooooor Fin

    Joer por fin lo he conseguido la leche, ya era personal, al final me he bajado el xmule1.4.1 y listo, la 1.6.0 me daba el error de la libreria esa que aunque estaba instalada me decia q la necesitaba asi que con la 1.4.1 perfecto, ala voy a verlo que ya tenia ganas.



  • 14

    mi problema no es al instalar emule, pq todavia no he instalado las wxwindows esas, me da un error, dice uqe me falta gtk, y no se que de gtk-config, me habal de las versiones 2….. y pone tb algo de 1.2.7 de gtk+ (mmmmm vaya lio)
    y me pongo a buscar manualmente lso paquetes pero esto no termina, meto todo loq ue tenga el nombre gtk de la instalacion de mandrake ya ver que pasa?
    alguien sabe qeue s exactamente lo qeu se necesita, o como hacer para instalar todo ya sea compilando o en rpm

    EDITADO:

    las wxwindows parece que ya estan instaladas, ahora es con el emule me da este error al compilar

    In file included from wintypes.h:44,
    from AddFriend.cpp:22:
    mfc.h:27:18: glib.h: No such file or directory
    In file included from xmuleDlg.h:41,
    from xmule.h:30,
    from AddFriend.cpp:23:
    SysTray.h:20:21: gtk/gtk.h: No such file or directory
    make[3]: *** [AddFriend.o] Error 1
    make[3]: Leaving directory /home/osfesa/xmule-1.4.3/src' make[2]: *** [all-recursive] Error 1 make[2]: Leaving directory/home/osfesa/xmule-1.4.3/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/osfesa/xmule-1.4.3'
    make: *** [all] Error 2

    pq puede ser? supongo que no sera del compilador, he metido el sistema ayer mismo, y el gcc aparte, junto con las libreiras uqe mandrake considero oportunas





Has perdido la conexión. Reconectando a Hardlimit.