ATI y linux


  • 0

    Hola a todos….

    Como me voy a comprar una tarjetilla nueva para Navidades... estoy en la duda de si irme a por Ati o a por Nvidia. Las ATI siempre me gustaron más por su 2D, pero para mi equipo actual compré una Nvidia por sus drivers para Linux.

    Ahora veo que Ati también tiene soporte para Linux, pero..... ¿cómo va realmente? ¿Alguien los ha probado? ¿Son estables, tienen buen rendimiento?

    Gracias y un saludo...



  • 1

    cascaman, mira un poquito en la siguiente rama http://www.hardlimit.com/forum/showthread.php?threadid=18205 :dormido: ; tal vez encuentres la respuesta .

    yo he probado esos drivers pero no he conseguido instalarlos del todo en mi debian, no consigo que funcionen correctamente, no puedo quitar el vesafb , ni instalar el modulo del kernel radeonfb para conseguir la aceleración por hardware. Los había utilizado antes en mandrake y te puedo asegurar que van de fábula. Venga un saludo !



  • 2

    pues yo lo tengo instaldo, y ya me funciona la acceleracion 3d. Pero en enemy territory segun en ke mapas se ve mal algunas veces.
    Ati creo que dijo ,que iban a sacar nuevos drivers para linux cada 2 meses y windows cada mes. A ver si con los nuevos drivers , que saldran pronto(creo), se arregla ese fallo.

    Un saludo.



  • 3

    l3g0r

    Si no es mucho pedir, me podrías explicar como has conseguido que te funcione la aceleración 3d. Yo he intentado de todo activando el agpgart, pero no lo he consegido, no se que más hacer. Creo que lo tengo todo bien puesto, pero nada no meva. Te pongo mi XF86Config-4.cfgpara ver si ves algo raro. Si no te importa puedes ponerme el tuyo pa que lo vea. Gracias y un Salu2!
    ( cascaman perdona por aprovecharme de tu rama pa poner mi duda :verguen: )

    Section "dri"

    Mode 0666

    EndSection

    Section "Module"

    Load "dbe" # Double buffer extension

    SubSection "extmod"

    EndSubSection

    Load "freetype"

    Load "glx" # libglx.a
    Load "dri" # libdri.a

    EndSection

    Section "Files"

    RgbPath "/usr/X11R6/lib/X11/rgb"

    FontPath "/usr/X11R6/lib/X11/fonts/local/"

    FontPath "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"

    EndSection

    Section "ServerFlags"

    EndSection

    Section "InputDevice"

    Identifier "Keyboard1"
    Driver "Keyboard"

    Option "AutoRepeat" "500 30"

    Option "XkbRules" "xfree86"
    Option "XkbModel" "pc102"
    Option "XkbLayout" "es"

    EndSection

    Section "InputDevice"

    Identifier and driver

    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Device" "/dev/psaux"

    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    HorizSync 30-71
    VertRefresh 50-160
    Option "DPMS"

    EndSection

    Section "Device"
    Identifier "Standard VGA"
    VendorName "Unknown"
    BoardName "Unknown"

    Driver "vga"

    EndSection

    === ATI device section ===

    Section "Device"
    Identifier "ATI Graphics Adapter"
    Driver "fglrx"

    Option "no_accel" "no"
    Option "no_dri" "no"

    === FireGL DDX driver module specific settings ===

    === Screen Management ===

    Option "DesktopSetup" "0x00000000"
    Option "MonitorLayout" "AUTO, AUTO"
    Option "IgnoreEDID" "off"
    Option "HSync2" "unspecified"
    Option "VRefresh2" "unspecified"
    Option "ScreenOverlap" "0"

    === TV-out Management ===

    Option "NoTV" "no"
    Option "TVStandard" "NTSC-M"
    Option "TVHSizeAdj" "0"
    Option "TVVSizeAdj" "0"
    Option "TVHPosAdj" "0"
    Option "TVVPosAdj" "0"
    Option "TVHStartAdj" "0"
    Option "TVColorAdj" "0"
    Option "GammaCorrectionI" "0x00000000"
    Option "GammaCorrectionII" "0x00000000"

    === OpenGL specific profiles/settings ===

    Option "Capabilities" "0x00000800"

    === Video Overlay for the Xv extension ===

    Option "VideoOverlay" "on"

    === OpenGL Overlay ===

    Note: When OpenGL Overlay is enabled, Video Overlay

    will be disabled automatically

    Option "OpenGLOverlay" "off"

    === Center Mode (Laptops only) ===

    Option "CenterMode" "off"

    === Pseudo Color Visuals (8-bit visuals) ===

    Option "PseudoColorVisuals" "on"

    === QBS Management ===

    Option "Stereo" "off"
    Option "StereoSyncEnable" "1"

    === FSAA Management ===

    Option "FSAAScale" "6"
    Option "FSAADisableGamma" "no"
    Option "FSAACustomizeMSPos" "yes"
    Option "FSAAMSPosX0" "0.250000"
    Option "FSAAMSPosY0" "0.416666"
    Option "FSAAMSPosX1" "0.083333"
    Option "FSAAMSPosY1" "0.083333"
    Option "FSAAMSPosX2" "0.416666"
    Option "FSAAMSPosY2" "0.750000"
    Option "FSAAMSPosX3" "0.750000"
    Option "FSAAMSPosY3" "0.916666"
    Option "FSAAMSPosX4" "0.583333"
    Option "FSAAMSPosY4" "0.250000"
    Option "FSAAMSPosX5" "0.916666"
    Option "FSAAMSPosY5" "0.583333"

    === Misc Options ===

    Option "UseFastTLS" "2"
    Option "BlockSignalsOnLock" "on"
    Option "UseInternalAGPGART" "no"
    Option "ForceGenericCPU" "no"
    BusID "PCI:1:0:0" # vendor=1002, device=514d
    Screen 0
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "ATI Graphics Adapter"
    Monitor "Monitor0"
    DefaultDepth 24
    #Option "backingstore"

    Subsection "Display"
    Depth 24
    Modes "1024x768" "800x600" "640x480"
    ViewPort 0 0 # initial origin if mode is smaller than desktop

    Virtual 1280 1024

    EndSubsection
    EndSection

    Section "ServerLayout"

    The Identifier line must be present

    Identifier "Server Layout"

    Screen "Screen0"



  • 4

    solucionado, he vuelto a instalar las x y ya rula. Gracias y Salu2!



  • 5

    cascaman, mira un poquito en la siguiente rama http://www.hardlimit.com/forum/show…?threadid=18205 ; tal vez encuentres la respuesta .

    OK. Gracias… y perdón por postear sin buscar... (mi falta de tiempo me ha jugado una mala pasada :rolleyes: )





Has perdido la conexión. Reconectando a Hardlimit.