¿¿Como configuro mi RED en Mandrake????


  • 0

    muy buenas!

    tengo un problema y seguro que alguno me lo podrá solucionar: No puedo conectarme a Internet desde Mandrake.
    Y el problema es que no sé donde configurar la Red.

    He estado mirando en el centro de configuración mandrake o algo así y ahí vienen algunos temas de configuración de la tarjeta de red, pero no encuentro dónde configurar la Puerta de Enlace (dirección del router).

    He probado agregar una nueva conexión de red, asigno el protocolo DHCP, y nada de nada.
    La tarjeta ethernet está encendida y es reconocida por el mandrake.

    Creo recordar que había algo parecido a entrar en http://localhost por algún puerto (creo que era el 10000) y ahi se podían configurar parametros. ¿NO?

    alguien sabe a qué puede ser debido? ¿tendré que instalar algún paquete? ¿tendré que levantar algún servicio?

    gracias de antemano,
    un saludo



  • 1

    Edita el archivo /etc/network/interface para poner ip mascara y puerta de enlace y /etc/resolv.conf para elegir el DNS.

    Este es el interface

    iface eth0 inet static
    address 10.0.0.10
    netmask 255.255.255.0
    gateway 10.0.0.137
    
    

    Este es el resolv.conf

    nameserver 10.0.0.137
    

    Salu2!!!



  • 2

    @zeratul_mdq:

    Edita el archivo /etc/network/interface para poner ip mascara y puerta de enlace y /etc/resolv.conf para elegir el DNS.

    El fichero /etc/resolv.conf si lo veo y lo puedo editar,pero me temo que la carpeta network (en /etc/network/) y el fichero interface no existen.
    A qué puede ser debido esto,a que la tarjeta de red no esté bien montada?

    muchas gracias zeratul_mdq por tu respuesta
    un saludo



  • 3

    Sino, usa el programa ifconfig, que viene con todas las distros.

    Salu2!!!



  • 4

    si usando ifconfig (teclea ifconfig en una ventana terminal) no te aparece un dispositivo eth0 es que probablemente no te ha detectado la tarjeta de red. En ese caso, deberias buscar cómo instalar tu tarjeta de red.



  • 5

    Wenas, aquí ando ya desesperao con Mandrake preguntándome si fué buena idea montar Linux o no.
    No hay forma de averiguar esto.

    tecleando ifconfig me salen dos dispositivos de red:
    eth0 (La tarjeta de red integrada en placa. una Marvell 10/100 blablabla)
    loopback (Una especie de tarjeta virtual)

    lo único es que durante el inicio, falla levantando yonoseké del eth0 (levantando la red)

    he probado a configurar con IFCONFIG y nada
    he instalado el WEBMIN y he configurado la tarjeta de red y nada

    Y eso que es bastante fácil. yo uso DHCP, así que supongo que sólo debería indicar que uso DHCP y cual es la dirección del router, aparte de la mascara de subred.

    Asi que no sé, hay una cosa que me mosquea, que es la dirección de multidifusión, que no se que poner ahi.
    Aparte, si le activo el DHCP me da una dirección que no es del rango correcto (el correcto es 192.168…... y la que me da es 195.255.255... o algo asi)

    Os agradezco enormemente vuestra ayuda. Seguiré intentando configurarla unos días más, sino...y muy a mi pesar, vuelta a Windows. :vayatela:

    aún así, toda ayuda es bien recibida
    un saludo



  • 6

    Para empezar con Linux y no volverse loco, es mejor andar primero con otro sistema, es decir con máquinas virtuales dentro de un ventanucos, otro HD para pruebas o cualquier equipo anticuado que consigas por ahí

    Yo la mandrake, o mandriva como se llama ahora, creo que la instalé una vez pero no me acuerdo de ella, aunque para el tema de red, todas las distros son iguales en lo básico, después que tengan una aplicación para que cambies la configuración desde la X ya es otro tema

    Como bien te dicen arriba, lo primero sería mirar en /etc/network/interface y editarlo, pero sinó aparece siempre te queda el ifconfig, donde símplemente tienes que poner la IP que quieres usar

    Por ejemplo -> ifconfig eth0 192.168.0.1 netmask 255.255.255.0

    Comprueba de paso que en resolv.conf tienes puesto algún servidor DNS válido, apareciéndote algo como -> "nameserver 80.58.0.33"

    Si con esto no funciona, comprueba poniendo "route" que la puerta de enlace por defecto (default), es la correcta, aunque si tienes activado el DHCP y bien configurado :susto:, debería darte toda esta configuración de manera automática :sisi:



  • 7

    Estas diciendo que te tira un error con la eth0, entonces, copia el /var/log/syslog aca (en realidad, la parte que nombra a la interface) y con eso seguro que podemos guiarte un poco mas.

    Salu2!!!



  • 8

    muy wenas
    antes de nada agradecer la atencion que estais mostrando con mi problema

    primero, decir que sin saber porqué, mandrake me monta las particiones de windows en modo Solo Lectura, por lo que no puedo copiar el archivo syslog desde windows a linux para postearlo aquí.

    He estado mirando el fichero, y éste se compone básicamente de una descripción detallada de los procesos que se ejecutan durante el arranque. cuando llega al proceso 'montando interfaz eth0' , muestra una especie de error en el protocolo IPV6?? algo así como un error en el protocolo de retransmisión de paquetes. Supongo que tendré que buscar este paquete e instalarlo.

    De todos modos, intentaré averiguar como montar las particiones en modo escritura para poder copiar el fichero en windows y postearlo. Y si no alguna captura con la cámara digital :rolleyes:

    weno señores,
    muchas gracias y un saludo!



  • 9

    Si son NTFS, el soporte para escritura en el kernel esta en estado de pruebas, asi que no creo que ninguna distro automaticamente te monte las particiones como RW. Pero entra en windows y usa el programa que se llama Explore2fs asi podes ver desde windows la particion de Linux y listo. Con respecto a lo de IPv6, es un error normal. Hace el comando que te dijo Fassou ifconfig eth0 192.168.0.1 netmask 255.255.255.0 y despues, tenes que levantar la interface con ifconfig eth0 up. Ya con eso tiene que salir andando.

    Salu2!!!



  • 10

    muy wenas
    usando el programa este he capturado el syslog y os lo dejo aquí a ver si alguien sabe de que puede ser este error

    Apr 29 15:43:55 ninchi network: Activando interfaz eth0: failed
    Apr 29 15:43:55 ninchi ifup: .
    Apr 29 15:43:57 ninchi ifup: .
    Apr 29 15:43:59 ninchi dhclient: No DHCPOFFERS received.
    Apr 29 15:43:59 ninchi ifplugd(eth0)[2549]: client: Determining IP information for eth0…
    Apr 29 15:43:59 ninchi ifplugd(eth0)[2549]: Program execution failed, return value is 0.
    Apr 29 15:43:59 ninchi ifplugd(eth0)[2549]: Exiting.
    Apr 29 15:43:59 ninchi ifup: .
    Apr 29 15:44:25 ninchi last message repeated 13 times
    Apr 29 15:44:27 ninchi ifup: TIMED OUT
    Apr 29 15:44:27 ninchi network: Activando interfaz ppp0: failed
    Apr 29 15:44:27 ninchi portmap: inicio de portmap succeeded

    Por lo que puedo entender, parece ser que no encuentra un servidor DHCP o algo así no?

    de ser así, lo veo raro puesto que el router lo tengo configurado con el DHCP para que asigne dinámicamente.

    Lo de ppp0 aparece desde que le dí a Agregar Nueva Conexión de Red y agregué una pppoE, para ver si así conectaba.

    bueno señores, agradezco vuestra ayuda
    un saludo



  • 11

    Bajo windows te toma los valores del DHCP? Porque ahi tenes un problema con el servidor DHCP. La estructura del DHCP es asi:

    DHCP Discover (Broadcast desde el PC)

    DHCP Offers (Paquete del servidor al PC)

    DHCP Request (Paquete del PC al servidor)

    DHCP Pack (Paquete del servidor al PC)

    O sea que esta fallando en el segundo paso, o en el primero, en caso de que no este enviando el Discover o no este llegando a ningun lado. Ahora, puede ser que sea un problema con la tarjeta, que no este soportada bajo Linux, pero eso lo veo mas dificil…. De manera manual como te indique la ultima vez tampoco te funciono?? Lo ultimo que se me ocurre, hace un lspci y fijate la info que te da de la tarjeta de red.

    Salu2!!!



  • 12

    Hace poco tuve un problema parecido en un portatil toshiba, resulta que la combinacion de la red integrada del portatil + router 3com 812 + IpV6 = Error al pillar ip por DHCP. La solución pasa por quitar el protocolo IpV6, a ver si busco el enlace donde dí con la solución y lo posteo por aqui.



  • 13

    Aqui esta, es un post en los foros de ubuntu aunque en teoria deberia ser aplicable a todas las distros

    http://www.ubuntuforums.org/showthread.php?t=87643

    Common Application Problems

    IPV6: Very few people use IPV6 (mostly just academic labs at this point), but it can cause networking problems with certain routers. I recommend disabling it by renaming the driver.

    sudo mv /lib/modules/$(uname -r)/kernel/net/ipv6/ipv6.ko /lib/modules/$(uname -r)/kernel/net/ipv6/ipv6.ko.bak
    sudo depmod -a
    


  • 14

    Buenisimo Nittaku. Todos los dias se aprende algo nuevo.

    Salu2!!!



  • 15

    wenas, os cuento.

    Primero de todo esto sigue sin rular.
    he renombrado los paquetes pertenecientes al protocolo Ipv6 para que cuando inicie no los encuentre.

    he renombrado el ipv6.ko.gz a ipv6.ko.gz.bak y además:
    ah6.ko.gz
    esp6.ko.gz
    ip6_tunnel.ko.gz
    ipcomp6.ko.gz

    Weno, el comando en sí que me puso nittaku no lo pude hacer porque fallaba o algo. Así que he utilizado solamente: mv archivo archivo.bak (de esta forma).

    No sé si será por eso por lo que no ha funcionado. Porque digo yo que el depmod ese servirá para algo y yo me lo he saltado.

    pues bien, hecho esto, el Log de arranque me sigue dando casi lo mismo

    network: Activando interfaz loopback: succeeded
    May 3 15:50:00 ninchi ifplugd(eth0)[2545]: ifplugd 0.25 initializing.
    May 3 15:50:00 ninchi ifplugd(eth0)[2545]: Using interface eth0/00:0F:EA:3A:F7:D2
    May 3 15:50:00 ninchi ifplugd(eth0)[2545]: Using detection mode: IFF_RUNNING
    May 3 15:50:00 ninchi ifplugd(eth0)[2545]: Initialization complete, link beat detected.
    May 3 15:50:00 ninchi ifplugd(eth0)[2545]: Executing '/etc/ifplugd/ifplugd.action eth0 up'.
    May 3 15:50:11 ninchi dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
    May 3 15:50:34 ninchi dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
    May 3 15:51:00 ninchi ifplugd(eth0)[2545]: Killing child.
    May 3 15:51:00 ninchi network: Activando interfaz eth0: failed
    May 3 15:51:00 ninchi ifup: .
    May 3 15:51:04 ninchi last message repeated 2 times
    May 3 15:51:06 ninchi dhclient: No DHCPOFFERS received.

    Creo que esto es problema ya de la tarjeta de red, que los drivers no van bien por lo que sea. Así que, aparte de vuestras posibles sugerencias, creo conveniente buscar un paquete de drivers bajo linux e instalarlo. no?

    a ver que pasa.
    un saludo



  • 16

    No tienes alguna otra tarjeta de red para probar? asi descartarias un error de hardware, con cualquier realtek matá deberia de funcionar bien el sistema.

    Por los logs, lo que parece es que la tarjeta no pilla DHCP…





Has perdido la conexión. Reconectando a Hardlimit.