Modulo de oscommerce


  • 0

    Bueno, lo primero es decir q de php o mysql se mas bien poco, pero me han pedido que haga una tienda online y casi la tengo hecha.

    El problem es que me he bajado un modulo para poner un pequeño "foro" en la web, y ya lo tengo instalado y todo, pero me da el siguiente error cuando voy a poner un post:

    Vaya el codigo img no esta activado, pero da igual, pinchar en el enlace y lo vereis.

    Os adjunto el modulo para q veais como esta, porque me da error en message.php

    Gracias de antemano
    attachment_t_25650_0_foro.zip



  • 1

    Pues la linea 3 del citado archivo que da el error es esta:

    if($HTTP_POST_VARS["submit"]) {

    es decir, Si se ha pasado como argumento por el metodo post la variable "submit" entonces….

    El error que te da es que en el array $HTTP_POST_VARS no se ha creado el indice submit.
    El array $HTTP_POST_VARS es una variable de entorno, no forma parte del modulo, por lo que parece que el error es del PHP, no del modulo, ya que en principio, si no se ha pasdo la variabe submit deveria devolver FALSE y no entrar en el IF, pero en lugar de eso da error. Lo siento mucho pero no te puedo ayudar mas.

    Por que no haces una cosa, en lugar de instalar modulos para el OsC., instala foros completos, como tengo hecho yo en mi web, o incluso este mismo foro ;). Asi te ahorraras quebraderos de cabeza, ganaras en prestaciones, facilidad de actualizacion, correcion de fallos de seguridad, etc.

    Un saludo.



  • 2

    Dicho y hecho Nacho :rolleyes: estoy "probando" la version 3.0.0 de vbulletin y va de vicio, q sencillo es todo :P

    Una cosa… he leido q se puede traducir al español... pero manualmente???? o hay algun modulo para traducirlo todo????

    saludos y gracias





Has perdido la conexión. Reconectando a Hardlimit.