Problemas con cookies en ASP


  • 0

    Bueno, pues sigo con mis rollos de las cookies pero ahora ya es en el curro, en donde estoy bajo ASP.

    El tema es que tengo una cookie que me guarda la fecha de la última visita a una página, y cuando entro en la página la historia es leer el contenido y actualizarla con la hora actual.

    El código es mas o menos este:

    'Recupero las fechas de ultimavisita de Informacion corporativa
    diaInforCorp=Request.Cookies("InforCorp")("diavisita")
    mesInforCorp=Request.Cookies("InforCorp")("mesvisita")
    anioInforCorp=Request.Cookies("InforCorp")("aniovisita")
    horaInforCorp=Request.Cookies("InforCorp")("horavisita")
    
    'ACTUALIZAMOS LA COOKIE CON LA FECHA DE HOY
    Response.Cookies("InforCorp")("diavisita")= dia
    Response.Cookies("InforCorp")("mesvisita")= mes
    Response.Cookies("InforCorp")("aniovisita")= anio
    Response.Cookies("InforCorp")("horavisita")= hora
    Response.Cookies("InforCorp").Expires = DateAdd("d", 1, Now)
    Response.Cookies("InforCorp").Domain = ".siemens.es"
    Response.Cookies("InforCorp").Secure = 0
    
    

    Bien, esto lo hago antes de generar nada de html , por si alguien lo pregunta.

    Pues el problema es que tras esto en diaInforCorp, mesInforCorp,etc… que debería estar el valor de la última visita, tengo el valor actual que estoy guardando justo después.

    Se que en php cuando se hace algo así el servidor lo hace de abajo a arriba por lo que tendría que primero escribir y luego leer pero no se si en ASP es igual. De cualquier forma lo he probado y nada.

    Peeeeeeeeeero, el caso es que funcionar funciona porque si desde otra página leo la cookie (sin actualizarla) me guarda el valor de la última visita perfectamente. El problema es cuando quiero actualizarla que siempre me la actualiza y luego lee de ella con lo cual no consigo recuperar el valor que tenía.

    No se si me explico. A ver si me podeis ayudar que ayter me tiré toda la mañana con esto y no consigoq ue funcione.



  • 1

    Vamos chicos. Nadie sabe algo de cookies en ASP????



  • 2

    Bueno, me autorespondo que ya se ha "solucionado".

    Resulta que ya al final dado por imposible y porque había que salir con la aplicación se ha pasado del servidor de test al real y resulta que en este funciona. ¿Porque? Ni idea, pero cuando algo funciona mejor no tocarlo xDxD.





Has perdido la conexión. Reconectando a Hardlimit.