Instalacion de Debian Sarge


  • 0

    Pues nada, he estado reorganizando mi HD y al final mi SUSE ha petado, lo cual no me importa mucho porque estaba ya quemado de no conseguir instalar la mitad de las cosas.

    Me descargué ayer Debian, pero en este caso la versión Sarge en vez de la woody, y muchisimo mejor. Por fin he conseguido arrancar las Xs con debian en mi PC con la 9600PRO.

    Ahora quiero instalar los drivers porque no me deja poner mas de 800x600 y se ve como el culo xD

    En la web de ati hay un .rpm para instalar y dice que antes hay que tener esto:
    @ATI:

    Before you install

    Make sure the following software is already installed on your system:
    glibc version 2.2 or 2.3
    XFree86 version 4.1.0, 4.2.0, or 4.3.0
    Kernel source code
    Kernel header (include) files
    GCC compiler
    Make Utility

    Bueno, me he bajado esta mañana el kernel 2.6.8 y no me ha dado tiempo a compilarlo, esta tarde termino. Entonces una vez lo compile y funcione tendré el "kenel source" en su version actual.

    Ahora, respecto al resto de cosas como se que versión tengo??? Por ejemplo, del "glibc"…... y ¿¿que es eso de "Kernel header"?? lo tendré al haberme bajado el fuente del kernel y haber podido compilar y eso???

    El GCC y make intentando ejecutar el comando sabré si los tengo instalados. Digo yo.

    Y creo que no necesito nada más. Esque los puñeteros drivers estos en SUSE fui incapaz de instalarlos y a ver si ahora lo consigo, que está mu feucho Debian a 800x600 xDxD

    Me gustaría que me dijeseis si hay que hacer algo más o si me dejo algo en el tintero.

    http://www.ati.com/support/infobase/linuxhowto-ati.html



  • 1

    Lo mio fué más curioso y más sencillo a la vez. Instalé Sarge y no me arrancaban las X. Tras mucho mirar decidi copiar los archivos de configuración que generaba una Knoppix 3.4, esto es, XF86Config y XF86Config-4. Tras esto pude arrancar las X y trabajar a 1024x768 con 100 Hz. Además de esto fuí un día a probar un juego hasta que me di cuenta que era en 3D y que mi Debian lo estaba ejecutando con aceleración. Lo que no se es si la aceleración me la añadió en Sarge con esa ñapa o cuando hice un upgrade a Sid. Mi tarjeta es una Radeon 8500LE.

    De todos modos tengo pensado meterle caña a los drivers a ver si mejoro el rendimiento, porque aunque me va exactamente igual que con Mandrake 10.0, que soporta y detecta estas tarjetas de serie, es posible que ATI haya mejorado algo los drivers, o al menos eso decían que iban a hacer.

    Salu2!.



  • 2

    Yo tengo una 9200 y funciona con aceleración 3d con la configuración del instalador de sarge.
    Vuelve a configurar las X's a ver: dpkg-reconfigure xserver-xfree86



  • 3

    @josefu:

    Yo tengo una 9200 y funciona con aceleración 3d con la configuración del instalador de sarge.
    Vuelve a configurar las X's a ver: dpkg-reconfigure xserver-xfree86

    Sí, pero el chip de esa tarjeta puede usar los drivers DRI libres y la Radeon 9600 Pro no. Para estas últimas ( y superiores ) es necesario el driver propietario de Ati, que por mucho que sigan prometiendo da tanto asco como siempre.

    3D support in Radeons

    Open source 3D acceleration is available on all Radeons up to and including the 9250 (rv280). The 7800/rv200 and below are supported by the radeon DRI driver; the 8500 through 9250 are supported by the r200 DRI driver. Both r200 and radeon DRI drivers use the radeon DRM driver.

    3D support for r300 based cards (9500 and above) is only available from ATI's binary linux driver.

    There's a project to make an opensource 3D driver for R300 / RV350 / R350 based chips (Radeon 9500 .. 9800, M10). That would be especially helpful for newer PPC Laptops with Radeon 9600.

    http://dri.sourceforge.net/cgi-bin/moin.cgi/ATIRadeon#head-a9fbb782173e9b50a28dd40210b2dda6a1d86c44



  • 4

    Sí, pero el chip de esa tarjeta puede usar los drivers DRI libres y la Radeon 9600 Pro no. Para estas últimas ( y superiores ) es necesario el driver propietario de Ati, que por mucho que sigan prometiendo da tanto asco como siempre.

    OK, no tenía ni idea. Soy nuevo en ati



  • 5

    Bueno, pues estoy atrancado con el jodio kernel.

    Me da el siguiente kernel panic:
    **
    VFS: Cannotopen root device "1642" or unknown-block(22,66)
    Please append a correct "root=" boot option
    kernel panic: VFS: Unable to mount root fs on unknown-block(22,66)**

    Bueno, he buscado en el tio google y seguún parece le da este error a medio mundo, y las razones pueden ser dos:

    1. No se ha marcado con el "*" al compilar el kernel el soporte para el tipo de ficheros de la particion ande está boot.

    2. No se ha especificado bien donde está la partición boot en el lilo.conf.

    La primera lo he revisado y tengo todo ok (eso croe), y la segunda he estado probando y no doy con el error. Os pego el lilo.conf

    XP2500:/home/oscar# more /etc/lilo.conf

    Generated by liloconfig

    This allows booting from any partition on disks with more than 1024

    cylinders.

    lba32

    Specifies the boot device

    boot=/dev/hdc

    Specifies the device that should be mounted as root.

    If the special name CURRENT is used, the root device is set to the

    device on which the root file system is currently mounted. If the root

    has been changed with -r , the respective device is used. If the

    variable ROOT is omitted, the root device setting contained in the

    kernel image is used. It can be changed with the rdev program.

    root=/dev/hdd2

    Bitmap configuration for /boot/sarge.bmp

    bitmap=/boot/sarge.bmp
    bmp-colors=1,,0,2,,0
    bmp-table=120p,173p,1,15,17
    bmp-timer=254p,432p,1,0,0

    Enables map compaction:

    Tries to merge read requests for adjacent sectors into a single

    read request. This drastically reduces load time and keeps the map

    smaller. Using COMPACT is especially recommended when booting from a

    floppy disk.

    compact

    Install the specified file as the new boot sector.

    LILO supports built in boot sectory, you only need

    to specify the type, choose one from 'text', 'menu' or 'bitmap'.

    new: install=bmp old: install=/boot/boot-bmp.b

    new: install=text old: install=/boot/boot-text.b

    new: install=menu old: install=/boot/boot-menu.b or boot.b

    default: 'menu' is default, unless you have a bitmap= line

    Note: install=bmp must be used to see the bitmap menu.

    install=menu

    install=bmp

    Specifies the number of tenths of a second LILO should

    wait before booting the first image. LILO

    doesn't wait if DELAY is omitted or if DELAY is set to zero.

    delay=20

    Prompt to use certaing image. If prompt is specified without timeout,

    boot will not take place unless you hit RETURN

    prompt
    timeout=50

    Specifies the location of the map file. If MAP is

    omitted, a file /boot/map is used.

    map=/boot/map

    Specifies the VGA text mode that should be selected when

    booting. The following values are recognized (case is ignored):

    NORMAL select normal 80x25 text mode.

    EXTENDED select 80x50 text mode. The word EXTENDED can be

    abbreviated to EXT.

    ASK stop and ask for user input (at boot time).

    <number>use the corresponding text mode. A list of available modes

    can be obtained by booting with vga=ask and pressing [Enter].

    vga=extended

    These images were automagically added. You may need to edit something.

    default = "Windows XP"

    image=/boot/vmlinuz-2.4.27-1-386
    label="Linux 2.4.27-0"
    initrd=/boot/initrd.img-2.4.27-1-386
    read-only

    image=/boot/bzImage-2.6.8
    label="Linux 2.6.8"
    initrd=/initrd.img
    root=/dev/hdd2

    read-only

    If you have another OS on this machine (say DOS),

    you can boot if by uncommenting the following lines

    (Of course, change /dev/hda2 to wherever your DOS partition is.)

    other=/dev/hdc1
    label="Windows XP"</number>



  • 6

    Mi fstab:

    XP2500:/usr/src/linux# more /etc/fstab
    # /etc/fstab: static file system information.
    #
    # <file system=""> <mount point="">   <type>  <options>       <dump>  <pass>proc            /proc           proc    defaults        0       0
    /dev/hdd2       /               ext3    defaults,errors=remount-ro 0       1
    /dev/hdd6       /home           ext3    defaults        0       2
    /dev/hdd5       none            swap    sw              0       0
    /dev/hdb        /media/cdrom0   iso9660 ro,user,noauto  0       0
    /dev/hda        /media/cdrom1   iso9660 ro,user,noauto  0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0</pass> </dump></options></type></mount></file>
    

    Y el menuconfig dentro de File System tengo:

    <*> Second extended fs support
    [ ]   Ext2 extended attributes     
    <*> Ext3 journalling file system support 
    [ ]   Ext3 extended attributes                 
    [ ] JBD (ext3) debugging support             
     <m>Reiserfs support                           
    [ ]   Enable reiserfs debug mode           
    [ ]   Stats in /proc/fs/reiserfs                 
    [ ]   ReiserFS extended attributes          
    < > JFS filesystem support</m> 
    


  • 7

    Tienes también marcado como* el modulo de tu controladora ATA???
    Si no lo tienes, lo más posible es que sea eso.



  • 8

    @josefu:

    Tienes también marcado como* el modulo de tu controladora ATA???
    Si no lo tienes, lo más posible es que sea eso.

    Eres un crack. Has dado en el clavo asique has ganado un gallifante.
    
    Ahora me da un error con el entorno gráfico, pero esta tarde intentaré arreglarlo yo solo a ver si soy capaz.


  • 9

    Bueno, pues tras mis problemas dw HW con la placa base he vuelto a ver si consigo configurar esto pero no soy capaz.

    Al arrancar me dice que no se ha podido iniciar el entorno gráfico porque hay un error en la configuración, y me dice que el log está en el archivo que os adjunto.

    Que puede pasar??

    Esque he pensado en intentar reconfigurar el entorno con….... ¿¿ dpkg-reconfigure xserver-xfree86 ?? pero me da miedo de cagarla del todo, aunque bueno, en el peor de los caso reinstalo, que total no tengo nada instalado.
    attachment_p_267549_0_xfree86.0.log.txt



  • 10

    Bueno, pues tras un tiempo con esto pendiente este finde he conseguido dejar mi debian Sarge al 90% de lo que necesito (en plan basico).

    He instalado los jodidos drivers de ATI, que no veas si dan por saco.

    He instalado firefox y thunderbird y les he puesto themes y pijaditas.
    He instalado OpenOffice, Gimp2.0, K3B, XMMS y alguna cosilla más.

    Parece que la mayoría de las cosas chutan y por una vez en mi vida me he visto que dominaba yo a linux y no el a mi xDxD

    Bueno, chorradas a parte me he topado con un par de problemillas que a ver si me podeis solucionar.

    Respecto a montar unidades de red

    oscar@XP2500:~$ more /etc/fstab
    # /etc/fstab: static file system information.
    #
    # <file system=""> <mount point="">   <type>  <options>       <dump>  <pass>proc            /proc           proc    defaults        0       0
    /dev/hdd2       /               ext3    defaults,errors=remount-ro 0       1
    /dev/hdd6       /home           ext3    defaults        0       2
    /dev/hdd5       none            swap    sw              0       0
    /dev/hdb        /media/cdrom0   iso9660 ro,user,noauto  0       0
    /dev/hda        /media/cdrom1   iso9660 ro,user,noauto  0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
    /dev/hdd1       /datos/disco_aux ntfs   auto,user,rw,exec,umask=000     0       0
    /dev/hdc1       /datos/windows  vfat    auto,user,rw,exec,umask=000     0       0
    /dev/hdc5       /datos/programas ntfs   auto,user,rw,exec,umask=000     0       0
    [color]//servidor/recursos_compartidos/Musica  /mnt/servidor_raiz      smbfs   ro,auto,user    0   0[/color]
    oscar@XP2500:~$</pass> </dump></options></type></mount></file>
    

    Este es mi fstab. En principio todo bien. Me da un error con la particion en "vfat" pero creo que es porque no tenia bien puesto en el kernel lo de este tipo de particiones (cuando reinicie ya veré).
    Pero lo que no consigo montar son los recursos de mi otro PC.
    No se que puede estar mal.

    XP2500:/home/oscar# mount -a
    mount: el tipo de sistema de ficheros vfat no está soportado por el núcleo
    mount: tipo de sistema de ficheros incorrecto, opción incorrecta, superbloque incorrecto en //servidor/recursos_compartidos/Musica,
           o número de sistemas de ficheros montados excesivo
    XP2500:/home/oscar#
    
    

    Y otra cosita respecto a la RAM
    En el Monitor de sistema me dice:
    Memoria Usada XX(la que sea en cada momento) de 883 Mb.

    Pero si tengo un giga. Porque dice 883 MB?? Y no es la libre porque por ejemplo ahora mimso usada 97,1 MB de 883 MB. Que si lo sumas tampoco llega al giga.
    attachment_p_270834_0_error.jpg



  • 11

    @vallekano:

    Y otra cosita respecto a la RAM
    En el Monitor de sistema me dice:
    Memoria Usada XX(la que sea en cada momento) de 883 Mb.

    Pero si tengo un giga. Porque dice 883 MB?? Y no es la libre porque por ejemplo ahora mimso usada 97,1 MB de 883 MB. Que si lo sumas tampoco llega al giga.

    Si no recuerdo mal, para que Linux tenga acceso al GB completo tienes que activar esa opción en la configuración del núcleo, ahora mismo no recuerdo exactamente donde. Parece ser que a cambio se produce un ligero decremento de rendimiento en el acceso a memoria.



  • 12

    No se que opción dices.

    Hay una que es para equipos con mucha memoria o algo así, pero creo que es a partir de 4 gigas.

    Y lo de la red, que me urge un poco más????



  • 13

    @vallekano:

    No se que opción dices.

    Hay una que es para equipos con mucha memoria o algo así, pero creo que es a partir de 4 gigas.

    Y lo de la red, que me urge un poco más????

    La opción que te comento es válida también para equipos con 1GB y está en

    Processor type and features -> high memory support

    Te pongo un enlace donde hablan del tema y un extracto.

    Should I enable CONFIG_HIGHMEM for my 1 GB RAM system?

    It is advised to not enable CONFIG_HIGHMEM in the kernel to utilize
    the extra 128 MB you get for your 1 GB RAM system. I/O Devices cannot
    directly address high memory from PCI space, so bounce buffers have to
    be used. Plus the virtual memory management and paging costs come with
    extra mappings. For details on bounce buffers, refer to Mel Gorman's
    documentation (link below).

    http://kerneltrap.org/node/2450?PHPSESSID=37788776ed534f5f8ccdae47ac746a88

    Sobre la red no puedo ayudarte, lo siento.



  • 14

    Muchas gracias tio, era eso, exactamente.

    Ahora a ver si alguien me echa un cable con la red.



  • 15

    Yo lo de la red ni me moleste en usar el fstab para ello, uso un programita llamado linneightborhood (creo que se pone asi) y el te detectara los recursos que tengas compartidos en tu red y te permitira montarlos cada vez que inicies y listo, yo lo tengo asi, supongo que como lo quieres hacer tambien se podra pero pase de lios.



  • 16

    Ya lo arreglé.

    Me faltaba una cosita por instalar.

    Respecto al programa ese lo probé hace tiempo en SUSE.

    Gracias de todos modos.

    Ahora con lo que me estoy peleando es con los permisos.

    Por ejemplo las particiones de windows las he montado con la opcion "rw" y con la opcion para que la monten usuarios.

    Pero resulta que todos los archivos de esas particiones aparecian con dueño "root".

    Asique he echo un chown -R de una particion entera y le puesto de dueño mi user normal y de grupo "users". Pero sigo sin tenener acceso de escritura a la carpeta.

    Y con los recursos de red lo mismo. Puedo leere pero no escribir.



  • 17

    Bueno, pues creía que lo había arreglado pero no.

    Efectivamente parece que los drivers los pilló pero no está activada la aceleración 3D.

    Esque hoy he estado mirando lo del "glxgears" que no lo conocía y la tasa de FPS es muy muy baja. Y por eso me he dado cuenta con "glxinfo" que no tengo la aceleración activada.

    Bien, he estado mirando manuales y hay un sitio (al final) que me da un error.
    Este error viene porque no tengo instalado el paquete "module-init-tools".
    Pero al instalarlo me dice:

    XP2500:/home/oscar# apt-get install module-init-tools
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias... Hecho
    Tal vez quiera ejecutar `apt-get -f install' para corregirlo:
    Los siguientes paquetes tienen dependencias incumplidas:
      xlibmesa-gl-dev: Depende: xlibmesa-gl (= 4.3.0.dfsg.1-10) pero 4.3.0.dfsg.1-8 va a ser instalado
    E: Dependencias incumplidas. Intente 'apt-get -f install' sin paquetes (o especifique una solución).
    XP2500:/home/oscar#
    
    

    Y el paquete "xlibmesa-gl" no puedo instalarlo.

    XP2500:/home/oscar# apt-get install xlibmesa-gl
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias... Hecho
    Se actualizarán los siguientes paquetes:
      xlibmesa-gl
    1 actualizados, 0 se instalarán, 0 para eliminar y 350 no actualizados.
    38 no instalados del todo o eliminados.
    Se necesita descargar 0B/275kB de archivos.
    Se utilizarán 4096B de espacio de disco adicional después de desempaquetar.
    (Leyendo la base de datos ...
    89024 ficheros y directorios instalados actualmente.)
    Preparando para reemplazar xlibmesa-gl 4.3.0.dfsg.1-8 (usando .../xlibmesa-gl_4.3.0.dfsg.1-10_i386.deb) ...
    Desempaquetando el reemplazo de xlibmesa-gl ...
    dpkg: error al procesar /var/cache/apt/archives/xlibmesa-gl_4.3.0.dfsg.1-10_i386.deb (--unpack):
     intentando sobreescribir `/usr/X11R6/lib/libGL.so.1.2', que está también en el paquete fglrx-4-3-0
    dpkg-deb: el subproceso paste fue terminado por la señal (Tubería rota)
    Se encontraron errores al procesar:
     /var/cache/apt/archives/xlibmesa-gl_4.3.0.dfsg.1-10_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    XP2500:/home/oscar#
    
    

    Con "apt-get -f install" tampoco consigo nada.

    No se, aquí se ha quedado esto medio tonto. A ver si me podeis ayudar a arreglar este lio.

    Gracias.



  • 18

    ¿Has hecho un apt-get update antes de probar a instalar los paquetes?



  • 19

    @Yorus:

    ¿Has hecho un apt-get update antes de probar a instalar los paquetes?

    Bueno, lo he echo cuando ya me daba esos errores. He echo el update y he intentado volver a instalarlo y nada, igual.





Has perdido la conexión. Reconectando a Hardlimit.