Iniciandome en LINUX


  • 0

    Hola a todos, pues bien, despues de mi nueva adquisicion de un portatil, le he echo un huequecito para ponerle linux y asi ir habituandome un poco a el, pero como es normal, tengo algunas dudillas.

    La distro que he elegido ha sido la Mandriva 2008 64bits, y la corro en un HP Intel Core 2 Duo t5270 1'5ghz con 2 gb de ram i una x3100.
    Pues bien, la instalo, le doy una particion de 40gb y el mismo se ha administrado el espacio a cada particion que necesita y tal y qual, elijo KDE, configuro todo, aunque e tenido un pequeño problema con mi wifi, al principio no me la detectava, luego me ha pedido el dvd de instalacion junto con un archivo que me he bajado (de aqui http://prdownload.berlios.de/bcm43xx/b43-fwcutter-009.tar.bz2) y entonces ya me la ha detectado, pero no me encuentra ninguna red, cuando en windows me encuentra mas de 5.

    El otro problema que tengo es que quiero cambiar el orden de arranque del GRUB y, segun google, tengo qu cambiar el parametro default del archivo /boot/grub/menu.lst, pero no me deja porque me dice que no tengo privilegios, entonces leo algo de que el maximo administrador es el root, i intento entrar como root poniendo la clave, i me dice que no puedo entrar, vuelvo a buscar en google y me dice que para entrar en modo root lo tengo que hacer atraves del modo consola, pues bien, consigo entrar al usuario root en modo consola pero entonces aqui ya me pierdo…no se como acceder al archivo, e provado a poner /boot/grub/menu.lst, pero me dice "acceso denegado"...

    Me podeis hechar un cable porfavor?

    Gracias!!;D



  • 1

    @Rules:

    El otro problema que tengo es que quiero cambiar el orden de arranque del GRUB y, segun google, tengo qu cambiar el parametro default del archivo /boot/grub/menu.lst, pero no me deja porque me dice que no tengo privilegios, entonces leo algo de que el maximo administrador es el root, i intento entrar como root poniendo la clave, i me dice que no puedo entrar, vuelvo a buscar en google y me dice que para entrar en modo root lo tengo que hacer atraves del modo consola, pues bien, consigo entrar al usuario root en modo consola pero entonces aqui ya me pierdo…no se como acceder al archivo, e provado a poner /boot/grub/menu.lst, pero me dice "acceso denegado"...

    Abres una ventana de terminal y usas el comando "su", te pedirá la contraseña de root. una vez logueado, si estás en un terminal dentro del entorno grafico (lo mas probable) escribe en el terminal "kate /boot/grub/menu.lst". Para cambiar el orden, nada mas que tienes que mover las entradas del menu.lst a tu antojo, pero asegurate de que sean completas. Te pongo un ejemplo con mi menu.lst:

    ## ## End Default Options ##
    
    title		Debian GNU/Linux, kernel 2.6.23-1-686
    root		(hd0,0)
    kernel		/vmlinuz-2.6.23-1-686 root=/dev/hda3 ro 
    initrd		/initrd.img-2.6.23-1-686
    savedefault
    
    title		Debian GNU/Linux, kernel 2.6.23-1-686 (single-user mode)
    root		(hd0,0)
    kernel		/vmlinuz-2.6.23-1-686 root=/dev/hda3 ro single
    initrd		/initrd.img-2.6.23-1-686
    savedefault
    
    ### END DEBIAN AUTOMAGIC KERNELS LIST
    
    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    title		Other operating systems:
    root
    
    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/sda1
    title		Microsoft Windows XP Professional
    root		(hd1,0)
    savedefault
    makeactive
    map		(hd0) (hd1)
    map		(hd1) (hd0)
    chainloader	+1
    
    

    Esta es parte de mi menu.lst, si quisiera poner la entrada de windows XP primero sería:

    ## ## End Default Options ##
    
    title		Microsoft Windows XP Professional
    root		(hd1,0)
    savedefault
    makeactive
    map		(hd0) (hd1)
    map		(hd1) (hd0)
    chainloader	+1
    
    title		Linux:
    root
    
    title		Debian GNU/Linux, kernel 2.6.23-1-686
    root		(hd0,0)
    kernel		/vmlinuz-2.6.23-1-686 root=/dev/hda3 ro 
    initrd		/initrd.img-2.6.23-1-686
    savedefault
    
    title		Debian GNU/Linux, kernel 2.6.23-1-686 (single-user mode)
    root		(hd0,0)
    kernel		/vmlinuz-2.6.23-1-686 root=/dev/hda3 ro single
    initrd		/initrd.img-2.6.23-1-686
    savedefault
    
    

    Respecto a la wifi, ¿estas seguro de que la detecta bien? ¿que resultado te da el comando "iwconfig" en un terminal?



  • 2

    También puedes hacer lo que te dice Google, cambias el valor default por el que corresponda a Windows (empezando por cero), pero no sería el primero en aparecer, sino el que está seleccionado (con el método de NiTTAKu sería el primero y el seleccionado).



  • 3

    Para entrar en el grub como root puedes hacerlo poniendo en consola: "sudo gedit /boot/grub/menu.lst" , entonces te pedirá la contraseña de administrador, la pones, y se te abrirá el programa gedit, que es un editor de texto para Gnome donde podrás editar el archivo.

    Lo de la red ni idea…

    Ya nos contarás a ver si sabes el archivo del grub como editarlo, es facilito.

    Saludoss

    EDITO: Vale, se me han adelantado, y además cagada mía porque tiene KDE y no gnome. Hazlo como te explica Nitakku que está bien explicado. Un saludo!



  • 4

    Pues lo de la WiFi tiene una solución muy sencilla: cambia a la versión de 32 bits. Las de 64 teinden a dar más problemas.





Has perdido la conexión. Reconectando a Hardlimit.